aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2017-03-18 02:24:38 +0800
committerthierry <thierry@FreeBSD.org>2017-03-18 02:24:38 +0800
commita3be07073c461eac6e3f0a555f1c2df389deea11 (patch)
tree9c0c06b262d9c1f1c606afb27cae35c58160d976 /textproc
parente62d358bdc9ce9985605603b71c235898bf531d9 (diff)
downloadfreebsd-ports-gnome-a3be07073c461eac6e3f0a555f1c2df389deea11.tar.gz
freebsd-ports-gnome-a3be07073c461eac6e3f0a555f1c2df389deea11.tar.zst
freebsd-ports-gnome-a3be07073c461eac6e3f0a555f1c2df389deea11.zip
Upgrade to 1.5.27.
Release notes at https://github.com/mike-fabian/ibus-typing-booster/releases
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ibus-typing-booster/Makefile2
-rw-r--r--textproc/ibus-typing-booster/distinfo6
-rw-r--r--textproc/ibus-typing-booster/files/patch-engine_hunspell__suggest.py40
-rw-r--r--textproc/ibus-typing-booster/files/patch-engine_itb__util.py67
4 files changed, 4 insertions, 111 deletions
diff --git a/textproc/ibus-typing-booster/Makefile b/textproc/ibus-typing-booster/Makefile
index 07b1870d5042..58af991b3482 100644
--- a/textproc/ibus-typing-booster/Makefile
+++ b/textproc/ibus-typing-booster/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ibus-typing-booster
-PORTVERSION= 1.5.25
+PORTVERSION= 1.5.27
CATEGORIES= textproc
MAINTAINER= thierry@FreeBSD.org
diff --git a/textproc/ibus-typing-booster/distinfo b/textproc/ibus-typing-booster/distinfo
index fd4d0e8adf5d..93fd298779f1 100644
--- a/textproc/ibus-typing-booster/distinfo
+++ b/textproc/ibus-typing-booster/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489430261
-SHA256 (mike-fabian-ibus-typing-booster-1.5.25_GH0.tar.gz) = e32acf6d757e82bd94bc18db49d36184d72f82f99f79cc7eb517e6ad5e429312
-SIZE (mike-fabian-ibus-typing-booster-1.5.25_GH0.tar.gz) = 4799666
+TIMESTAMP = 1489774308
+SHA256 (mike-fabian-ibus-typing-booster-1.5.27_GH0.tar.gz) = 29f6cfd7d42620c59f58d548ea5ebdd5073013d97f195dcb18e312cd654129fa
+SIZE (mike-fabian-ibus-typing-booster-1.5.27_GH0.tar.gz) = 4801545
diff --git a/textproc/ibus-typing-booster/files/patch-engine_hunspell__suggest.py b/textproc/ibus-typing-booster/files/patch-engine_hunspell__suggest.py
deleted file mode 100644
index 225e23bdf5b2..000000000000
--- a/textproc/ibus-typing-booster/files/patch-engine_hunspell__suggest.py
+++ /dev/null
@@ -1,40 +0,0 @@
---- engine/hunspell_suggest.py.orig 2017-03-13 08:42:29 UTC
-+++ engine/hunspell_suggest.py
-@@ -76,8 +76,9 @@ class Dictionary:
- '''
- if DEBUG_LEVEL > 0:
- sys.stderr.write("load_dictionary() ...\n")
-- (dic_path, self.words) = itb_util.get_hunspell_dictionary_wordlist(
-- self.name)
-+ (dic_path,
-+ self.encoding,
-+ self.words) = itb_util.get_hunspell_dictionary_wordlist(self.name)
- if self.words:
- # List of languages where accent insensitive matching makes sense:
- accent_languages = (
-@@ -183,6 +184,9 @@ class Hunspell:
- >>> h.suggest('Glühwürmchen')[0]
- ('Glühwürmchen', 0)
-
-+ >>> h.suggest('Alpengluhen')[0]
-+ ('Alpenglühen', 0)
-+
- >>> h.suggest('filosofictejsi')
- [('filosofičtější', 0), ('filosofičtěji', -1)]
-
-@@ -291,7 +295,9 @@ class Hunspell:
- # the result back to the internal
- # normalization form (NFD) (hunspell does the
- # right thing for Korean if the input is NFC).
-- if dictionary.pyhunspell_object.spell(input_phrase_nfc):
-+ if dictionary.pyhunspell_object.spell(
-+ input_phrase_nfc.encode(
-+ dictionary.encoding, 'replace')):
- # This is a valid word in this dictionary.
- # It might have been missed by the matching
- # above because the dictionary might not
-@@ -380,3 +386,4 @@ def main():
-
- if __name__ == "__main__":
- main()
-+
diff --git a/textproc/ibus-typing-booster/files/patch-engine_itb__util.py b/textproc/ibus-typing-booster/files/patch-engine_itb__util.py
deleted file mode 100644
index 69603f423796..000000000000
--- a/textproc/ibus-typing-booster/files/patch-engine_itb__util.py
+++ /dev/null
@@ -1,67 +0,0 @@
---- engine/itb_util.py.orig 2017-03-13 08:42:29 UTC
-+++ engine/itb_util.py
-@@ -348,11 +348,12 @@ def get_hunspell_dictionary_wordlist(lan
-
- :param language: The language of the dictionary to open
- :type language: String
-- :rtype: tuple of the form (dic_path, wordlist) where
-- dic_path is the full path of the dictionary file found
-+ :rtype: tuple of the form (dic_path, dictionary_encoding, wordlist) where
-+ dic_path is the full path of the dictionary file found,
-+ dictionary_encoding is the encoding of that dictionary file,
- and wordlist is a list of words found in that file.
- If no dictionary can be found for the requested language,
-- the return value is ('', []).
-+ the return value is ('', '', []).
- '''
- dirnames = [
- '/usr/share/hunspell',
-@@ -374,7 +375,7 @@ def get_hunspell_dictionary_wordlist(lan
- 'get_hunspell_dictionary_wordlist(): '
- + 'No file %s.dic found in %s\n'
- %(language, dirnames))
-- return ('', [])
-+ return ('', '', [])
- sys.stderr.write(
- 'get_hunspell_dictionary_wordlist(): '
- + '%s file found.\n'
-@@ -439,21 +440,21 @@ def get_hunspell_dictionary_wordlist(lan
- %(dic_path, dictionary_encoding)
- + 'giving up.\n')
- traceback.print_exc()
-- return ('', [])
-+ return ('', '', [])
- except:
- sys.stderr.write(
- 'get_hunspell_dictionary_wordlist(): '
- + 'Unexpected error loading .dic File: %s\n' %dic_path)
- traceback.print_exc()
-- return ('', [])
-+ return ('', '', [])
- except:
- sys.stderr.write(
- 'get_hunspell_dictionary_wordlist(): '
- + 'Unexpected error loading .dic File: %s\n' %dic_path)
- traceback.print_exc()
-- return ('', [])
-+ return ('', '', [])
- if not dic_buffer:
-- return ('', [])
-+ return ('', '', [])
- sys.stderr.write(
- 'get_hunspell_dictionary_wordlist(): '
- + 'Successfully loaded %s using %s encoding.\n'
-@@ -488,7 +489,7 @@ def get_hunspell_dictionary_wordlist(lan
- re.sub(r'[/\t].*', '', x.replace('\n', '')))
- for x in dic_buffer
- ]
-- return (dic_path, word_list)
-+ return (dic_path, dictionary_encoding, word_list)
-
- if __name__ == "__main__":
- import doctest
-@@ -497,3 +498,4 @@ if __name__ == "__main__":
- sys.exit(1)
- else:
- sys.exit(0)
-+