aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2008-07-23 06:37:20 +0800
committergabor <gabor@FreeBSD.org>2008-07-23 06:37:20 +0800
commitba4749065110d1f434f5bbfec24f29b448f40935 (patch)
treed0aa9e66b4e09ac73fde3b9cb9dfb394f209f09e /textproc
parent7a6d3a69de069e571747d467e534b79f5472f58a (diff)
downloadfreebsd-ports-gnome-ba4749065110d1f434f5bbfec24f29b448f40935.tar.gz
freebsd-ports-gnome-ba4749065110d1f434f5bbfec24f29b448f40935.tar.zst
freebsd-ports-gnome-ba4749065110d1f434f5bbfec24f29b448f40935.zip
DocBook is a general purpose XML schema particularly well suited to books and
papers about computer hardware and software (though it is by no means limited to these applications). The Version 5.0 release is a complete rewrite of DocBook in RELAX NG. The intent of this rewrite is to produce a schema that is true to the spirit of DocBook while simultaneously removing inconsistencies that have arisen as a natural consequence of DocBook's long, slow evolution. The Technical Committee has taken this opportunity to simplify a number of content models and tighten constraints where RELAX NG makes that possible. The Technical Committee provides the DocBook 5.0 schema in other schema languages, including W3C XML Schema and an XML DTD, but the RELAX NG Schema is now the normative schema. WWW: http://www.docbook.org/specs/docbook-5.0-spec-cd-04.html
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/docbook-500/Makefile126
-rw-r--r--textproc/docbook-500/distinfo3
-rw-r--r--textproc/docbook-500/pkg-descr16
-rw-r--r--textproc/docbook-500/pkg-plist38
5 files changed, 184 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4441629ab2ac..b57adced82a3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -102,6 +102,7 @@
SUBDIR += docbook-430
SUBDIR += docbook-440
SUBDIR += docbook-450
+ SUBDIR += docbook-500
SUBDIR += docbook-sk
SUBDIR += docbook-tdg
SUBDIR += docbook-to-man
diff --git a/textproc/docbook-500/Makefile b/textproc/docbook-500/Makefile
new file mode 100644
index 000000000000..1655caea639f
--- /dev/null
+++ b/textproc/docbook-500/Makefile
@@ -0,0 +1,126 @@
+# New ports collection makefile for: docbook-450
+# Date created: 14 Jul 2008
+# Whom: Gabor Kovesdan <gabor@kovesdan.org>
+#
+# $FreeBSD$
+
+PORTNAME= docbook
+PORTVERSION= 5.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.docbook.org/xml/5.0/
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= DocBook 5.0, designed for technical documentation
+
+RUN_DEPENDS= ${LOCALBASE}/${ISOCAT}:${PORTSDIR}/textproc/iso8879 \
+ ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+USE_ZIP= yes
+NO_BUILD= yes
+LATEST_LINK= ${PORTNAME}-500
+
+DOCBOOKDIR= share/xml/${PORTNAME}/${PORTVERSION}
+DOCSDIR= ${PREFIX}/${DOCBOOKDIR}/docs
+
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_XML= ${PREFIX}/share/xml/catalog.ports
+REGIST_CAT_FLAGS_XML= -c ${CATALOG_PORTS_XML} \
+ add nextCatalog ${DOCBOOKDIR}/catalog.xml
+UNREGIST_CAT_FLAGS_XML= -c ${CATALOG_PORTS_XML} \
+ remove nextCatalog ${DOCBOOKDIR}/catalog.xml
+
+OPTIONS= DTD "XML DTD" on \
+ SCHEMA "W3C XML Schema" on \
+ RELAX_NG "RELAX NG Schema" on \
+ SCHEMATRON "Schematron constraints" on \
+ NVDL "NVDL description" on \
+ TOOLS "Tools for working with DocBook" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DTD)
+PLIST_SUB+= DTD=""
+.else
+PLIST_SUB+= DTD="@comment "
+.endif
+.if defined(WITH_SCHEMA)
+PLIST_SUB+= SCHEMA=""
+.else
+PLIST_SUB+= SCHEMA="@comment "
+.endif
+.if defined(WITH_RELAX_NG)
+PLIST_SUB+= RELAXNG=""
+.else
+PLIST_SUB+= RELAXNG="@comment "
+.endif
+.if defined(WITH_SCHEMATRON)
+PLIST_SUB+= SCHEMATRON=""
+.else
+PLIST_SUB+= SCHEMATRON="@comment "
+.endif
+.if defined(WITH_NVDL)
+PLIST_SUB+= NVDL=""
+.else
+PLIST_SUB+= NVDL="@comment "
+.endif
+.if defined(WITH_TOOLS)
+PLIST_SUB+= TOOLS=""
+.else
+PLIST_SUB+= TOOLS="@comment "
+.endif
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS="@comment "
+.else
+PLIST_SUB+= NOPORTDOCS=""
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}
+ ${INSTALL_DATA} ${WRKSRC}/catalog.xml ${PREFIX}/${DOCBOOKDIR}
+.if defined(WITH_DTD)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/dtd
+ ${INSTALL_DATA} ${WRKSRC}/dtd/docbook.dtd ${PREFIX}/${DOCBOOKDIR}/dtd
+.endif
+.if defined(WITH_SCHEMA)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/xsd
+.for i in docbook.xsd xlink.xsd xml.xsd
+ ${INSTALL_DATA} ${WRKSRC}/xsd/${i} ${PREFIX}/${DOCBOOKDIR}/xsd
+.endfor
+.endif
+.if defined(WITH_RELAX_NG)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/rng
+.for i in docbook.rnc docbook.rng docbookxi.rnc docbookxi.rng
+ ${INSTALL_DATA} ${WRKSRC}/rng/${i} ${PREFIX}/${DOCBOOKDIR}/rng
+.endfor
+.endif
+.if defined(WITH_SCHEMATRON)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/sch
+ ${INSTALL_DATA} ${WRKSRC}/sch/docbook.sch ${PREFIX}/${DOCBOOKDIR}/sch
+.endif
+.if defined(WITH_NVDL)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/nvdl
+ ${INSTALL_DATA} ${WRKSRC}/docbook.nvdl ${PREFIX}/${DOCBOOKDIR}/nvdl
+.endif
+.if defined(WITH_TOOLS)
+ ${MKDIR} ${PREFIX}/${DOCBOOKDIR}/tools
+.for i in db4-entities.pl db4-upgrade.xsl
+ ${INSTALL_DATA} ${WRKSRC}/tools/${i} ${PREFIX}/${DOCBOOKDIR}/tools
+.endfor
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README VERSION docs/docbook-5.0-spec-cd-01.html \
+ docs/docbook-5.0-spec-cd-01.pdf docs/docbook-5.0-spec-cd-01.xml \
+ docs/howto.html docs/howto.pdf docs/howto.xml
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+ ${MKDIR} ${DOCSDIR}/images
+.for i in emacs.png oxygen1.png oxygen2.png oxygen3.png xxe.png
+ ${INSTALL_DATA} ${WRKSRC}/docs/images/${i} ${DOCSDIR}/images
+.endfor
+.endif
+
+post-install:
+ -${XMLCATMGR} ${REGIST_CAT_FLAGS_XML}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/docbook-500/distinfo b/textproc/docbook-500/distinfo
new file mode 100644
index 000000000000..87c825b36545
--- /dev/null
+++ b/textproc/docbook-500/distinfo
@@ -0,0 +1,3 @@
+MD5 (docbook-5.0.zip) = 2411c19ed4fb141f3fa3d389fae40736
+SHA256 (docbook-5.0.zip) = 3dcd65e1f5d9c0c891b3be204fa2bb418ce485d32310e1ca052e81d36623208e
+SIZE (docbook-5.0.zip) = 835797
diff --git a/textproc/docbook-500/pkg-descr b/textproc/docbook-500/pkg-descr
new file mode 100644
index 000000000000..f4aab1b81dd5
--- /dev/null
+++ b/textproc/docbook-500/pkg-descr
@@ -0,0 +1,16 @@
+DocBook is a general purpose XML schema particularly well suited to books and
+papers about computer hardware and software (though it is by no means limited
+to these applications).
+
+The Version 5.0 release is a complete rewrite of DocBook in RELAX NG.
+The intent of this rewrite is to produce a schema that is true to the spirit
+of DocBook while simultaneously removing inconsistencies that have arisen as
+a natural consequence of DocBook's long, slow evolution. The Technical
+Committee has taken this opportunity to simplify a number of content models
+and tighten constraints where RELAX NG makes that possible.
+
+The Technical Committee provides the DocBook 5.0 schema in other schema
+languages, including W3C XML Schema and an XML DTD, but the RELAX NG Schema
+is now the normative schema.
+
+WWW: http://www.docbook.org/specs/docbook-5.0-spec-cd-04.html
diff --git a/textproc/docbook-500/pkg-plist b/textproc/docbook-500/pkg-plist
new file mode 100644
index 000000000000..119d1c19148d
--- /dev/null
+++ b/textproc/docbook-500/pkg-plist
@@ -0,0 +1,38 @@
+share/xml/docbook/5.0/catalog.xml
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/ChangeLog
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/README
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/VERSION
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/docbook-5.0-spec-cd-01.html
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/docbook-5.0-spec-cd-01.pdf
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/docbook-5.0-spec-cd-01.xml
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/howto.html
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/howto.pdf
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/howto.xml
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/images/emacs.png
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/images/oxygen1.png
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/images/oxygen2.png
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/images/oxygen3.png
+%%NOPORTDOCS%%share/xml/docbook/5.0/docs/images/xxe.png
+%%NOPORTDOCS%%@dirrm share/xml/docbook/5.0/docs/images
+%%NOPORTDOCS%%@dirrm share/xml/docbook/5.0/docs
+%%DTD%%share/xml/docbook/5.0/dtd/docbook.dtd
+%%DTD%%@dirrm share/xml/docbook/5.0/dtd
+%%NVDL%%share/xml/docbook/5.0/nvdl/docbook.nvdl
+%%NVDL%%@dirrm share/xml/docbook/5.0/nvdl
+%%RELAXNG%%share/xml/docbook/5.0/rng/docbook.rnc
+%%RELAXNG%%share/xml/docbook/5.0/rng/docbook.rng
+%%RELAXNG%%share/xml/docbook/5.0/rng/docbookxi.rnc
+%%RELAXNG%%share/xml/docbook/5.0/rng/docbookxi.rng
+%%RELAXNG%%@dirrm share/xml/docbook/5.0/rng
+%%SCHEMATRON%%share/xml/docbook/5.0/sch/docbook.sch
+%%SCHEMATRON%%@dirrm share/xml/docbook/5.0/sch
+%%TOOLS%%share/xml/docbook/5.0/tools/db4-entities.pl
+%%TOOLS%%share/xml/docbook/5.0/tools/db4-upgrade.xsl
+%%TOOLS%%@dirrm share/xml/docbook/5.0/tools
+%%SCHEMA%%share/xml/docbook/5.0/xsd/docbook.xsd
+%%SCHEMA%%share/xml/docbook/5.0/xsd/xlink.xsd
+%%SCHEMA%%share/xml/docbook/5.0/xsd/xml.xsd
+%%SCHEMA%%@dirrm share/xml/docbook/5.0/xsd
+@dirrm share/xml/docbook/5.0
+@dirrmtry share/xml/docbook
+@dirrmtry share/xml