aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-14 11:53:54 +0800
committerswills <swills@FreeBSD.org>2011-08-14 11:53:54 +0800
commitc37a2807442983c26106fee15c659fa8af949256 (patch)
tree7d7eeaa693af2df973ae0758765a280be39cc235 /textproc
parente31e98b264b525a7f2a66fb2f8b4f7cc19ec71c3 (diff)
downloadfreebsd-ports-gnome-c37a2807442983c26106fee15c659fa8af949256.tar.gz
freebsd-ports-gnome-c37a2807442983c26106fee15c659fa8af949256.tar.zst
freebsd-ports-gnome-c37a2807442983c26106fee15c659fa8af949256.zip
Hailo is a fast and lightweight markov engine intended to replace AI::MegaHAL.
Hailso has a Mouse (or Moose) based core with pluggable storage, tokenizer and engine backends. Hailo is similar to MegaHAL in functionality, the main differences (with the default backends) being better scalability, drastically less memory usage, an improved tokenizer, and tidier output. With Hailo, you can create, modify, and query Hailo brains. To use Hailo in event-driven POE applications, you can use the POE::Component::Hailo wrapper. WWW: http://search.cpan.org/dist/Hailo PR: ports/159065 Submitted by: milki <milki@rescomp.berkeley.edu>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Hailo/Makefile93
-rw-r--r--textproc/p5-Hailo/distinfo2
-rw-r--r--textproc/p5-Hailo/files/patch-Makefile.PL.in14
-rw-r--r--textproc/p5-Hailo/pkg-descr12
-rw-r--r--textproc/p5-Hailo/pkg-plist26
6 files changed, 148 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dad4e352ccdd..43a8e6d26e1a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -516,6 +516,7 @@
SUBDIR += p5-HTML-Tidy
SUBDIR += p5-HTML-Tiny
SUBDIR += p5-HTML-Truncate
+ SUBDIR += p5-Hailo
SUBDIR += p5-Hash-Merge
SUBDIR += p5-Hatena-Keyword
SUBDIR += p5-IDNA-Punycode
diff --git a/textproc/p5-Hailo/Makefile b/textproc/p5-Hailo/Makefile
new file mode 100644
index 000000000000..daa6a64339a6
--- /dev/null
+++ b/textproc/p5-Hailo/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: Hailo
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hailo
+PORTVERSION= 0.69
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HINRIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= A pluggable Markov engine analogous to MegaHAL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Any-Moose>=0.13:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-Bot-Training-MegaHAL>=0:${PORTSDIR}/misc/p5-Bot-Training-MegaHAL \
+ p5-Bot-Training-StarCraft>=0:${PORTSDIR}/misc/p5-Bot-Training-StarCraft \
+ p5-Bot-Training>=0:${PORTSDIR}/misc/p5-Bot-Training \
+ p5-Class-Load>=0.06:${PORTSDIR}/devel/p5-Class-Load \
+ p5-Data-Dump>=1.17:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-Data-Section>=0.101620:${PORTSDIR}/devel/p5-Data-Section \
+ p5-Dir-Self>=0.10:${PORTSDIR}/devel/p5-Dir-Self \
+ p5-File-CountLines>=0.0.2:${PORTSDIR}/devel/p5-File-CountLines \
+ p5-Getopt-Long-Descriptive>=0.085:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+ p5-IO-Interactive>=0.0.6:${PORTSDIR}/devel/p5-IO-Interactive \
+ p5-IPC-System-Simple>=1.21:${PORTSDIR}/devel/p5-IPC-System-Simple \
+ p5-List-MoreUtils>=0.22:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-MouseX-Getopt>=0.33:${PORTSDIR}/devel/p5-MouseX-Getopt \
+ p5-MouseX-StrictConstructor>=0.02:${PORTSDIR}/devel/p5-MouseX-StrictConstructor \
+ p5-Regexp-Common>=2010010201:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Term-Sk>=0.06:${PORTSDIR}/devel/p5-Term-Sk \
+ p5-autodie>=2.08:${PORTSDIR}/devel/p5-autodie \
+ p5-namespace-clean>=0.18:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Exception>=0.29:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Expect>=0.31:${PORTSDIR}/devel/p5-Test-Expect \
+ p5-Test-Output>=0.16:${PORTSDIR}/devel/p5-Test-Output \
+ p5-Test-Script>=1.07:${PORTSDIR}/devel/p5-Test-Script \
+ p5-Test-Script-Run>=0.04:${PORTSDIR}/devel/p5-Test-Script-Run \
+ p5-Test-Synopsis>=0.06:${PORTSDIR}/devel/p5-Test-Synopsis
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN1= hailo.1
+
+MAN3= Hailo.3 \
+ Hailo::Command.3 \
+ Hailo::Engine::Default.3 \
+ Hailo::Engine::Scored.3 \
+ Hailo::Role::Arguments.3 \
+ Hailo::Role::Engine.3 \
+ Hailo::Role::Storage.3 \
+ Hailo::Role::Tokenizer.3 \
+ Hailo::Role::UI.3 \
+ Hailo::Storage.3 \
+ Hailo::Storage::MySQL.3 \
+ Hailo::Storage::PostgreSQL.3 \
+ Hailo::Storage::SQLite.3 \
+ Hailo::Storage::Schema.3 \
+ Hailo::Tokenizer::Chars.3 \
+ Hailo::Tokenizer::Words.3 \
+ Hailo::UI::ReadLine.3
+
+OPTIONS= SQLITE "Use SQLite as a database backend" On \
+ PSQL "Use PostgreSQL as database backend" Off \
+ MYSQL "Use MySQL as database backend" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SQLITE)
+RUN_DEPENDS+= p5-DBD-SQLite>=1.29:${PORTSDIR}/databases/p5-DBD-SQLite
+.endif
+
+.if !defined(WITHOUT_PSQL)
+RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-More>=0.94:${PORTSDIR}/devel/p5-Test-More
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Hailo/distinfo b/textproc/p5-Hailo/distinfo
new file mode 100644
index 000000000000..521850ebcd26
--- /dev/null
+++ b/textproc/p5-Hailo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Hailo-0.69.tar.gz) = 8694f17e9d02cbc89ec56508ef4ff1a7e329f554f29fcac884fa75f3c62ad3f5
+SIZE (Hailo-0.69.tar.gz) = 330417
diff --git a/textproc/p5-Hailo/files/patch-Makefile.PL.in b/textproc/p5-Hailo/files/patch-Makefile.PL.in
new file mode 100644
index 000000000000..41dd3b65a201
--- /dev/null
+++ b/textproc/p5-Hailo/files/patch-Makefile.PL.in
@@ -0,0 +1,14 @@
+--- Makefile.PL 2011-05-06 21:02:43.000000000 -0700
++++ Makefile.PL 2011-07-20 11:35:49.000000000 -0700
+@@ -95,3 +95,11 @@
+
+ return $inherited;
+ }
++
++sub init_PM {
++ my $self = shift;
++ $self->SUPER::init_PM(@_);
++ # Do not install the README and README.pod
++ delete $self->{PM}{"README.pod"};
++ delete $self->{PM}{"README"};
++}
diff --git a/textproc/p5-Hailo/pkg-descr b/textproc/p5-Hailo/pkg-descr
new file mode 100644
index 000000000000..ed2b3adb5fae
--- /dev/null
+++ b/textproc/p5-Hailo/pkg-descr
@@ -0,0 +1,12 @@
+Hailo is a fast and lightweight markov engine intended to replace AI::MegaHAL.
+Hailso has a Mouse (or Moose) based core with pluggable storage, tokenizer and
+engine backends.
+
+Hailo is similar to MegaHAL in functionality, the main differences (with the
+default backends) being better scalability, drastically less memory usage, an
+improved tokenizer, and tidier output.
+
+With Hailo, you can create, modify, and query Hailo brains. To use Hailo in
+event-driven POE applications, you can use the POE::Component::Hailo wrapper.
+
+WWW: http://search.cpan.org/dist/Hailo
diff --git a/textproc/p5-Hailo/pkg-plist b/textproc/p5-Hailo/pkg-plist
new file mode 100644
index 000000000000..ea8584c86273
--- /dev/null
+++ b/textproc/p5-Hailo/pkg-plist
@@ -0,0 +1,26 @@
+bin/hailo
+%%SITE_PERL%%/Hailo.pm
+%%SITE_PERL%%/Hailo/Command.pm
+%%SITE_PERL%%/Hailo/Engine/Default.pm
+%%SITE_PERL%%/Hailo/Engine/Scored.pm
+%%SITE_PERL%%/Hailo/Role/Arguments.pm
+%%SITE_PERL%%/Hailo/Role/Engine.pm
+%%SITE_PERL%%/Hailo/Role/Storage.pm
+%%SITE_PERL%%/Hailo/Role/Tokenizer.pm
+%%SITE_PERL%%/Hailo/Role/UI.pm
+%%SITE_PERL%%/Hailo/Storage.pm
+%%SITE_PERL%%/Hailo/Storage/MySQL.pm
+%%SITE_PERL%%/Hailo/Storage/PostgreSQL.pm
+%%SITE_PERL%%/Hailo/Storage/SQLite.pm
+%%SITE_PERL%%/Hailo/Storage/Schema.pm
+%%SITE_PERL%%/Hailo/Tokenizer/Chars.pm
+%%SITE_PERL%%/Hailo/Tokenizer/Words.pm
+%%SITE_PERL%%/Hailo/UI/ReadLine.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hailo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hailo
+@dirrmtry %%SITE_PERL%%/Hailo/Engine
+@dirrmtry %%SITE_PERL%%/Hailo/Role
+@dirrmtry %%SITE_PERL%%/Hailo/Storage
+@dirrmtry %%SITE_PERL%%/Hailo/Tokenizer
+@dirrmtry %%SITE_PERL%%/Hailo/UI
+@dirrm %%SITE_PERL%%/Hailo