aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-24 10:04:11 +0800
committerwen <wen@FreeBSD.org>2010-01-24 10:04:11 +0800
commite75f04c3c1ccb0fc74ee3bebdb314bc6e1c1f92d (patch)
tree863f9ae0412a5921a0ad378f5d01e37c2400053d /textproc
parent3fde978aad9c4e448be471e581dd73d2cf9b8713 (diff)
downloadfreebsd-ports-gnome-e75f04c3c1ccb0fc74ee3bebdb314bc6e1c1f92d.tar.gz
freebsd-ports-gnome-e75f04c3c1ccb0fc74ee3bebdb314bc6e1c1f92d.tar.zst
freebsd-ports-gnome-e75f04c3c1ccb0fc74ee3bebdb314bc6e1c1f92d.zip
- Update to 0.21.1
- Add test target - Remove patch-src-my_iconv.c and add patch-tests__Makefile.in - Pass maintainership to submitter PR: ports/143044 Submitted by: bf <bf1783@gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/unrtf/Makefile31
-rw-r--r--textproc/unrtf/distinfo6
-rw-r--r--textproc/unrtf/files/patch-src-my_iconv.c11
-rw-r--r--textproc/unrtf/files/patch-tests__Makefile.in11
4 files changed, 30 insertions, 29 deletions
diff --git a/textproc/unrtf/Makefile b/textproc/unrtf/Makefile
index 1fc55c16e6b9..6c22d94acc88 100644
--- a/textproc/unrtf/Makefile
+++ b/textproc/unrtf/Makefile
@@ -5,11 +5,11 @@
# $FreeBSD$
PORTNAME= unrtf
-PORTVERSION= 0.21.0
+PORTVERSION= 0.21.1
CATEGORIES= textproc
MASTER_SITES= GNU
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bf1783@gmail.com
COMMENT= A converter from RTF to several formats, including HTML and LaTeX
USE_ICONV= yes
@@ -20,22 +20,23 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/share
MAN1= unrtf.1
PLIST_FILES= bin/unrtf \
- %%DATADIR%%/charmaps/SYMBOL \
- %%DATADIR%%/outputs/html \
- %%DATADIR%%/outputs/latex \
- %%DATADIR%%/outputs/rtf \
- %%DATADIR%%/outputs/text \
- %%DATADIR%%/outputs/vt
-PLIST_DIRS= %%DATADIR%%/outputs \
- %%DATADIR%%/charmaps \
- %%DATADIR%%
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -liconv
+ %%DATADIR%%/SYMBOL.charmap \
+ %%DATADIR%%/html.conf \
+ %%DATADIR%%/latex.conf \
+ %%DATADIR%%/rtf.conf \
+ %%DATADIR%%/text.conf \
+ %%DATADIR%%/vt.conf
+PLIST_DIRS= %%DATADIR%%
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
post-patch:
- @${FIND} ${WRKSRC} -name "*.[1h]" -print0 | ${XARGS} -0 \
+ @${FIND} -X ${WRKSRC} -type f -and -name "*.[1h]" | ${XARGS} \
${REINPLACE_CMD} -e \
's|/usr/local/lib/unrtf/|${DATADIR}/|g'
+test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
+
.include <bsd.port.mk>
diff --git a/textproc/unrtf/distinfo b/textproc/unrtf/distinfo
index c5a6c320c63a..86ed2db176ad 100644
--- a/textproc/unrtf/distinfo
+++ b/textproc/unrtf/distinfo
@@ -1,3 +1,3 @@
-MD5 (unrtf-0.21.0.tar.gz) = 8d1f8617d6813308c310f111145c7cb9
-SHA256 (unrtf-0.21.0.tar.gz) = 3be1b49b7d3b1f7d915cf1821d2916444c45034a3a79dd46dbb4fc0453ca97f0
-SIZE (unrtf-0.21.0.tar.gz) = 626157
+MD5 (unrtf-0.21.1.tar.gz) = ce069646837d0a2c15b439a5529afde8
+SHA256 (unrtf-0.21.1.tar.gz) = f0db720484c3d371e3448f9ab35f9c158a0488a9f38181780b8a755fde28a53d
+SIZE (unrtf-0.21.1.tar.gz) = 609261
diff --git a/textproc/unrtf/files/patch-src-my_iconv.c b/textproc/unrtf/files/patch-src-my_iconv.c
deleted file mode 100644
index 817b4c20b7f9..000000000000
--- a/textproc/unrtf/files/patch-src-my_iconv.c
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN src.old/my_iconv.c src/my_iconv.c
---- src.old/my_iconv.c 2009-08-10 14:02:54.000000000 +0600
-+++ src/my_iconv.c 2009-08-10 14:03:26.000000000 +0600
-@@ -10,6 +10,7 @@
- #include "malloc.h"
- #include "my_iconv.h"
- #include "util.h"
-+#include "unicode.h"
-
- my_iconv_t
- my_iconv_open(const char *tocode, const char *fromcode)
diff --git a/textproc/unrtf/files/patch-tests__Makefile.in b/textproc/unrtf/files/patch-tests__Makefile.in
new file mode 100644
index 000000000000..2711ca6de6f5
--- /dev/null
+++ b/textproc/unrtf/files/patch-tests__Makefile.in
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.orig 2010-01-20 21:04:39.000000000 -0500
++++ tests/Makefile.in 2010-01-20 21:04:14.000000000 -0500
+@@ -208,7 +208,7 @@
+
+ # add the test scripts and the test data to the distributed files
+ EXTRA_DIST = $(TESTS) $(testdata)
+-TESTS_ENVIRONMENT = UNRTF=$(top_builddir)/src/unrtf
++TESTS_ENVIRONMENT = UNRTF="$(top_builddir)/src/unrtf -P $(top_builddir)/outputs:$(top_builddir)/charmaps"
+ all: all-am
+
+ .SUFFIXES: