aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-03-09 08:55:48 +0800
committermakc <makc@FreeBSD.org>2009-03-09 08:55:48 +0800
commit40c0b38bfb75211cd9b99a1e0e107ee18aaa163f (patch)
tree671c4c9a23d6aae9dc387581484123b6f3acfa06 /textproc
parentcbaad731bb7914033b36d2b1229bffb984186e56 (diff)
downloadfreebsd-ports-gnome-40c0b38bfb75211cd9b99a1e0e107ee18aaa163f.tar.gz
freebsd-ports-gnome-40c0b38bfb75211cd9b99a1e0e107ee18aaa163f.tar.zst
freebsd-ports-gnome-40c0b38bfb75211cd9b99a1e0e107ee18aaa163f.zip
Update KDE to 4.2.1.
multimedia/phonon port has been split into phonon itself, phonon-xine and phono-gstreamer backends. After updating phonon port you have to install at least one backend. phonon-xine backend is recommended for KDE.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ebook-tools/Makefile6
-rw-r--r--textproc/soprano/Makefile32
-rw-r--r--textproc/soprano/distinfo6
-rw-r--r--textproc/soprano/pkg-plist11
4 files changed, 41 insertions, 14 deletions
diff --git a/textproc/ebook-tools/Makefile b/textproc/ebook-tools/Makefile
index d2fa64b90d03..4f70669c5fc4 100644
--- a/textproc/ebook-tools/Makefile
+++ b/textproc/ebook-tools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ebook-tools
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= textproc kde
MASTER_SITES= SF
@@ -15,13 +16,8 @@ COMMENT= Accessing and converting various ebook file formats
LIB_DEPENDS= zip.1:${PORTSDIR}/archivers/libzip
-USE_KDE4= kdehier kdeprefix
USE_CMAKE= yes
-CMAKE_VERBOSE= yes
USE_LDCONFIG= yes
USE_GNOME= libxml2 pkgconfig
-post-extract:
- ${MKDIR} ${WRKSRC}/build
-
.include <bsd.port.mk>
diff --git a/textproc/soprano/Makefile b/textproc/soprano/Makefile
index 632e715bb915..b3a7b5404ca3 100644
--- a/textproc/soprano/Makefile
+++ b/textproc/soprano/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= soprano
-PORTVERSION= 2.1.67
+PORTVERSION= 2.2.3
CATEGORIES= textproc
MASTER_SITES= SF
@@ -13,7 +13,10 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= QT4 RDF framework
LIB_DEPENDS= clucene.0:${PORTSDIR}/textproc/clucene \
- rdf.0:${PORTSDIR}/textproc/redland
+ raptor.2:${PORTSDIR}/textproc/raptor
+
+OPTIONS= REDLAND "Use Redland as storage backend" on \
+ SESAME2 "Use Sesame2 as storage backend (requires Java)" off
USE_BZIP2= yes
USE_QT_VER= 4
@@ -23,9 +26,30 @@ USE_GNOME= pkgconfig
USE_LDCONFIG= yes
USE_CMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_REDLAND)
+LIB_DEPENDS+= rdf.0:${PORTSDIR}/textproc/redland
+PLIST_SUB+= REDLAND=""
+.else
+CMAKE_ARGS+= -DSOPRANO_DISABLE_REDLAND_BACKEND=yes
+PLIST_SUB+= REDLAND="@comment "
+.endif
+
+.if defined(WITH_SESAME2)
+CATEGORIES+= java
+CMAKE_ENV+= JAVA_HOME=${JAVA_HOME}
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+PLIST_SUB+= SESAME2=""
+.else
+CMAKE_ARGS+= -DSOPRANO_DISABLE_SESAME2_BACKEND=yes
+PLIST_SUB+= SESAME2="@comment "
+.endif
+
post-patch:
- ${MKDIR} ${WRKSRC}
${REINPLACE_CMD} -e "s,$${LIB_SUFFIX}/pkgconfig,data/pkgconfig," \
${WRKSRC}/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/soprano/distinfo b/textproc/soprano/distinfo
index 28c90a118012..b67f39ae6de5 100644
--- a/textproc/soprano/distinfo
+++ b/textproc/soprano/distinfo
@@ -1,3 +1,3 @@
-MD5 (soprano-2.1.67.tar.bz2) = 9639e400ba4beb08af35e5128439cc77
-SHA256 (soprano-2.1.67.tar.bz2) = 1fe7feb83891e5761646e731fbdb8a44c84600392a72316c7eada304e8e29026
-SIZE (soprano-2.1.67.tar.bz2) = 1847445
+MD5 (soprano-2.2.3.tar.bz2) = 22c992a252144ae0a3a964ba2f6f1933
+SHA256 (soprano-2.2.3.tar.bz2) = 49df0b7ee51c1dc1722b167726c95b18bb1eb8cb7178e5afd28c639efed7a6d2
+SIZE (soprano-2.2.3.tar.bz2) = 1849174
diff --git a/textproc/soprano/pkg-plist b/textproc/soprano/pkg-plist
index 9e951c5e1979..976e4f46f0d7 100644
--- a/textproc/soprano/pkg-plist
+++ b/textproc/soprano/pkg-plist
@@ -150,7 +150,8 @@ lib/soprano/libsoprano_nquadparser.so
lib/soprano/libsoprano_nquadserializer.so
lib/soprano/libsoprano_raptorparser.so
lib/soprano/libsoprano_raptorserializer.so
-lib/soprano/libsoprano_redlandbackend.so
+%%REDLAND%%lib/soprano/libsoprano_redlandbackend.so
+%%SESAME2%%lib/soprano/libsoprano_sesame2backend.so
libdata/pkgconfig/soprano.pc
share/dbus-1/interfaces/org.soprano.Model.xml
share/dbus-1/interfaces/org.soprano.NodeIterator.xml
@@ -161,9 +162,15 @@ share/dbus-1/interfaces/org.soprano.StatementIterator.xml
%%DATADIR%%/plugins/nquadserializer.desktop
%%DATADIR%%/plugins/raptorparser.desktop
%%DATADIR%%/plugins/raptorserializer.desktop
-%%DATADIR%%/plugins/redlandbackend.desktop
+%%REDLAND%%%%DATADIR%%/plugins/redlandbackend.desktop
+%%SESAME2%%%%DATADIR%%/plugins/sesame2backend.desktop
%%DATADIR%%/rules/nrl.rules
%%DATADIR%%/rules/rdfs.rules
+%%SESAME2%%%%DATADIR%%/sesame2/openrdf-sesame-2.1.4-onejar.jar
+%%SESAME2%%%%DATADIR%%/sesame2/slf4j-api-1.5.5.jar
+%%SESAME2%%%%DATADIR%%/sesame2/slf4j-simple-1.5.5.jar
+%%SESAME2%%%%DATADIR%%/sesame2/SopranoSesame2Wrapper.class
+%%SESAME2%%@dirrm %%DATADIR%%/sesame2
@dirrm %%DATADIR%%/rules
@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%