aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2010-07-15 22:20:29 +0800
committerashish <ashish@FreeBSD.org>2010-07-15 22:20:29 +0800
commit94d3b7e3ec9d229858ecd57c10cf63fbe0c323af (patch)
treefae7b5c64267256fea77a15da44665f94df77aec /textproc
parent666abc4eac1982fd51c9c9efc2d44387dcf98583 (diff)
downloadfreebsd-ports-gnome-94d3b7e3ec9d229858ecd57c10cf63fbe0c323af.tar.gz
freebsd-ports-gnome-94d3b7e3ec9d229858ecd57c10cf63fbe0c323af.tar.zst
freebsd-ports-gnome-94d3b7e3ec9d229858ecd57c10cf63fbe0c323af.zip
- Update to 0.4.16.
- Add LICENSE information. Approved by: tabthorpe (mentor)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/scim-bridge-qt4/Makefile12
-rw-r--r--textproc/scim-bridge-qt4/distinfo6
-rw-r--r--textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in23
-rw-r--r--textproc/scim-bridge-qt4/files/patch-configure22
-rw-r--r--textproc/scim-bridge/Makefile10
-rw-r--r--textproc/scim-bridge/distinfo6
-rw-r--r--textproc/scim-bridge/files/patch-configure29
7 files changed, 95 insertions, 13 deletions
diff --git a/textproc/scim-bridge-qt4/Makefile b/textproc/scim-bridge-qt4/Makefile
index dabe1e93090e..e4a8219342dd 100644
--- a/textproc/scim-bridge-qt4/Makefile
+++ b/textproc/scim-bridge-qt4/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim-bridge
-PORTVERSION= 0.4.15
-PORTREVISION= 3
+PORTVERSION= 0.4.16
CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION}
PKGNAMESUFFIX= -qt4
@@ -18,13 +17,18 @@ COMMENT= Qt4 client for Scim-bridge
RUN_DEPENDS= scim-bridge:${PORTSDIR}/textproc/scim-bridge
USE_QT_VER= 4
-QT_COMPONENTS= gui corelib moc_build
+QT_COMPONENTS= corelib gui moc_build
QT_NONSTANDARD= yes
USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+LICENSE= GPLv2 LGPL21
+LICENSE_FILES= ${WRKSRC}/doc/LICENSE.GPL ${WRKSRC}/doc/LICENSE.LGPL
+LICENSE_COMB= dual
+
+CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
+CXXFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
--disable-agent \
diff --git a/textproc/scim-bridge-qt4/distinfo b/textproc/scim-bridge-qt4/distinfo
index c347c6a9013b..2e1cabe4af78 100644
--- a/textproc/scim-bridge-qt4/distinfo
+++ b/textproc/scim-bridge-qt4/distinfo
@@ -1,3 +1,3 @@
-MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
-SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
-SIZE (scim-bridge-0.4.15.tar.gz) = 753583
+MD5 (scim-bridge-0.4.16.tar.gz) = 0011b178c4a0d2b0de26e7a14545323c
+SHA256 (scim-bridge-0.4.16.tar.gz) = 50d9da4a2842ab31cd3b27b1baacb14c458614bdb35855c6ecd09ab855ac702c
+SIZE (scim-bridge-0.4.16.tar.gz) = 508870
diff --git a/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in b/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in
new file mode 100644
index 000000000000..acfce4fc8b3b
--- /dev/null
+++ b/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- client-qt/qt4/Makefile.in.orig
++++ client-qt/qt4/Makefile.in
+@@ -243,7 +243,7 @@
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@ -I$(top_srcdir)/client-common
+
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@noinst_HEADERS = ../scim-bridge-client-qt.h ../scim-bridge-client-imcontext-qt.h ../scim-bridge-client-key-event-utility-qt.h ../scim-bridge-client-common-qt.h
+-@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@moduledir = @QT4_PREFIX@/plugins/inputmethods
++@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@moduledir = @QT4_PREFIX@/lib/qt4/plugins/inputmethods
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@module_LTLIBRARIES = im-scim-bridge.la
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@im_scim_bridge_la_SOURCES = ../im-scim-bridge-qt.cpp \
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@ ../scim-bridge-client-qt.cpp \
+@@ -261,7 +261,7 @@
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@im_scim_bridge_la_LIBADD = $(top_srcdir)/common/libscimbridgecommon.la \
+ @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@ $(top_srcdir)/client-common/libscimbridgeclientcommon.la
+
+-@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@MOC = @QT4_PREFIX@/bin/moc
++@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@MOC = @QT4_PREFIX@/bin/moc-qt4
+ MAINTAINERCLEANFILES = Makefile.in
+ CLEANFILES = moc_scim-bridge-client-qt.cpp
+ all: all-am
diff --git a/textproc/scim-bridge-qt4/files/patch-configure b/textproc/scim-bridge-qt4/files/patch-configure
new file mode 100644
index 000000000000..8d23f499d937
--- /dev/null
+++ b/textproc/scim-bridge-qt4/files/patch-configure
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -24584,6 +24584,8 @@
+ enable_gtk2_immodule="yes";
+ fi
+
++enable_gtk2_immodule="no";
++
+ # Check if we should build scim-bridge-qt-immodule
+
+ pkg_failed=no
+@@ -24661,6 +24663,7 @@
+ enable_qt3_immodule="yes";
+ fi
+
++enable_qt3_immodule="no";
+
+ pkg_failed=no
+ { $as_echo "$as_me:$LINENO: checking for QT4" >&5
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
index 06168cea8113..e8ea9515a4fb 100644
--- a/textproc/scim-bridge/Makefile
+++ b/textproc/scim-bridge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim-bridge
-PORTVERSION= 0.4.15
-PORTREVISION= 4
+PORTVERSION= 0.4.16
CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION}
@@ -20,7 +19,12 @@ USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+LICENSE= GPLv2 LGPL21
+LICENSE_FILES= ${WRKSRC}/doc/LICENSE.GPL ${WRKSRC}/doc/LICENSE.LGPL
+LICENSE_COMB= dual
+
+CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
+CXXFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
--enable-agent \
diff --git a/textproc/scim-bridge/distinfo b/textproc/scim-bridge/distinfo
index c347c6a9013b..2e1cabe4af78 100644
--- a/textproc/scim-bridge/distinfo
+++ b/textproc/scim-bridge/distinfo
@@ -1,3 +1,3 @@
-MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
-SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
-SIZE (scim-bridge-0.4.15.tar.gz) = 753583
+MD5 (scim-bridge-0.4.16.tar.gz) = 0011b178c4a0d2b0de26e7a14545323c
+SHA256 (scim-bridge-0.4.16.tar.gz) = 50d9da4a2842ab31cd3b27b1baacb14c458614bdb35855c6ecd09ab855ac702c
+SIZE (scim-bridge-0.4.16.tar.gz) = 508870
diff --git a/textproc/scim-bridge/files/patch-configure b/textproc/scim-bridge/files/patch-configure
new file mode 100644
index 000000000000..160af1af87e2
--- /dev/null
+++ b/textproc/scim-bridge/files/patch-configure
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -24583,6 +24583,7 @@
+
+ enable_gtk2_immodule="yes";
+ fi
++enable_gtk2_immodule="no";
+
+ # Check if we should build scim-bridge-qt-immodule
+
+@@ -24660,6 +24661,7 @@
+
+ enable_qt3_immodule="yes";
+ fi
++enable_qt3_immodule="no";
+
+
+ pkg_failed=no
+@@ -24736,6 +24738,7 @@
+
+ enable_qt4_immodule="yes";
+ fi
++enable_qt4_immodule="no";
+
+ ###########################################################
+ ## Definiation of compile args. ##