aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-06-19 11:46:46 +0800
committerdanfe <danfe@FreeBSD.org>2017-06-19 11:46:46 +0800
commita37f14d294f98f2bec47441771eed7b09681e017 (patch)
tree84e51748c8e2ac449ed9ee134e76a649e1e4315a /textproc
parentb1471a14fc0d3109a04449887c06a95d26534e67 (diff)
downloadfreebsd-ports-gnome-a37f14d294f98f2bec47441771eed7b09681e017.tar.gz
freebsd-ports-gnome-a37f14d294f98f2bec47441771eed7b09681e017.tar.zst
freebsd-ports-gnome-a37f14d294f98f2bec47441771eed7b09681e017.zip
Resurrect `textproc/ssddiff' and unbreak by providing a bunch of working
mirrors. Original upstream (alioth.debian.org) exists and seems alive, but for some reason no longer allows unauthenticated downloads. Keep it for the reference though, it might get fixed one day.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ssddiff/Makefile39
-rw-r--r--textproc/ssddiff/distinfo2
-rw-r--r--textproc/ssddiff/files/patch-src__rel_count.h10
-rw-r--r--textproc/ssddiff/files/patch-src__ustring.h10
-rw-r--r--textproc/ssddiff/pkg-descr15
6 files changed, 77 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e01c92894842..8c8f952b548e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1641,6 +1641,7 @@
SUBDIR += sr-hunspell
SUBDIR += srilm
SUBDIR += ss-hunspell
+ SUBDIR += ssddiff
SUBDIR += stardict-dict-fa_IR
SUBDIR += stardict-dictd_mova
SUBDIR += stardict-quick
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
new file mode 100644
index 000000000000..eec315dfc2b4
--- /dev/null
+++ b/textproc/ssddiff/Makefile
@@ -0,0 +1,39 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ssddiff
+PORTVERSION= 0.2
+PORTREVISION= 2
+CATEGORIES= textproc
+MASTER_SITES= http://freebsd.nsu.ru/distfiles/ \
+ http://ftp.is.co.za/FreeBSD/ports/distfiles/ \
+ ftp://ftp.rediris.es/sites/ftp.freebsd.org/pub/FreeBSD/ports/distfiles/ \
+ http://ftp.nchc.org.tw/BSD/FreeBSD/ports/distfiles/ \
+ ftp://ftp.eunet.cz/FreeBSD/ports/distfiles/ \
+ https://alioth.debian.org/frs/download.php/file/1469/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Diff application for semistructured data such as XML files
+
+LICENSE= GPLv2+
+
+GNU_CONFIGURE= yes
+USES= autoreconf pkgconfig tar:bzip2
+USE_GNOME= libxml2
+
+PLIST_FILES= bin/xmldiff
+
+post-patch:
+ @${FIND} ${WRKSRC} -type l -delete
+ @${REINPLACE_CMD} -e \
+ 's|^CXXFLAGS|AM_CPPFLAGS|' ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} -e \
+ 's|"getopt\.h"|<unistd.h>|' ${WRKSRC}/src/main.cc
+ @${REINPLACE_CMD} \
+ -e 's/hash</__gnu_cxx::&/' -e 's/hash<char/& const/' \
+ ${WRKSRC}/src/doc.h ${WRKSRC}/src/out_common.cc \
+ ${WRKSRC}/src/out_merged.cc ${WRKSRC}/src/out_xupdate.cc \
+ ${WRKSRC}/src/out_xupdate.h ${WRKSRC}/src/ustring.cc \
+ ${WRKSRC}/src/ustring.h
+
+.include <bsd.port.mk>
diff --git a/textproc/ssddiff/distinfo b/textproc/ssddiff/distinfo
new file mode 100644
index 000000000000..0f285a7d8109
--- /dev/null
+++ b/textproc/ssddiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ssddiff-0.2.tar.bz2) = 2c0c3fe73d149f92b74005805c5b5135a47d88eea83493255c31ab931281b9be
+SIZE (ssddiff-0.2.tar.bz2) = 86679
diff --git a/textproc/ssddiff/files/patch-src__rel_count.h b/textproc/ssddiff/files/patch-src__rel_count.h
new file mode 100644
index 000000000000..691d6c8416f6
--- /dev/null
+++ b/textproc/ssddiff/files/patch-src__rel_count.h
@@ -0,0 +1,10 @@
+--- src/rel_count.h.orig
++++ src/rel_count.h
+@@ -13,6 +13,7 @@
+ #define SSD_REL_COUNT_H
+ #include "config.h"
+ #include "rel_eqclass.h"
++#include <climits>
+ #include <vector>
+ #include <ext/hash_map>
+
diff --git a/textproc/ssddiff/files/patch-src__ustring.h b/textproc/ssddiff/files/patch-src__ustring.h
new file mode 100644
index 000000000000..fca819b55c54
--- /dev/null
+++ b/textproc/ssddiff/files/patch-src__ustring.h
@@ -0,0 +1,10 @@
+--- src/ustring.h.orig
++++ src/ustring.h
+@@ -14,6 +14,7 @@
+
+ #include "config.h"
+
++#include <cstring>
+ #include <iostream>
+ #include <map>
+ #include <ext/hash_map>
diff --git a/textproc/ssddiff/pkg-descr b/textproc/ssddiff/pkg-descr
new file mode 100644
index 000000000000..b45fe365b057
--- /dev/null
+++ b/textproc/ssddiff/pkg-descr
@@ -0,0 +1,15 @@
+Semistructured data is a generic term for data that does have structure
+information, while not being tabular or very tightly restricted. XML and
+HTML data is the most prominent examples for this. You normally would not
+use this term e.g. for database tables (which for example do not allow
+nesting of entries).
+
+While this application currently only supports XML, the algorithms should be
+able to process other semistructured data as well.
+
+The approach used here is usually much slower than other well-known xmldiff
+applications, however it produces better results in many "tricky" cases.
+You say that other xmldiff applications try to do a syntactic diff, whereas
+xmldiff tries to do a semantic diff.
+
+WWW: http://ssddiff.alioth.debian.org/