aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2007-07-28 22:17:21 +0800
committerchinsan <chinsan@FreeBSD.org>2007-07-28 22:17:21 +0800
commit18a51629b41d7f212561396312434673e6833f37 (patch)
treee21c97b083ae2a11780c850cd07314b43f6cd2c2 /textproc
parent33b78049283fab435ac651025299f27a58707f6f (diff)
downloadfreebsd-ports-gnome-18a51629b41d7f212561396312434673e6833f37.tar.gz
freebsd-ports-gnome-18a51629b41d7f212561396312434673e6833f37.tar.zst
freebsd-ports-gnome-18a51629b41d7f212561396312434673e6833f37.zip
Add p5-Google-Data-JSON, Google::Data::JSON provides several methods to
convert an XML feed into a JSON feed, and vice versa. The JSON format is defined in Google Data APIs, http://code.google.com/apis/gdata/json.html . Approved by: rafan (mentor, implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Google-Data-JSON/Makefile34
-rw-r--r--textproc/p5-Google-Data-JSON/distinfo3
-rw-r--r--textproc/p5-Google-Data-JSON/pkg-descr5
-rw-r--r--textproc/p5-Google-Data-JSON/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1c2013b149da..87a7ec1999e6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -358,6 +358,7 @@
SUBDIR += p5-Filter-Simple
SUBDIR += p5-FormValidator-Simple
SUBDIR += p5-Games-Dissociate
+ SUBDIR += p5-Google-Data-JSON
SUBDIR += p5-HTML-Entities-Numbered
SUBDIR += p5-HTML-EscapeEvil
SUBDIR += p5-HTML-Format
diff --git a/textproc/p5-Google-Data-JSON/Makefile b/textproc/p5-Google-Data-JSON/Makefile
new file mode 100644
index 000000000000..4ce5b9028727
--- /dev/null
+++ b/textproc/p5-Google-Data-JSON/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Google-Data-JSON
+# Date created: 2007/07/28
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-Data-JSON
+PORTVERSION= 0.1.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML/TAKERU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= General XML-JSON converter based on Google Data APIs
+
+BUILD_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Perl6-Export-Attrs>=0:${PORTSDIR}/devel/p5-Perl6-Export-Attrs \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
+ p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Google::Data::JSON.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Google-Data-JSON/distinfo b/textproc/p5-Google-Data-JSON/distinfo
new file mode 100644
index 000000000000..908dfd0e77f1
--- /dev/null
+++ b/textproc/p5-Google-Data-JSON/distinfo
@@ -0,0 +1,3 @@
+MD5 (Google-Data-JSON-0.1.3.tar.gz) = 131f1bdfb6f99df7308474d14ef681fd
+SHA256 (Google-Data-JSON-0.1.3.tar.gz) = 076b4c52bc0a527031bfce55b384e0fc91926fa931ad162c0115f944244d029b
+SIZE (Google-Data-JSON-0.1.3.tar.gz) = 6757
diff --git a/textproc/p5-Google-Data-JSON/pkg-descr b/textproc/p5-Google-Data-JSON/pkg-descr
new file mode 100644
index 000000000000..4f1cc193ead5
--- /dev/null
+++ b/textproc/p5-Google-Data-JSON/pkg-descr
@@ -0,0 +1,5 @@
+Google::Data::JSON provides several methods to convert an XML feed into a
+JSON feed, and vice versa. The JSON format is defined in Google Data APIs,
+http://code.google.com/apis/gdata/json.html .
+
+WWW: http://search.cpan.org/dist/Google-Data-JSON/
diff --git a/textproc/p5-Google-Data-JSON/pkg-plist b/textproc/p5-Google-Data-JSON/pkg-plist
new file mode 100644
index 000000000000..55e53baae448
--- /dev/null
+++ b/textproc/p5-Google-Data-JSON/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Google/Data/JSON.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data/JSON/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google
+@dirrmtry %%SITE_PERL%%/Google/Data
+@dirrmtry %%SITE_PERL%%/Google