aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-10-07 05:42:58 +0800
committerswills <swills@FreeBSD.org>2014-10-07 05:42:58 +0800
commit239e0f6207e2c13888e010ef884ec60759492f8c (patch)
tree89118de1c5902247cc1c319d06bc05851c14aa5b /textproc
parent98b1fbe5cc6d31ecfae22a363b9d124479ef9bc9 (diff)
downloadfreebsd-ports-gnome-239e0f6207e2c13888e010ef884ec60759492f8c.tar.gz
freebsd-ports-gnome-239e0f6207e2c13888e010ef884ec60759492f8c.tar.zst
freebsd-ports-gnome-239e0f6207e2c13888e010ef884ec60759492f8c.zip
textproc/rubygem-rmmseg-cp: create port
rmmseg-cpp is a high performance Chinese word segmentation utility for Ruby. WWW: http://rmmseg-cpp.rubyforge.org
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rmmseg-cpp/Makefile18
-rw-r--r--textproc/rubygem-rmmseg-cpp/distinfo2
-rw-r--r--textproc/rubygem-rmmseg-cpp/pkg-descr16
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0b63df4b5199..02a17069c615 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1357,6 +1357,7 @@
SUBDIR += rubygem-redcarpet
SUBDIR += rubygem-ri_cal
SUBDIR += rubygem-rich
+ SUBDIR += rubygem-rmmseg-cpp
SUBDIR += rubygem-rouge
SUBDIR += rubygem-rttool
SUBDIR += rubygem-rubypants
diff --git a/textproc/rubygem-rmmseg-cpp/Makefile b/textproc/rubygem-rmmseg-cpp/Makefile
new file mode 100644
index 000000000000..d815f4aad1a5
--- /dev/null
+++ b/textproc/rubygem-rmmseg-cpp/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rmmseg-cpp
+PORTVERSION= 0.2.9
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= High performance Chinese word segmentation utility
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+PLIST_FILES= bin/rmmseg
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rmmseg-cpp/distinfo b/textproc/rubygem-rmmseg-cpp/distinfo
new file mode 100644
index 000000000000..377d9297ae0d
--- /dev/null
+++ b/textproc/rubygem-rmmseg-cpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rmmseg-cpp-0.2.9.gem) = 9c94449163519d9c0c054ad2efa9d4f11914a3a5a0d086778c8a1659cbe060ea
+SIZE (rubygem/rmmseg-cpp-0.2.9.gem) = 802304
diff --git a/textproc/rubygem-rmmseg-cpp/pkg-descr b/textproc/rubygem-rmmseg-cpp/pkg-descr
new file mode 100644
index 000000000000..6da5bfb1cadd
--- /dev/null
+++ b/textproc/rubygem-rmmseg-cpp/pkg-descr
@@ -0,0 +1,16 @@
+rmmseg-cpp is a high performance Chinese word segmentation utility for
+Ruby. It features full "Ferret":http://ferret.davebalmain.com/ integration
+as well as support for normal Ruby program usage.
+
+rmmseg-cpp is a re-written of the original
+RMMSeg(http://rmmseg.rubyforge.org/) gem in C++. RMMSeg is written
+in pure Ruby. Though I tried hard to tweak RMMSeg, it just consumes
+lots of memory and the segmenting process is rather slow.
+
+The interface is almost identical to RMMSeg but the performance is
+much better. This gem is always preferable in production
+use. However, if you want to understand how the MMSEG segmenting
+algorithm works, the source code of RMMSeg is a better choice than
+this.
+
+WWW: http://rmmseg-cpp.rubyforge.org