aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-25 22:28:28 +0800
committertobik <tobik@FreeBSD.org>2018-08-25 22:28:28 +0800
commit2b7f472ff2ddc3412b83186de6df98b64aece6b5 (patch)
tree8a37fe2ea51cabf412a7c0ae8c381eb07c1c89ca /textproc
parent0c20f7adafdeb7a1a8ad72c452cbea6acdd009cc (diff)
downloadfreebsd-ports-gnome-2b7f472ff2ddc3412b83186de6df98b64aece6b5.tar.gz
freebsd-ports-gnome-2b7f472ff2ddc3412b83186de6df98b64aece6b5.tar.zst
freebsd-ports-gnome-2b7f472ff2ddc3412b83186de6df98b64aece6b5.zip
textproc/soothsayer: Fix build with Clang 6
../../../src/lib/core/charsets.h:108:5: error: constant expression evaluates to 192 which cannot be narrowed to type 'char' [-Wc++11-narrowing] Agrave , ^~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/soothsayer-0.6.3_3.log
Diffstat (limited to 'textproc')
-rw-r--r--textproc/soothsayer/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index ec1c9e880933..4b9e54e53753 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
BUILD_DEPENDS= help2man:misc/help2man
-USES= libtool localbase ncurses pkgconfig sqlite
+USES= compiler libtool localbase ncurses pkgconfig sqlite
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_CPPUNIT_CONFIG=no \
ac_cv_path_PYTHON=no \
@@ -22,6 +22,8 @@ CONFIGURE_ENV= ac_cv_path_CPPUNIT_CONFIG=no \
ac_cv_prog_HAVE_DOT=no \
ac_cv_prog_HAVE_DOXYGEN=no
CONFIGURE_ARGS= --disable-python-binding --localstatedir="${PREFIX}/var"
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes