aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-05-14 04:35:02 +0800
committerkwm <kwm@FreeBSD.org>2014-05-14 04:35:02 +0800
commit2dda99fa27db0df60e1e6e7a55cff79018893efa (patch)
treece3228c17d6f2e1bfc7aad08709fad4c3acc89c5 /textproc
parent15bb9847051f0ac285657dd08363daf8f762fe7f (diff)
downloadfreebsd-ports-gnome-2dda99fa27db0df60e1e6e7a55cff79018893efa.tar.gz
freebsd-ports-gnome-2dda99fa27db0df60e1e6e7a55cff79018893efa.tar.zst
freebsd-ports-gnome-2dda99fa27db0df60e1e6e7a55cff79018893efa.zip
Add python3 version of the libxml2 python bindings.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py3-libxml2/Makefile37
-rw-r--r--textproc/py3-libxml2/pkg-descr3
-rw-r--r--textproc/py3-libxml2/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 539d45d74842..4764ae2cd107 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += py-zope.tal
SUBDIR += py-zpt
SUBDIR += py2html
+ SUBDIR += py3-libxml2
SUBDIR += pychm
SUBDIR += pystemmer
SUBDIR += qprint
diff --git a/textproc/py3-libxml2/Makefile b/textproc/py3-libxml2/Makefile
new file mode 100644
index 000000000000..21f7f07ddbf3
--- /dev/null
+++ b/textproc/py3-libxml2/Makefile
@@ -0,0 +1,37 @@
+# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/textproc/py3-libxml2/Makefile 19293 2014-03-24 20:46:10Z kwm $
+
+PORTREVISION= 0
+CATEGORIES= textproc gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface for XML parser library for GNOME
+
+MASTERDIR= ${.CURDIR}/../libxml2
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME+= libxml2
+USE_PYTHON= 3
+USE_PYDISTUTILS=yes
+PYDISTUTILS_EGGINFO= libxml2_python-${PORTVERSION}-py${PYTHON_VER}.egg-info
+PLIST_SUB+= PYTVER=${PYTHON_VER:S/.//}
+
+CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
+LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
+CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
+ --with-html-dir=${PREFIX}/share/doc \
+ --with-html-subdir=${PORTNAME} \
+ --with-python=${PYTHON_CMD}
+
+DOCSDIR= ${PREFIX}/share/doc/py-libxml2
+EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/py3-libxml2/pkg-descr b/textproc/py3-libxml2/pkg-descr
new file mode 100644
index 000000000000..afb7cf4dd299
--- /dev/null
+++ b/textproc/py3-libxml2/pkg-descr
@@ -0,0 +1,3 @@
+Python interface for XML parser library for GNOME
+
+WWW: http://xmlsoft.org/
diff --git a/textproc/py3-libxml2/pkg-plist b/textproc/py3-libxml2/pkg-plist
new file mode 100644
index 000000000000..bbda20c6d04f
--- /dev/null
+++ b/textproc/py3-libxml2/pkg-plist
@@ -0,0 +1,9 @@
+%%PYTHON_SITELIBDIR%%/__pycache__/drv_libxml2.cpython-%%PYTVER%%.pyc
+%%PYTHON_SITELIBDIR%%/__pycache__/drv_libxml2.cpython-%%PYTVER%%.pyo
+%%PYTHON_SITELIBDIR%%/__pycache__/libxml2.cpython-%%PYTVER%%.pyc
+%%PYTHON_SITELIBDIR%%/__pycache__/libxml2.cpython-%%PYTVER%%.pyo
+%%PYTHON_SITELIBDIR%%/drv_libxml2.py
+%%PYTHON_SITELIBDIR%%/libxml2.py
+%%PYTHON_SITELIBDIR%%/libxml2mod.so
+@dirrmtry %%PYTHON_SITELIBDIR%%/__pycache__
+