aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-07 03:09:37 +0800
committerbapt <bapt@FreeBSD.org>2014-10-07 03:09:37 +0800
commit3fe3130f07b285244b83b51490c1dd3c8bac6bfd (patch)
tree0313677438d0768a90153667cf164a3648f70c94 /textproc
parentf854e8db8c657acdff50dd9ca3a160bfecd4c567 (diff)
downloadfreebsd-ports-gnome-3fe3130f07b285244b83b51490c1dd3c8bac6bfd.tar.gz
freebsd-ports-gnome-3fe3130f07b285244b83b51490c1dd3c8bac6bfd.tar.zst
freebsd-ports-gnome-3fe3130f07b285244b83b51490c1dd3c8bac6bfd.zip
Import libwps03
Ensure libwps does not conflict with libwps03
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libwps/Makefile12
-rw-r--r--textproc/libwps/pkg-plist5
-rw-r--r--textproc/libwps03/Makefile35
-rw-r--r--textproc/libwps03/distinfo2
-rw-r--r--textproc/libwps03/pkg-descr7
-rw-r--r--textproc/libwps03/pkg-plist12
7 files changed, 62 insertions, 12 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 06138f0b51de..f4f6b4ba08c7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -383,6 +383,7 @@
SUBDIR += libwpd
SUBDIR += libwpd010
SUBDIR += libwps
+ SUBDIR += libwps03
SUBDIR += libxdiff
SUBDIR += libxml++26
SUBDIR += libxml++26-reference
diff --git a/textproc/libwps/Makefile b/textproc/libwps/Makefile
index bc9630b28c91..c47e6acde8d0 100644
--- a/textproc/libwps/Makefile
+++ b/textproc/libwps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libwps
PORTVERSION= 0.2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,17 +15,12 @@ LICENSE_COMB= dual
LIB_DEPENDS= libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
-OPTIONS_DEFINE= DOCS
-
-CONFIGURE_ARGS= --disable-werror
+CONFIGURE_ARGS= --disable-werror --without-docs
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
USES= compiler:features libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-PORTDOCS= *
-DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
-DOCS_CONFIGURE_OFF= --without-docs
.include <bsd.port.pre.mk>
@@ -36,4 +31,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boos
CONFIGURE_ARGS+= --with-sharedptr=boost
.endif
+post-stage:
+ @${RM} -f ${STAGEDIR}${PREFIX}/bin/*
+
.include <bsd.port.post.mk>
diff --git a/textproc/libwps/pkg-plist b/textproc/libwps/pkg-plist
index 8b9b90199000..dac0556fd621 100644
--- a/textproc/libwps/pkg-plist
+++ b/textproc/libwps/pkg-plist
@@ -1,6 +1,3 @@
-bin/wps2html
-bin/wps2raw
-bin/wps2text
include/libwps-0.2/libwps/WPSDocument.h
include/libwps-0.2/libwps/libwps.h
lib/libwps-0.2.la
@@ -8,5 +5,3 @@ lib/libwps-0.2.so
lib/libwps-0.2.so.2
lib/libwps-0.2.so.2.0.9
libdata/pkgconfig/libwps-0.2.pc
-@dirrm include/libwps-0.2/libwps
-@dirrm include/libwps-0.2
diff --git a/textproc/libwps03/Makefile b/textproc/libwps03/Makefile
new file mode 100644
index 000000000000..efba8aac4e05
--- /dev/null
+++ b/textproc/libwps03/Makefile
@@ -0,0 +1,35 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libwps
+PORTVERSION= 0.3.0
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMESUFFIX= 03
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Microsoft file word processor format import filter library
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+CONFIGURE_ARGS= --disable-werror
+CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-docs
+USES= compiler:features libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS+= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+= --with-sharedptr=boost
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libwps03/distinfo b/textproc/libwps03/distinfo
new file mode 100644
index 000000000000..820790800fe5
--- /dev/null
+++ b/textproc/libwps03/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libwps-0.3.0.tar.gz) = ec6f17caa6cd576a2851d92b4d48508d79bece4fc83b66b012e4c8026113d44a
+SIZE (libwps-0.3.0.tar.gz) = 639591
diff --git a/textproc/libwps03/pkg-descr b/textproc/libwps03/pkg-descr
new file mode 100644
index 000000000000..b9fabb298083
--- /dev/null
+++ b/textproc/libwps03/pkg-descr
@@ -0,0 +1,7 @@
+Libwps is a library (for use by word procesors, for example) for importing the
+Microsoft Works word processor file format. It imports Works format versions 2,
+3, 4, 5 (aka 2000), and 8 with some formatting. The scope of this project is
+just a Works word processor import filter, so there are no plans for supporting
+an export filter, spreadsheets, or databases.
+
+WWW: http://libwps.sourceforge.net/
diff --git a/textproc/libwps03/pkg-plist b/textproc/libwps03/pkg-plist
new file mode 100644
index 000000000000..aa06701ffa46
--- /dev/null
+++ b/textproc/libwps03/pkg-plist
@@ -0,0 +1,12 @@
+bin/wks2csv
+bin/wks2raw
+bin/wks2text
+bin/wps2html
+bin/wps2raw
+bin/wps2text
+include/libwps-0.3/libwps/WPSDocument.h
+include/libwps-0.3/libwps/libwps.h
+lib/libwps-0.3.so
+lib/libwps-0.3.so.3
+lib/libwps-0.3.so.3.0.0
+libdata/pkgconfig/libwps-0.3.pc