aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2018-03-02 21:06:24 +0800
committerfeld <feld@FreeBSD.org>2018-03-02 21:06:24 +0800
commit4b65ecabc3c25f4b9537b3f96d743ba5cb61320d (patch)
tree3f322b8304184dea464af082ec324219d83671fd /textproc
parent6404d231530a564fd994b9cbbe0b23dc3147b783 (diff)
downloadfreebsd-ports-gnome-4b65ecabc3c25f4b9537b3f96d743ba5cb61320d.tar.gz
freebsd-ports-gnome-4b65ecabc3c25f4b9537b3f96d743ba5cb61320d.tar.zst
freebsd-ports-gnome-4b65ecabc3c25f4b9537b3f96d743ba5cb61320d.zip
textproc/elasticsearch{5,6}: Fix symlink
Relative symlinks should only be used when both files are in the STAGEDIR. In this situation poudriere was producing usable packages because of the unique location of WRKSRC (/wrksrc/...) which caused the relative symlink to be deep enough "../../../../../" to hit the root of the filesystem and then point to the location of the file. However, users who were building the port directory with "make" or "portmaster" were getting symlinks that did not point to the right location. PR: 226234 226265 222261
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch5/Makefile4
-rw-r--r--textproc/elasticsearch6/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
index 947934a0d69f..a54e9d3c8535 100644
--- a/textproc/elasticsearch5/Makefile
+++ b/textproc/elasticsearch5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 5.6.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -74,7 +74,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
- ${INSTALL} -lrs ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
+ ${LN} -s ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
index 298aa59914e5..7b88fc0a8462 100644
--- a/textproc/elasticsearch6/Makefile
+++ b/textproc/elasticsearch6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -74,7 +74,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
- ${INSTALL} -lrs ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
+ ${LN} -s ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}