aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-05 00:53:46 +0800
committeraz <az@FreeBSD.org>2012-06-05 00:53:46 +0800
commit6b3a16e015b5d0b53831ba6fb12985c500cb2b3d (patch)
tree2a4393511589ece276ba3133345f500023c64a02 /textproc
parentc118f713b438a9ba647ee8e4509ca685831dc391 (diff)
downloadfreebsd-ports-gnome-6b3a16e015b5d0b53831ba6fb12985c500cb2b3d.tar.gz
freebsd-ports-gnome-6b3a16e015b5d0b53831ba6fb12985c500cb2b3d.tar.zst
freebsd-ports-gnome-6b3a16e015b5d0b53831ba6fb12985c500cb2b3d.zip
- Remove SITE_PERL from *_DEPENDS
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-AI-Categorizer/Makefile14
-rw-r--r--textproc/p5-Lingua-EN-MatchNames/Makefile8
-rw-r--r--textproc/p5-Lingua-EN-NamedEntity/Makefile4
-rw-r--r--textproc/p5-Text-ParagraphDiff/Makefile4
-rw-r--r--textproc/p5-Text-WikiFormat/Makefile6
-rw-r--r--textproc/p5-XML-DBMS/Makefile8
-rw-r--r--textproc/p5-XML-Generator-PerlData/Makefile2
-rw-r--r--textproc/p5-XML-SimpleObject/Makefile2
-rw-r--r--textproc/p5-XML-XSLT/Makefile2
9 files changed, 25 insertions, 25 deletions
diff --git a/textproc/p5-AI-Categorizer/Makefile b/textproc/p5-AI-Categorizer/Makefile
index d6a631dc5ece..193b163735da 100644
--- a/textproc/p5-AI-Categorizer/Makefile
+++ b/textproc/p5-AI-Categorizer/Makefile
@@ -15,14 +15,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatic Text Categorization
-BUILD_DEPENDS= ${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
+BUILD_DEPENDS= p5-Class-Container>=0:${PORTSDIR}/devel/p5-Class-Container \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/Statistics/Contingency.pm:${PORTSDIR}/math/p5-Statistics-Contingency \
- ${SITE_PERL}/Lingua/Stem.pm:${PORTSDIR}/textproc/p5-Lingua-Stem \
- ${SITE_PERL}/Time/Progress.pm:${PORTSDIR}/devel/p5-Time-Progress \
- ${SITE_PERL}/${PERL_ARCH}/Algorithm/SVM.pm:${PORTSDIR}/devel/p5-Algorithm-SVM \
- ${SITE_PERL}/${PERL_ARCH}/AI/DecisionTree.pm:${PORTSDIR}/math/p5-AI-DecisionTree \
- ${SITE_PERL}/Algorithm/NaiveBayes.pm:${PORTSDIR}/devel/p5-Algorithm-NaiveBayes
+ p5-Statistics-Contingency>=0:${PORTSDIR}/math/p5-Statistics-Contingency \
+ p5-Lingua-Stem>=0:${PORTSDIR}/textproc/p5-Lingua-Stem \
+ p5-Time-Progress>=0:${PORTSDIR}/devel/p5-Time-Progress \
+ p5-Algorithm-SVM>=0:${PORTSDIR}/devel/p5-Algorithm-SVM \
+ p5-AI-DecisionTree>=0:${PORTSDIR}/math/p5-AI-DecisionTree \
+ p5-Algorithm-NaiveBayes>=0:${PORTSDIR}/devel/p5-Algorithm-NaiveBayes
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= AI::Categorizer.3 \
diff --git a/textproc/p5-Lingua-EN-MatchNames/Makefile b/textproc/p5-Lingua-EN-MatchNames/Makefile
index bafedc6fc4bd..604c1b6ad83b 100644
--- a/textproc/p5-Lingua-EN-MatchNames/Makefile
+++ b/textproc/p5-Lingua-EN-MatchNames/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Smart matching for human names
-BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/NameParse.pm:${PORTSDIR}/textproc/p5-Lingua-EN-NameParse \
- ${SITE_PERL}/Lingua/EN/Nickname.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Nickname \
- ${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx \
- ${SITE_PERL}/${PERL_ARCH}/Text/Metaphone.pm:${PORTSDIR}/textproc/p5-Text-Metaphone
+BUILD_DEPENDS= p5-Lingua-EN-NameParse>=0:${PORTSDIR}/textproc/p5-Lingua-EN-NameParse \
+ p5-Lingua-EN-Nickname>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Nickname \
+ p5-String-Approx>=0:${PORTSDIR}/devel/p5-String-Approx \
+ p5-Text-Metaphone>=0:${PORTSDIR}/textproc/p5-Text-Metaphone
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Lingua-EN-NamedEntity/Makefile b/textproc/p5-Lingua-EN-NamedEntity/Makefile
index 798d64f03c87..ca8aeacbbdc5 100644
--- a/textproc/p5-Lingua-EN-NamedEntity/Makefile
+++ b/textproc/p5-Lingua-EN-NamedEntity/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Basic Named Entity Extraction algorithm
-RUN_DEPENDS= ${SITE_PERL}/Lingua/Stem/En.pm:${PORTSDIR}/textproc/p5-Lingua-Stem \
- ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-Lingua-Stem>=0:${PORTSDIR}/textproc/p5-Lingua-Stem \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Text-ParagraphDiff/Makefile b/textproc/p5-Text-ParagraphDiff/Makefile
index 3a6f5790d0d5..216c2ee77f69 100644
--- a/textproc/p5-Text-ParagraphDiff/Makefile
+++ b/textproc/p5-Text-ParagraphDiff/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Visual difference for paragraphed text
-BUILD_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser
+BUILD_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Text-WikiFormat/Makefile b/textproc/p5-Text-WikiFormat/Makefile
index 1304b3a3d740..ef5a5be37ad2 100644
--- a/textproc/p5-Text-WikiFormat/Makefile
+++ b/textproc/p5-Text-WikiFormat/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Module for translating Wiki formatted text into other formats
-BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
PERL_MODBUILD= yes
diff --git a/textproc/p5-XML-DBMS/Makefile b/textproc/p5-XML-DBMS/Makefile
index 3fadde17cd7e..3bfc66c8698e 100644
--- a/textproc/p5-XML-DBMS/Makefile
+++ b/textproc/p5-XML-DBMS/Makefile
@@ -16,10 +16,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl port of Java package XML-DBMS v1.0
-BUILD_DEPENDS= ${SITE_PERL}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-libxml>=0:${PORTSDIR}/textproc/p5-libxml \
+ p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/textproc/p5-XML-Generator-PerlData/Makefile b/textproc/p5-XML-Generator-PerlData/Makefile
index 30b9eb546ffa..6507c84def5c 100644
--- a/textproc/p5-XML-Generator-PerlData/Makefile
+++ b/textproc/p5-XML-Generator-PerlData/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension for generating SAX2 events from Perl data structures
-BUILD_DEPENDS= ${SITE_PERL}/XML/SAX/Base.pm:${PORTSDIR}/textproc/p5-XML-SAX
+BUILD_DEPENDS= p5-XML-SAX>=0:${PORTSDIR}/textproc/p5-XML-SAX
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/textproc/p5-XML-SimpleObject/Makefile b/textproc/p5-XML-SimpleObject/Makefile
index 675ca00f312e..29d54102d2b7 100644
--- a/textproc/p5-XML-SimpleObject/Makefile
+++ b/textproc/p5-XML-SimpleObject/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= API for accessing the structure of an XML document
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
WRKSRC?= ${WRKDIR}/${PORTNAME}${PORTVERSION}
diff --git a/textproc/p5-XML-XSLT/Makefile b/textproc/p5-XML-XSLT/Makefile
index 37f9ce5569b2..9c00d3229238 100644
--- a/textproc/p5-XML-XSLT/Makefile
+++ b/textproc/p5-XML-XSLT/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= XML::XSLT - A perl module for processing XSLT
-BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes