aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-07-01 06:36:05 +0800
committerfeld <feld@FreeBSD.org>2016-07-01 06:36:05 +0800
commit7cb4828b49f0ad60016f4b274d81cade51820661 (patch)
tree7895fb425cc0e6e051444b62a5a29af43757ceff /textproc
parent0695bcc98cdf5f87905d63f5e688980642defcec (diff)
downloadfreebsd-ports-gnome-7cb4828b49f0ad60016f4b274d81cade51820661.tar.gz
freebsd-ports-gnome-7cb4828b49f0ad60016f4b274d81cade51820661.tar.zst
freebsd-ports-gnome-7cb4828b49f0ad60016f4b274d81cade51820661.zip
textproc/expat2: Patch vulnerability
This patch resolves a vulnerability that may still exist due to compiler optimizations. The previous patches for CVE-2015-1283 and CVE-2015-2716 may not work as intended in some situations. MFH: 2016Q2 Security: CVE-2016-4472
Diffstat (limited to 'textproc')
-rw-r--r--textproc/expat2/Makefile2
-rw-r--r--textproc/expat2/files/patch-CVE-2016-447226
2 files changed, 27 insertions, 1 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index 5a566c5e8f1c..682a58b76d15 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= expat
PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF
diff --git a/textproc/expat2/files/patch-CVE-2016-4472 b/textproc/expat2/files/patch-CVE-2016-4472
new file mode 100644
index 000000000000..dbce55e07d3d
--- /dev/null
+++ b/textproc/expat2/files/patch-CVE-2016-4472
@@ -0,0 +1,26 @@
+ expat/CMakeLists.txt | 3 +++
+ expat/lib/xmlparse.c | 48 +++++++++++++++++++++++++++++++++++++++++-------
+ 2 files changed, 44 insertions(+), 7 deletions(-)
+
+--- lib/xmlparse.c.orig 2016-06-30 22:23:11 UTC
++++ lib/xmlparse.c
+@@ -1693,7 +1693,8 @@ XML_GetBuffer(XML_Parser parser, int len
+ }
+
+ if (len > bufferLim - bufferEnd) {
+- int neededSize = len + (int)(bufferEnd - bufferPtr);
++ /* Do not invoke signed arithmetic overflow: */
++ int neededSize = (int) ((unsigned)len + (unsigned)(bufferEnd - bufferPtr));
+ if (neededSize < 0) {
+ errorCode = XML_ERROR_NO_MEMORY;
+ return NULL;
+@@ -1725,7 +1726,8 @@ XML_GetBuffer(XML_Parser parser, int len
+ if (bufferSize == 0)
+ bufferSize = INIT_BUFFER_SIZE;
+ do {
+- bufferSize *= 2;
++ /* Do not invoke signed arithmetic overflow: */
++ bufferSize = (int) (2U * (unsigned) bufferSize);
+ } while (bufferSize < neededSize && bufferSize > 0);
+ if (bufferSize <= 0) {
+ errorCode = XML_ERROR_NO_MEMORY;