aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-18 04:56:00 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-18 04:56:00 +0800
commit7d2cb01a2140d25a50cb02943d077fcfc2f14a9e (patch)
tree81bca8d498f0aadd7b13cdfb23c0cc09920fcb33 /textproc
parent50f79521cd78adb1a092fb15152026d51807cbac (diff)
downloadfreebsd-ports-gnome-7d2cb01a2140d25a50cb02943d077fcfc2f14a9e.tar.gz
freebsd-ports-gnome-7d2cb01a2140d25a50cb02943d077fcfc2f14a9e.tar.zst
freebsd-ports-gnome-7d2cb01a2140d25a50cb02943d077fcfc2f14a9e.zip
- Respect PREFIX and CFLAGS
- Bump PORTREVISION PR: 87582 Submitted by: David Le Brun <david@dyn-ns.net> (maintainer) Approved by: novel (mentor) (implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmlindent/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/textproc/xmlindent/Makefile b/textproc/xmlindent/Makefile
index a82545c1baea..486b836050d3 100644
--- a/textproc/xmlindent/Makefile
+++ b/textproc/xmlindent/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xmlindent
PORTVERSION= 0.2.17
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,13 +16,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= david@dyn-ns.net
COMMENT= XML stream reformatter
-USE_REINPLACE= yes
-MAN1= xmlindent.1
MANCOMPRESSED= no
+
+SOURCES= error.c indent.c buffer.c main.c
+
+MAN1= xmlindent.1
PLIST_FILES= bin/xmlindent
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|/share/man/|/man/|' ${WRKSRC}/Makefile
+do-build:
+ @cd ${WRKSRC}; flex xmlindent.yy
+ ${CC} ${CFLAGS} ${SOURCES:C/(.*)/${WRKSRC}\/\1/} -o ${WRKSRC}/${PORTNAME} -lfl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
.include <bsd.port.mk>