aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-11-14 14:34:55 +0800
committerwen <wen@FreeBSD.org>2011-11-14 14:34:55 +0800
commit7dddc5f273ec1282541cc52ab2f4b641c8e151b6 (patch)
tree4906bb3ac8a4dd0de4740789b9a293342477c6e3 /textproc
parent761c65420ed8ef1e69b86090247397cc1e9bebe9 (diff)
downloadfreebsd-ports-gnome-7dddc5f273ec1282541cc52ab2f4b641c8e151b6.tar.gz
freebsd-ports-gnome-7dddc5f273ec1282541cc52ab2f4b641c8e151b6.tar.zst
freebsd-ports-gnome-7dddc5f273ec1282541cc52ab2f4b641c8e151b6.zip
This package provides a parser and renderers for the classic Zope
"structured text" markup dialect (STX). STX is a plain text markup in which document structure is signalled primarily by identation. WWW: http://pypi.python.org/pypi/zope.structuredtext Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> (via github) Feature safe: yes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-zope.structuredtext/Makefile23
-rw-r--r--textproc/py-zope.structuredtext/distinfo2
-rw-r--r--textproc/py-zope.structuredtext/pkg-descr5
-rw-r--r--textproc/py-zope.structuredtext/pkg-plist57
5 files changed, 88 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index bb3fba8e6bf2..b00a05d62f6a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1136,6 +1136,7 @@
SUBDIR += py-xmltools
SUBDIR += py-xmltv
SUBDIR += py-zope.i18nmessageid
+ SUBDIR += py-zope.structuredtext
SUBDIR += py-zope.tal
SUBDIR += py-zpt
SUBDIR += py2html
diff --git a/textproc/py-zope.structuredtext/Makefile b/textproc/py-zope.structuredtext/Makefile
new file mode 100644
index 000000000000..dd267dd71426
--- /dev/null
+++ b/textproc/py-zope.structuredtext/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-zope.structuredtext
+# Date created: Nov 14, 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.structuredtext
+PORTVERSION= 3.5.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= zope
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= StructuredText parser
+
+LICENSE= ZPL21
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/textproc/py-zope.structuredtext/distinfo b/textproc/py-zope.structuredtext/distinfo
new file mode 100644
index 000000000000..f26cc17650e8
--- /dev/null
+++ b/textproc/py-zope.structuredtext/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope/zope.structuredtext-3.5.1.tar.gz) = 12b9119ccc737470da73ee777118068db171e77ef9f28e69360905da8b8dbc70
+SIZE (zope/zope.structuredtext-3.5.1.tar.gz) = 59461
diff --git a/textproc/py-zope.structuredtext/pkg-descr b/textproc/py-zope.structuredtext/pkg-descr
new file mode 100644
index 000000000000..c718d7889963
--- /dev/null
+++ b/textproc/py-zope.structuredtext/pkg-descr
@@ -0,0 +1,5 @@
+This package provides a parser and renderers for the classic Zope
+"structured text" markup dialect (STX). STX is a plain text markup
+in which document structure is signalled primarily by identation.
+
+WWW: http://pypi.python.org/pypi/zope.structuredtext
diff --git a/textproc/py-zope.structuredtext/pkg-plist b/textproc/py-zope.structuredtext/pkg-plist
new file mode 100644
index 000000000000..ca889ba52ae1
--- /dev/null
+++ b/textproc/py-zope.structuredtext/pkg-plist
@@ -0,0 +1,57 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/namespace_packages.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/docbook.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/docbook.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/docbook.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/document.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/document.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/document.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/html.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/html.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/html.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/Acquisition.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/Acquisition.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/ExtensionClass.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/ExtensionClass.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/InnerLinks.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/InnerLinks.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/Links.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/Links.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/MultiMapping.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/MultiMapping.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/examples.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/examples.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/examples1.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/examples1.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/index.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/index.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/table.ref
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions/table.stx
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stdom.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stdom.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stdom.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stletters.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stletters.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stletters.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stng.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stng.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/stng.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/tests.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext/regressions
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope/structuredtext
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/zope
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%