aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-07-20 13:26:35 +0800
committerrafan <rafan@FreeBSD.org>2007-07-20 13:26:35 +0800
commit8452b6d1a9099dc5249c7d589a6e8423c45ebd08 (patch)
tree047dc2b069fee28ba46bdc18fb5ed6e892c87b83 /textproc
parent092b63ffa6e440d7d1243e99ebc8a3189cfd9a0e (diff)
downloadfreebsd-ports-gnome-8452b6d1a9099dc5249c7d589a6e8423c45ebd08.tar.gz
freebsd-ports-gnome-8452b6d1a9099dc5249c7d589a6e8423c45ebd08.tar.zst
freebsd-ports-gnome-8452b6d1a9099dc5249c7d589a6e8423c45ebd08.zip
QStarDict is a StarDict clone written with using Qt4.
The user interface is similar to StarDict. Main features * Full support of StarDict dictionaries * Working in system tray * Scanning mouse selection and showing popup window with translation of selected word WWW: http://qstardict.ylsoftware.com/ Note that it is a GPLv3 software. PR: ports/114556 Submitted by: Yinghong.Liu <relaxbsd at gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/qstardict/Makefile53
-rw-r--r--textproc/qstardict/distinfo3
-rw-r--r--textproc/qstardict/pkg-descr10
-rw-r--r--textproc/qstardict/pkg-message11
-rw-r--r--textproc/qstardict/pkg-plist8
6 files changed, 86 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 317a06187c5e..10157d063c79 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -797,6 +797,7 @@
SUBDIR += py2html
SUBDIR += pybook
SUBDIR += pychm
+ SUBDIR += qstardict
SUBDIR += qt4-xml
SUBDIR += qu-aspell
SUBDIR += queequeg
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
new file mode 100644
index 000000000000..3a34552a390c
--- /dev/null
+++ b/textproc/qstardict/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: qstardict
+# Date created: 12 Jul 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qstardict
+PORTVERSION= 0.03
+CATEGORIES= textproc
+MASTER_SITES= http://qstardict.ylsoftware.com/files/ \
+ ftp://local-distfiles.freebsd.org.cn/pub/china-ports/hamigua/
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A StarDict clone written with using Qt4
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui corelib qmake uic moc rcc
+
+DICPATH= ${PREFIX}/share/gnome/stardict/dic
+
+PORTDOCS= AUTHORS COPYNG ChangeLog INSTALL README THANKS
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
+ ${WRKSRC}/qstardict.pro
+ @${REINPLACE_CMD} -e "s|/usr/share/stardict/dic|${DICPATH}|g" \
+ ${WRKSRC}/src/dictcore.cpp
+
+post-configure:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE}
+
+post-install:
+.if !defined(WITHOUT_NLS)
+ @${MKDIR} ${DATADIR}/translations
+ (cd ${WRKSRC}/translations/ && ${COPYTREE_SHARE} '*.qm' ${DATADIR}/translations)
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in AUTHORS COPYNG ChangeLog INSTALL README THANKS
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/qstardict/distinfo b/textproc/qstardict/distinfo
new file mode 100644
index 000000000000..c7dd1440eb30
--- /dev/null
+++ b/textproc/qstardict/distinfo
@@ -0,0 +1,3 @@
+MD5 (qstardict-0.03.tar.bz2) = 5e4ba2a3fcf712b4a30bd2d1cb4889fd
+SHA256 (qstardict-0.03.tar.bz2) = a710c4e3c9894a2243b44798f35782cdc27f8d92a1b4acf7bc83ffa13e98a9a0
+SIZE (qstardict-0.03.tar.bz2) = 179052
diff --git a/textproc/qstardict/pkg-descr b/textproc/qstardict/pkg-descr
new file mode 100644
index 000000000000..1d36a340855e
--- /dev/null
+++ b/textproc/qstardict/pkg-descr
@@ -0,0 +1,10 @@
+QStarDict is a StarDict clone written with using Qt4.
+The user interface is similar to StarDict.
+
+Main features
+* Full support of StarDict dictionaries
+* Working in system tray
+* Scanning mouse selection and showing popup window
+ with translation of selected word
+
+WWW: http://qstardict.ylsoftware.com/
diff --git a/textproc/qstardict/pkg-message b/textproc/qstardict/pkg-message
new file mode 100644
index 000000000000..aa2fbe4c7702
--- /dev/null
+++ b/textproc/qstardict/pkg-message
@@ -0,0 +1,11 @@
+=======================================================================
+QStarDict can support for StarDict dictionaries.
+You can install some dictionaries for StarDict(QStarDict):
+
+ chinese/stardict2-dict-zh_CN Simplified Chinese - English
+ chinese/stardict2-dict-zh_TW Traditional Chinese - English
+ japanese/stardict2-dict-ja Japanese - English
+ korean/stardict2-dict-kr orean and foreign language Dictionaries
+ textproc/stardict2-dictd_mova Dictionaries from www.mova.org
+ textproc/stardict2-quick Dictionaries from Quick for StarDict
+=======================================================================
diff --git a/textproc/qstardict/pkg-plist b/textproc/qstardict/pkg-plist
new file mode 100644
index 000000000000..9288cf15c80d
--- /dev/null
+++ b/textproc/qstardict/pkg-plist
@@ -0,0 +1,8 @@
+bin/qstardict
+share/applications/qstardict.desktop
+share/pixmaps/qstardict.png
+%%NLS%%%%DATADIR%%/translations/qstardict-ru_RU.qm
+%%NLS%%%%DATADIR%%/translations/qstardict-zh_TW.qm
+%%NLS%%@dirrm %%DATADIR%%/translations
+%%NLS%%@dirrm %%DATADIR%%
+@dirrmtry share/applications