aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
committerlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
commit92df36cb4f060e53f821e67dff720610621261e0 (patch)
treec51388c2c26e8fc4241309ebb4a13b91e275da69 /textproc
parentf7bec0a60889d39376e4a9a13050951960059bb2 (diff)
downloadfreebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.tar.gz
freebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.tar.zst
freebsd-ports-gnome-92df36cb4f060e53f821e67dff720610621261e0.zip
- bsd.qt.mk:
QT_COMPONENTS can now be depended on at runtime or buildtime only by specifiying them as <component>_build or <component>_run, respectively. Specifying <component> without any suffix will depend on the component at both build- and runtime just like before. - Convert Qt core ports to use the new dependency switches. - Add a patch to corelib to fix Qt4 on ARM, submitted by: Björn König <bkoenig@alpha-tierchen.de>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/qt4-xml/Makefile8
-rw-r--r--textproc/qt4-xml/pkg-plist1
2 files changed, 4 insertions, 5 deletions
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 9aacf23f96c7..3c2fe41250ee 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt XML library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib
+QT_COMPONENTS= qmake_build moc_build corelib
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -45,8 +45,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -59,10 +57,10 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/qt4-xml/pkg-plist b/textproc/qt4-xml/pkg-plist
index 1bdf9f64b59c..98401099712f 100644
--- a/textproc/qt4-xml/pkg-plist
+++ b/textproc/qt4-xml/pkg-plist
@@ -54,5 +54,6 @@ lib/libQtXml.so
lib/libQtXml.so.4
lib/libQtXml.so.4.3
lib/libQtXml.so.4.3.0
+%%DEBUG%%lib/libQtXml.so.4.3.0.debug
libdata/pkgconfig/QtXml.pc
@dirrm include/QtXml