aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-04-10 02:50:23 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-04-10 02:50:23 +0800
commit93c5824d8b2ded62fc77ab1383a1b299655b632e (patch)
tree27eeab935de6b3f3af77c9d218a757d4d2c23d1b /textproc
parent697ad90e2c26e968c1d4396e480c427309a617c2 (diff)
downloadfreebsd-ports-gnome-93c5824d8b2ded62fc77ab1383a1b299655b632e.tar.gz
freebsd-ports-gnome-93c5824d8b2ded62fc77ab1383a1b299655b632e.tar.zst
freebsd-ports-gnome-93c5824d8b2ded62fc77ab1383a1b299655b632e.zip
Add py-elasticsearch-async 6.0.0
This is an adapter for elasticsearch providing a transport layer based on Python's asyncio module. All API calls now return a future wrapping the response. WWW: https://pypi.python.org/pypi/elasticsearch-async WWW: https://github.com/elastic/elasticsearch-py-async
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-elasticsearch-async/Makefile27
-rw-r--r--textproc/py-elasticsearch-async/distinfo3
-rw-r--r--textproc/py-elasticsearch-async/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7712ce16a171..84903eb2ffcb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1287,6 +1287,7 @@
SUBDIR += py-docutils
SUBDIR += py-dsv
SUBDIR += py-elasticsearch
+ SUBDIR += py-elasticsearch-async
SUBDIR += py-elasticsearch5
SUBDIR += py-elasticsearch-curator
SUBDIR += py-elasticsearch-dsl-py
diff --git a/textproc/py-elasticsearch-async/Makefile b/textproc/py-elasticsearch-async/Makefile
new file mode 100644
index 000000000000..aa985c2119f6
--- /dev/null
+++ b/textproc/py-elasticsearch-async/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch-async
+PORTVERSION= 6.0.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Elasticsearch Async Client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}async_timeout>=0:devel/py-async_timeout@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}elasticsearch>=6.0.0:textproc/py-elasticsearch@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python:3.4+
+
+.include <bsd.port.mk>
diff --git a/textproc/py-elasticsearch-async/distinfo b/textproc/py-elasticsearch-async/distinfo
new file mode 100644
index 000000000000..5e9e4453d938
--- /dev/null
+++ b/textproc/py-elasticsearch-async/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523290496
+SHA256 (elasticsearch-async-6.0.0.tar.gz) = 555f9b7bc97c3f0484d940525aabd559e0c87feccefa4448a4d11ddbf4870c5f
+SIZE (elasticsearch-async-6.0.0.tar.gz) = 10925
diff --git a/textproc/py-elasticsearch-async/pkg-descr b/textproc/py-elasticsearch-async/pkg-descr
new file mode 100644
index 000000000000..1791e4c4dd9a
--- /dev/null
+++ b/textproc/py-elasticsearch-async/pkg-descr
@@ -0,0 +1,6 @@
+This is an adapter for elasticsearch providing a transport layer based on
+Python's asyncio module. All API calls now return a future wrapping the
+response.
+
+WWW: https://pypi.python.org/pypi/elasticsearch-async
+WWW: https://github.com/elastic/elasticsearch-py-async