aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2017-08-17 17:45:13 +0800
committered <ed@FreeBSD.org>2017-08-17 17:45:13 +0800
commit93dca6be813ac4ea11d36cf00362a080e859067a (patch)
treeffb730f778ab7b919fbedead992f6b48f1346bb4 /textproc
parent11760cdda13f72c736b6adaa46655904bb699997 (diff)
downloadfreebsd-ports-gnome-93dca6be813ac4ea11d36cf00362a080e859067a.tar.gz
freebsd-ports-gnome-93dca6be813ac4ea11d36cf00362a080e859067a.tar.zst
freebsd-ports-gnome-93dca6be813ac4ea11d36cf00362a080e859067a.zip
Add py-pyPEG2.
I am currently in the process of creating ports for various components related to CloudABI, including ARPC (an RPC framework that supports file descriptor passing) and Flower (a capability-based network backplane). The former comes with a script called 'aprotoc' for creating C++ bindings for messages and RPC services. This script depends on Python's pyPEG2 package to parse (a subset of) Protobuf's .proto grammar. Reviewed by: wg Differential Revision: https://reviews.freebsd.org/D12048
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pyPEG2/Makefile20
-rw-r--r--textproc/py-pyPEG2/distinfo3
-rw-r--r--textproc/py-pyPEG2/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 421cf6731b95..4a47034e2a90 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1305,6 +1305,7 @@
SUBDIR += py-parsimonious
SUBDIR += py-pdfminer
SUBDIR += py-pss
+ SUBDIR += py-pyPEG2
SUBDIR += py-pyctpp2
SUBDIR += py-pyelasticsearch
SUBDIR += py-pyes
diff --git a/textproc/py-pyPEG2/Makefile b/textproc/py-pyPEG2/Makefile
new file mode 100644
index 000000000000..d319c08cca07
--- /dev/null
+++ b/textproc/py-pyPEG2/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ed Schouten <ed@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyPEG2
+PORTVERSION= 2.15.2
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= Parsing Expression Grammar (PEG) parser for Python
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES?= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pyPEG2/distinfo b/textproc/py-pyPEG2/distinfo
new file mode 100644
index 000000000000..20cf35c94514
--- /dev/null
+++ b/textproc/py-pyPEG2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502893061
+SHA256 (pyPEG2-2.15.2.tar.gz) = 2b2d4f80d8e1a9370b2a91f4a25f4abf7f69b85c8da84cd23ec36451958a1f6d
+SIZE (pyPEG2-2.15.2.tar.gz) = 40334
diff --git a/textproc/py-pyPEG2/pkg-descr b/textproc/py-pyPEG2/pkg-descr
new file mode 100644
index 000000000000..d31a06218442
--- /dev/null
+++ b/textproc/py-pyPEG2/pkg-descr
@@ -0,0 +1,7 @@
+PyPEG2 is a parser-interpreter for Parsing Expression Grammars (PEGs).
+
+PEGs look similar to context-free grammars (CFGs), except that the choice
+operator always picks the first matching option. This allows for parsing
+in linear time.
+
+WWW: https://fdik.org/pyPEG/