aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-12-29 20:59:31 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-12-29 20:59:31 +0800
commit961ab7dbff7b876fde7219df35026e1b03a18a41 (patch)
tree32056088e91029f1df189b81a29b9b0207519903 /textproc
parentd46a39eb1f541eff67b3bb14be562315812c5db3 (diff)
downloadfreebsd-ports-gnome-961ab7dbff7b876fde7219df35026e1b03a18a41.tar.gz
freebsd-ports-gnome-961ab7dbff7b876fde7219df35026e1b03a18a41.tar.zst
freebsd-ports-gnome-961ab7dbff7b876fde7219df35026e1b03a18a41.zip
A utility to split a diff patch into separate sections. It also features
splitting a patch file by hunks instead of the default by file. This is very useful for merging patches that fail to apply by only some hunks. WWW: https://github.com/benjsc/splitpatch
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/splitpatch/Makefile36
-rw-r--r--textproc/splitpatch/distinfo3
-rw-r--r--textproc/splitpatch/files/patch-man_pod2man.mk33
-rw-r--r--textproc/splitpatch/pkg-descr5
5 files changed, 78 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3a8f3a849da8..49c25b48cfe1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1591,6 +1591,7 @@
SUBDIR += sphinxsearch
SUBDIR += sphinxsearch-devel
SUBDIR += spiff
+ SUBDIR += splitpatch
SUBDIR += sq-hunspell
SUBDIR += sr-aspell
SUBDIR += sr-hunspell
diff --git a/textproc/splitpatch/Makefile b/textproc/splitpatch/Makefile
new file mode 100644
index 000000000000..0abb4718d313
--- /dev/null
+++ b/textproc/splitpatch/Makefile
@@ -0,0 +1,36 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= splitpatch
+PORTVERSION= 1.0.2016122801
+CATEGORIES= textproc
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Utility to split a diff patch into separate sections
+
+LICENSE= GPLv2+
+
+USES= gmake perl5
+USE_PERL5= build
+USE_RUBY= yes
+NO_ARCH= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= jaalto
+GH_TAGNAME= 13c5941
+
+PLIST_FILES= bin/splitpatch man/man1/splitpatch.1.gz
+
+# avoid build date in man page
+#MAKE_ENV+= PODCENTER=" "
+
+MAKE_JOBS_UNSAFE=yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.rb \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/splitpatch/distinfo b/textproc/splitpatch/distinfo
new file mode 100644
index 000000000000..7333cf83ff00
--- /dev/null
+++ b/textproc/splitpatch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1482940118
+SHA256 (jaalto-splitpatch-1.0.2016122801-13c5941_GH0.tar.gz) = d07e1c00794eefa2f3c2b7f204f4fbdfcbe1afcff595a88fbd3fce7b925584d9
+SIZE (jaalto-splitpatch-1.0.2016122801-13c5941_GH0.tar.gz) = 4798
diff --git a/textproc/splitpatch/files/patch-man_pod2man.mk b/textproc/splitpatch/files/patch-man_pod2man.mk
new file mode 100644
index 000000000000..4dabb2a0d3a6
--- /dev/null
+++ b/textproc/splitpatch/files/patch-man_pod2man.mk
@@ -0,0 +1,33 @@
+--- man/pod2man.mk.orig 2016-08-15 17:36:10 UTC
++++ man/pod2man.mk
+@@ -36,7 +36,6 @@ RELEASE ?= $(PACKAGE)
+
+ # Optional variables to set
+ MANSECT ?= 1
+-PODCENTER ?= $$(date "+%Y-%m-%d")
+
+ # Directories
+ MANSRC =
+@@ -46,7 +45,6 @@ MANPOD = $(MANSRC)$(PACKAGE).$(MANSECT)
+ MANPAGE = $(MANDEST)$(PACKAGE).$(MANSECT)
+
+ POD2MAN = pod2man
+-POD2MAN_FLAGS = --utf8
+
+ makeman: $(MANPAGE)
+
+@@ -54,12 +52,9 @@ $(MANPAGE): $(MANPOD)
+ # make target - create manual page from a *.pod page
+ podchecker $(MANPOD)
+ LC_ALL=C $(POD2MAN) $(POD2MAN_FLAGS) \
+- --center="$(PODCENTER)" \
++ --center=" " \
+ --name="$(PACKAGE)" \
+ --section="$(MANSECT)" \
+ --release="$(RELEASE)" \
+ $(MANPOD) \
+- > $(MANPAGE) && \
+- rm -f pod*.tmp
+-
+-# End of of Makefile part
++ > $(MANPAGE)
diff --git a/textproc/splitpatch/pkg-descr b/textproc/splitpatch/pkg-descr
new file mode 100644
index 000000000000..c08dfcd91157
--- /dev/null
+++ b/textproc/splitpatch/pkg-descr
@@ -0,0 +1,5 @@
+A utility to split a diff patch into separate sections. It also features
+splitting a patch file by hunks instead of the default by file. This is very
+useful for merging patches that fail to apply by only some hunks.
+
+WWW: https://github.com/benjsc/splitpatch