aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-01 12:51:13 +0800
committermarcus <marcus@FreeBSD.org>2002-07-01 12:51:13 +0800
commit9c6de8d9b484e2869e51f26f425d9a857dcec3ce (patch)
treeadd7f8204b1b711dd23bb37b3b8f7ab6da9ab9f6 /textproc
parenta1b30aa2d868ea6f7b0909cf3e6ebcef1e30ce82 (diff)
downloadfreebsd-ports-gnome-9c6de8d9b484e2869e51f26f425d9a857dcec3ce.tar.gz
freebsd-ports-gnome-9c6de8d9b484e2869e51f26f425d9a857dcec3ce.tar.zst
freebsd-ports-gnome-9c6de8d9b484e2869e51f26f425d9a857dcec3ce.zip
Allow the pkg-install script to traverse symbolic links looking for DTD files.
This fixes a problem where /usr/local might be a symlink. Reported by: Eric W. Bates <ericx@vineyard.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/scrollkeeper/Makefile2
-rw-r--r--textproc/scrollkeeper/pkg-install6
2 files changed, 4 insertions, 4 deletions
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
index cd03f6698aa8..dd21b7055e09 100644
--- a/textproc/scrollkeeper/Makefile
+++ b/textproc/scrollkeeper/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 0.3.9
PORTEPOCH= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-rc2
+MASTER_SITE_SUBDIR= 2.0.0/releases/gnome-2.0-desktop-final
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
diff --git a/textproc/scrollkeeper/pkg-install b/textproc/scrollkeeper/pkg-install
index ea42dfd90f4e..8c83f70aafa5 100644
--- a/textproc/scrollkeeper/pkg-install
+++ b/textproc/scrollkeeper/pkg-install
@@ -47,7 +47,7 @@ fi
#
# find the prefix for DocBook DTD
#
-found=`find ${PREFIX} -name docbookx.dtd 2> /dev/null`
+found=`find -L ${PREFIX} -name docbookx.dtd 2> /dev/null`
if [ "$found" = "" ] ; then
echo could not locate docbookx.dtd for DocBook XML
exit 1
@@ -119,7 +119,7 @@ xmlcatalog --noout --add "delegateURI" \
#
top=`dirname $docbookdir`
found=`find $top -iname "iso*amsb.ent" 2> /dev/null`
-found=`find ${PREFIX} -iname "iso*amsb.ent" 2> /dev/null`
+found=`find -L ${PREFIX} -iname "iso*amsb.ent" 2> /dev/null`
if [ "$found" = "" ] ; then
echo could not locate iso-amsb.ent of ISO DocBook entities
exit 1
@@ -208,7 +208,7 @@ xmlcatalog --noout --add "delegatePublic" \
#
top=`dirname $docbookdir`
found=`find $top -name chunk.xsl 2> /dev/null`
-found=`find ${PREFIX} -name chunk.xsl 2> /dev/null`
+found=`find -L ${PREFIX} -name chunk.xsl 2> /dev/null`
if [ "$found" = "" ] ; then
echo could not locate chunk-common.xsl of DocBook XSLT stylesheets
exit 1