aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-12-08 02:47:10 +0800
committerantoine <antoine@FreeBSD.org>2015-12-08 02:47:10 +0800
commitabc3ef681d043cc8ecb9a0cd941be3a0d49f3307 (patch)
tree18e7aec51ab0c0d948d4ba53e77257441444497c /textproc
parent1ba2892da70bd9d1610c5bdc0bedb70d60286bcd (diff)
downloadfreebsd-ports-gnome-abc3ef681d043cc8ecb9a0cd941be3a0d49f3307.tar.gz
freebsd-ports-gnome-abc3ef681d043cc8ecb9a0cd941be3a0d49f3307.tar.zst
freebsd-ports-gnome-abc3ef681d043cc8ecb9a0cd941be3a0d49f3307.zip
New port: textproc/py-et_xmlfile
et_xmlfile is a low memory library for creating large XML files. It is based upon the xmlfile module from lxml with the aim of allowing code to be developed that will work with both libraries. It was developed initially for the openpyxl project but is now a standalone module. WWW: https://bitbucket.org/openpyxl/et_xmlfile
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-et_xmlfile/Makefile18
-rw-r--r--textproc/py-et_xmlfile/distinfo2
-rw-r--r--textproc/py-et_xmlfile/pkg-descr6
4 files changed, 27 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 523fc355270b..a8f3e1c56291 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1217,6 +1217,7 @@
SUBDIR += py-empy
SUBDIR += py-enchant
SUBDIR += py-errorhandler
+ SUBDIR += py-et_xmlfile
SUBDIR += py-excelerator
SUBDIR += py-feedparser
SUBDIR += py-genshi
diff --git a/textproc/py-et_xmlfile/Makefile b/textproc/py-et_xmlfile/Makefile
new file mode 100644
index 000000000000..d17af00e5c16
--- /dev/null
+++ b/textproc/py-et_xmlfile/Makefile
@@ -0,0 +1,18 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= et_xmlfile
+PORTVERSION= 1.0.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Implementation of lxml.xmlfile for the standard library
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-et_xmlfile/distinfo b/textproc/py-et_xmlfile/distinfo
new file mode 100644
index 000000000000..29e0b1b3b22a
--- /dev/null
+++ b/textproc/py-et_xmlfile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (et_xmlfile-1.0.1.tar.gz) = 614d9722d572f6246302c4491846d2c393c199cfa4edc9af593437691683335b
+SIZE (et_xmlfile-1.0.1.tar.gz) = 8427
diff --git a/textproc/py-et_xmlfile/pkg-descr b/textproc/py-et_xmlfile/pkg-descr
new file mode 100644
index 000000000000..e4a984b64cc8
--- /dev/null
+++ b/textproc/py-et_xmlfile/pkg-descr
@@ -0,0 +1,6 @@
+et_xmlfile is a low memory library for creating large XML files.
+It is based upon the xmlfile module from lxml with the aim of allowing code to
+be developed that will work with both libraries. It was developed initially for
+the openpyxl project but is now a standalone module.
+
+WWW: https://bitbucket.org/openpyxl/et_xmlfile