aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2018-05-06 20:31:02 +0800
committerlwhsu <lwhsu@FreeBSD.org>2018-05-06 20:31:02 +0800
commitad85a776a5555d63c61e700f724762721d64599d (patch)
tree237263deb5e2c15383001ce5263e410d3cb10add /textproc
parentb3afaf14d257f1119ab0418602a800b406ffdf68 (diff)
downloadfreebsd-ports-gnome-ad85a776a5555d63c61e700f724762721d64599d.tar.gz
freebsd-ports-gnome-ad85a776a5555d63c61e700f724762721d64599d.tar.zst
freebsd-ports-gnome-ad85a776a5555d63c61e700f724762721d64599d.zip
Add c2man, tool to generate documentation from C source code comments
Add with DEPRECATED but without EXPIRATION_DATE because it is not recommended for use in new projects. We still add this port because there is needed for building GNU FriBidi from git snapshot. PR: 226915 Submitted by: Ting-Wei Lan <lantw44@gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/c2man/Makefile35
-rw-r--r--textproc/c2man/distinfo3
-rw-r--r--textproc/c2man/files/patch-grammar.y22
-rw-r--r--textproc/c2man/files/patch-lex.l10
-rw-r--r--textproc/c2man/pkg-descr5
6 files changed, 76 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1ab95672d1f7..62332c23ea6d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -70,6 +70,7 @@
SUBDIR += bsdsort
SUBDIR += btparse
SUBDIR += c2html
+ SUBDIR += c2man
SUBDIR += ca-aspell
SUBDIR += catdoc
SUBDIR += cdif
diff --git a/textproc/c2man/Makefile b/textproc/c2man/Makefile
new file mode 100644
index 000000000000..e64158223696
--- /dev/null
+++ b/textproc/c2man/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= c2man
+PORTVERSION= ${VERSION}.${PATCHLEVEL}
+CATEGORIES= textproc
+MASTER_SITES= http://www.ciselant.de/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${VERSION}@${PATCHLEVEL}
+
+MAINTAINER= lantw44@gmail.com
+COMMENT= Tool to generate documentation from C source code comments
+
+LICENSE= ${PORTNAME}
+LICENSE_NAME= ${PORTNAME}
+LICENSE_FILE= ${WRKSRC}/README
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+DEPRECATED= Not recommended for use in new projects
+
+VERSION= 2.0
+PATCHLEVEL= 42
+
+NO_WRKSUBDIR= yes
+NO_INSTALL= yes
+
+PLIST_FILES= bin/c2man man/man1/c2man.1.gz
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT=Configure
+CONFIGURE_ARGS= -des -Dcc="${CC}" -Dccflags="${CFLAGS}" -Dldflags="${LDFLAGS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/textproc/c2man/distinfo b/textproc/c2man/distinfo
new file mode 100644
index 000000000000..d92d1724bac8
--- /dev/null
+++ b/textproc/c2man/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518289578
+SHA256 (c2man-2.0@42.tar.gz) = 0280ba17471da32216af2109e7e3b17ff2fda15f294d68efdc0108eca64cd577
+SIZE (c2man-2.0@42.tar.gz) = 188551
diff --git a/textproc/c2man/files/patch-grammar.y b/textproc/c2man/files/patch-grammar.y
new file mode 100644
index 000000000000..24aa753d11f9
--- /dev/null
+++ b/textproc/c2man/files/patch-grammar.y
@@ -0,0 +1,22 @@
+--- grammar.y.orig 1998-09-30 01:29:13 UTC
++++ grammar.y
+@@ -14,7 +14,7 @@
+ %token T_INLINE
+
+ /* type specifiers */
+-%token T_CHAR T_DOUBLE T_FLOAT T_INT T_VOID
++%token T_CHAR T_DOUBLE T_FLOAT T_INT T_VOID T_VALIST
+ %token T_LONG T_SHORT T_SIGNED T_UNSIGNED
+ %token T_ENUM T_STRUCT T_UNION
+
+@@ -374,6 +374,10 @@ type_specifier
+ {
+ new_decl_spec(&$$, "void", DS_NONE);
+ }
++ | T_VALIST
++ {
++ new_decl_spec(&$$, "va_list", DS_NONE);
++ }
+ | struct_or_union_specifier
+ | enum_specifier
+ | T_TYPEDEF_NAME
diff --git a/textproc/c2man/files/patch-lex.l b/textproc/c2man/files/patch-lex.l
new file mode 100644
index 000000000000..0d4178f7d706
--- /dev/null
+++ b/textproc/c2man/files/patch-lex.l
@@ -0,0 +1,10 @@
+--- lex.l.orig 2000-02-25 01:41:11 UTC
++++ lex.l
+@@ -167,6 +167,7 @@ QUOTED ({STRING}|\'(\\\'|[^'\n])*\'|\\.
+ <INITIAL>float return T_FLOAT;
+ <INITIAL>int return T_INT;
+ <INITIAL>void return T_VOID;
++<INITIAL>__builtin_va_list return T_VALIST;
+ <INITIAL>long return T_LONG;
+ <INITIAL>short return T_SHORT;
+ <INITIAL>signed return T_SIGNED;
diff --git a/textproc/c2man/pkg-descr b/textproc/c2man/pkg-descr
new file mode 100644
index 000000000000..fe4a88c904cc
--- /dev/null
+++ b/textproc/c2man/pkg-descr
@@ -0,0 +1,5 @@
+c2man is an obsolete and unmaintained documentation tool that extracts comments
+from C source code. Do not use this tool in new projects. The only reason for it
+to exist in FreeBSD ports is to allow building GNU FriBidi from a git snapshot.
+
+WWW: http://www.ciselant.de/c2man/c2man.html