aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-02-26 02:49:50 +0800
committerijliao <ijliao@FreeBSD.org>2001-02-26 02:49:50 +0800
commitae7e8ba4c71baba5dd378539815b3eda1e23454b (patch)
treec13d28662418de7c312c6f091d260b1e43bf7f84 /textproc
parent81e9f0e86c0165dfac2430d3202c00fea7c03126 (diff)
downloadfreebsd-ports-gnome-ae7e8ba4c71baba5dd378539815b3eda1e23454b.tar.gz
freebsd-ports-gnome-ae7e8ba4c71baba5dd378539815b3eda1e23454b.tar.zst
freebsd-ports-gnome-ae7e8ba4c71baba5dd378539815b3eda1e23454b.zip
add libxml++, XML API for C++
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libxml++/Makefile29
-rw-r--r--textproc/libxml++/distinfo1
-rw-r--r--textproc/libxml++/pkg-comment1
-rw-r--r--textproc/libxml++/pkg-descr5
-rw-r--r--textproc/libxml++/pkg-plist6
-rw-r--r--textproc/libxml++26/Makefile29
-rw-r--r--textproc/libxml++26/distinfo1
-rw-r--r--textproc/libxml++26/pkg-comment1
-rw-r--r--textproc/libxml++26/pkg-descr5
-rw-r--r--textproc/libxml++26/pkg-plist6
11 files changed, 85 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a9b7289f05aa..2a5710136c46 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -59,6 +59,7 @@
SUBDIR += latte
SUBDIR += latex2html
SUBDIR += libxml
+ SUBDIR += libxml++
SUBDIR += libxml2
SUBDIR += libxode
SUBDIR += libxslt
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
new file mode 100644
index 000000000000..2fd0adc70d10
--- /dev/null
+++ b/textproc/libxml++/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: libxml++
+# Date created: Feb 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml++
+PORTVERSION= 0.11
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/+/plus/g}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s|libxml/|libxml2/|g" ${WRKSRC}/xml++.h
+
+.include <bsd.port.mk>
diff --git a/textproc/libxml++/distinfo b/textproc/libxml++/distinfo
new file mode 100644
index 000000000000..b1fa474487f7
--- /dev/null
+++ b/textproc/libxml++/distinfo
@@ -0,0 +1 @@
+MD5 (libxml++-0.11.tar.gz) = cbe12b128eb73c3c5b2ecbe603e02faa
diff --git a/textproc/libxml++/pkg-comment b/textproc/libxml++/pkg-comment
new file mode 100644
index 000000000000..d1cd9c9f1f2b
--- /dev/null
+++ b/textproc/libxml++/pkg-comment
@@ -0,0 +1 @@
+XML API for C++
diff --git a/textproc/libxml++/pkg-descr b/textproc/libxml++/pkg-descr
new file mode 100644
index 000000000000..d9a4edbf9f77
--- /dev/null
+++ b/textproc/libxml++/pkg-descr
@@ -0,0 +1,5 @@
+libxml++ is a C++ interface for working with XML files, using libxml
+(gnome-xml) to parse and write the actual XML files. It has a simple
+but complete API.
+
+WWW: http://www.ari.lusis.org/xml++/
diff --git a/textproc/libxml++/pkg-plist b/textproc/libxml++/pkg-plist
new file mode 100644
index 000000000000..c8ea8e7b2053
--- /dev/null
+++ b/textproc/libxml++/pkg-plist
@@ -0,0 +1,6 @@
+bin/xml++-config
+include/xml++.h
+lib/libxml++.a
+lib/libxml++.so
+lib/libxml++.so.0
+share/aclocal/libxml++.m4
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
new file mode 100644
index 000000000000..2fd0adc70d10
--- /dev/null
+++ b/textproc/libxml++26/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: libxml++
+# Date created: Feb 26, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml++
+PORTVERSION= 0.11
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/+/plus/g}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s|xml-config|xml2-config|g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s|libxml/|libxml2/|g" ${WRKSRC}/xml++.h
+
+.include <bsd.port.mk>
diff --git a/textproc/libxml++26/distinfo b/textproc/libxml++26/distinfo
new file mode 100644
index 000000000000..b1fa474487f7
--- /dev/null
+++ b/textproc/libxml++26/distinfo
@@ -0,0 +1 @@
+MD5 (libxml++-0.11.tar.gz) = cbe12b128eb73c3c5b2ecbe603e02faa
diff --git a/textproc/libxml++26/pkg-comment b/textproc/libxml++26/pkg-comment
new file mode 100644
index 000000000000..d1cd9c9f1f2b
--- /dev/null
+++ b/textproc/libxml++26/pkg-comment
@@ -0,0 +1 @@
+XML API for C++
diff --git a/textproc/libxml++26/pkg-descr b/textproc/libxml++26/pkg-descr
new file mode 100644
index 000000000000..d9a4edbf9f77
--- /dev/null
+++ b/textproc/libxml++26/pkg-descr
@@ -0,0 +1,5 @@
+libxml++ is a C++ interface for working with XML files, using libxml
+(gnome-xml) to parse and write the actual XML files. It has a simple
+but complete API.
+
+WWW: http://www.ari.lusis.org/xml++/
diff --git a/textproc/libxml++26/pkg-plist b/textproc/libxml++26/pkg-plist
new file mode 100644
index 000000000000..c8ea8e7b2053
--- /dev/null
+++ b/textproc/libxml++26/pkg-plist
@@ -0,0 +1,6 @@
+bin/xml++-config
+include/xml++.h
+lib/libxml++.a
+lib/libxml++.so
+lib/libxml++.so.0
+share/aclocal/libxml++.m4