aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2016-03-10 01:03:10 +0800
committerdvl <dvl@FreeBSD.org>2016-03-10 01:03:10 +0800
commitb78e55b8b8c7da3718239eeccb4a0de181478f24 (patch)
treeb9a1b6bd85447079b17934120d1e5ec6d6f4bc62 /textproc
parentcbe7e45494757979bbc3942c7222f4d86654f9f0 (diff)
downloadfreebsd-ports-gnome-b78e55b8b8c7da3718239eeccb4a0de181478f24.tar.gz
freebsd-ports-gnome-b78e55b8b8c7da3718239eeccb4a0de181478f24.tar.zst
freebsd-ports-gnome-b78e55b8b8c7da3718239eeccb4a0de181478f24.zip
Add Marvel 2, an Elasticsearch monitoring plugin
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile3
-rw-r--r--textproc/elasticsearch-plugin-marvel2/Makefile46
-rw-r--r--textproc/elasticsearch-plugin-marvel2/distinfo4
-rw-r--r--textproc/elasticsearch-plugin-marvel2/pkg-descr4
-rw-r--r--textproc/elasticsearch-plugin-marvel2/pkg-plist10
5 files changed, 66 insertions, 1 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 73a4a5d3eae5..7ff046b1de52 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -156,6 +156,7 @@
SUBDIR += elasticsearch-plugin-head
SUBDIR += elasticsearch-plugin-hq
SUBDIR += elasticsearch-plugin-marvel
+ SUBDIR += elasticsearch-plugin-marvel2
SUBDIR += elasticsearch-plugin-sql
SUBDIR += elasticsearch-river-rabbitmq
SUBDIR += elasticsearch2
@@ -1216,10 +1217,10 @@
SUBDIR += py-chardet
SUBDIR += py-cloud_sptheme
SUBDIR += py-creole
- SUBDIR += py-curator
SUBDIR += py-diff-match-patch
SUBDIR += py-docutils
SUBDIR += py-dsv
+ SUBDIR += py-elasticsearch-curator
SUBDIR += py-elasticsearch-dsl-py
SUBDIR += py-elasticsearch-py
SUBDIR += py-elib.intl
diff --git a/textproc/elasticsearch-plugin-marvel2/Makefile b/textproc/elasticsearch-plugin-marvel2/Makefile
new file mode 100644
index 000000000000..8abec03fb676
--- /dev/null
+++ b/textproc/elasticsearch-plugin-marvel2/Makefile
@@ -0,0 +1,46 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= marvel
+PORTVERSION= 2.1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= http://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/${PORTVERSION}/:source1 \
+ http://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/marvel-agent/${PORTVERSION}/:source2
+PKGNAMEPREFIX= elasticsearch-plugin
+DISTFILES= license-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}:source1 \
+ marvel-agent-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}:source2
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= ElasticSearch Marvel Monitoring Plugin
+
+LICENSE= COMMERCIAL
+LICENSE_NAME= Free for development; license required for production use
+LICENSE_TEXT= License available from Elasticsearch for production use.
+LICENSE_TEXT+= See http://www.elasticsearch.com/marvel/ for more details.
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell no-auto-accept
+
+RUN_DEPENDS:= elasticsearch2>2.0.0:${PORTSDIR}/textproc/elasticsearch2
+
+NO_BUILD= yes
+LEGAL_TEXT= ${LICENSE_NAME_COMMERCIAL}
+PLIST_SUB= VERSION=${PORTVERSION}
+
+USES+= zip
+
+ZIP_FILES= license \
+ marvel-agent
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for file in ${ZIP_FILES}
+ ( cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} -d ${file}-${PORTVERSION} \
+ ${_DISTDIR}/${file}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX} )
+.endfor
+
+do-install:
+.for file in ${ZIP_FILES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/${file}
+ @cd ${WRKDIR}/${file}-${PORTVERSION} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch-plugin-marvel2/distinfo b/textproc/elasticsearch-plugin-marvel2/distinfo
new file mode 100644
index 000000000000..3a9bf75e0bb1
--- /dev/null
+++ b/textproc/elasticsearch-plugin-marvel2/distinfo
@@ -0,0 +1,4 @@
+SHA256 (license-2.1.0.zip) = 7705f011c1027be520143f834031f79f15e3c378924f7a05a934e413c31937af
+SIZE (license-2.1.0.zip) = 102034
+SHA256 (marvel-agent-2.1.0.zip) = f9d118c67255d762b5692813dad3fa098bb16cc465dbf857898a794a43732caa
+SIZE (marvel-agent-2.1.0.zip) = 153231
diff --git a/textproc/elasticsearch-plugin-marvel2/pkg-descr b/textproc/elasticsearch-plugin-marvel2/pkg-descr
new file mode 100644
index 000000000000..fbcd5bdad85a
--- /dev/null
+++ b/textproc/elasticsearch-plugin-marvel2/pkg-descr
@@ -0,0 +1,4 @@
+Marvel is an Elasticsearch management tool. This tool is free for
+development use but requires a license to be used in production.
+
+WWW: http://www.elasticsearch.org/overview/marvel/download/
diff --git a/textproc/elasticsearch-plugin-marvel2/pkg-plist b/textproc/elasticsearch-plugin-marvel2/pkg-plist
new file mode 100644
index 000000000000..9b549b9d001d
--- /dev/null
+++ b/textproc/elasticsearch-plugin-marvel2/pkg-plist
@@ -0,0 +1,10 @@
+lib/elasticsearch/plugins/license/LICENSE.txt
+lib/elasticsearch/plugins/license/NOTICE.txt
+lib/elasticsearch/plugins/license/license-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/license-core-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/license-plugin-api-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/plugin-descriptor.properties
+lib/elasticsearch/plugins/marvel-agent/LICENSE.txt
+lib/elasticsearch/plugins/marvel-agent/NOTICE.txt
+lib/elasticsearch/plugins/marvel-agent/marvel-agent-%%VERSION%%.jar
+lib/elasticsearch/plugins/marvel-agent/plugin-descriptor.properties