aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
committerbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
commitba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /textproc
parent3fcb7028e93fb51c19b4379e9c99091b90563e30 (diff)
downloadfreebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.gz
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.zst
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.zip
Convert bsd.gnustep.mk to USES=gnustep
Simplify gnustep ports Hook into the regular ports framework: - LIB_DEPENDS for library dependencies - Use regular USE_LDCONFIG Reuse USES=objc (automatic) USE_GNUSTEP is now a macro to set the dependencies and build feature needed. Accepted arguments: back base build gui Merge deskutils/preferencepanes into deskutils/systempreferences
Diffstat (limited to 'textproc')
-rw-r--r--textproc/duncan/Makefile6
-rw-r--r--textproc/easydiff/Makefile6
-rw-r--r--textproc/latex-service/Makefile7
-rw-r--r--textproc/localize/Makefile6
-rw-r--r--textproc/popup/Makefile6
5 files changed, 10 insertions, 21 deletions
diff --git a/textproc/duncan/Makefile b/textproc/duncan/Makefile
index 70e3b6b606cd..05b3ae0cc70f 100644
--- a/textproc/duncan/Makefile
+++ b/textproc/duncan/Makefile
@@ -14,10 +14,8 @@ COMMENT= English to Thai dictionary for GNUstep
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/Duncan
diff --git a/textproc/easydiff/Makefile b/textproc/easydiff/Makefile
index b54327dccef6..0bc1f8dd8883 100644
--- a/textproc/easydiff/Makefile
+++ b/textproc/easydiff/Makefile
@@ -12,10 +12,8 @@ COMMENT= GNUstep graphical diff
LICENSE= GPLv2 # or later; COPYING has GPLv3
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/EasyDiff.app/EasyDiff
diff --git a/textproc/latex-service/Makefile b/textproc/latex-service/Makefile
index a690a3751628..f32af3d84291 100644
--- a/textproc/latex-service/Makefile
+++ b/textproc/latex-service/Makefile
@@ -13,11 +13,8 @@ COMMENT= LaTeX service for GNUstep
LICENSE= GPLv2
-USES= tar:tgz
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= tar:tgz gnustep
+USE_GNUSTEP= back build
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Services/LaTeX.service/LaTeX
diff --git a/textproc/localize/Makefile b/textproc/localize/Makefile
index f39442fbd6b4..1fea59bbe3ff 100644
--- a/textproc/localize/Makefile
+++ b/textproc/localize/Makefile
@@ -12,10 +12,8 @@ COMMENT= Application to aid in the translation of .strings files
LICENSE= GPLv2
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/Localize
diff --git a/textproc/popup/Makefile b/textproc/popup/Makefile
index 6c8a84dfa37b..1da72a52ccf0 100644
--- a/textproc/popup/Makefile
+++ b/textproc/popup/Makefile
@@ -12,9 +12,7 @@ COMMENT= Interactive learning aid for pairs of words
LICENSE= GPLv2
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= gnustep
+USE_GNUSTEP= back build
.include <bsd.port.mk>