aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /textproc
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'textproc')
-rw-r--r--textproc/expat2/Makefile3
-rw-r--r--textproc/expat2/files/patch-cve-2012-6702-plus-cve-2016-5300-v118
-rw-r--r--textproc/p5-XML-AutoWriter/Makefile3
-rw-r--r--textproc/p5-XML-AutoWriter/files/patch-Makefile.PL6
-rw-r--r--textproc/p5-XML-AutoWriter/files/patch-lib_XML_Doctype.pm (renamed from textproc/p5-XML-AutoWriter/files/patch-Doctype.pm)20
5 files changed, 26 insertions, 24 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index 00273026a61f..5a566c5e8f1c 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -12,7 +12,8 @@ COMMENT= XML 1.0 parser written in C
GNU_CONFIGURE= yes
ALL_TARGET= default
-USES= libtool pathfix tar:bz2
+USES= dos2unix libtool pathfix tar:bz2
+DOS2UNIX_GLOB= *.txt
USE_LDCONFIG= yes
post-stage:
diff --git a/textproc/expat2/files/patch-cve-2012-6702-plus-cve-2016-5300-v1 b/textproc/expat2/files/patch-cve-2012-6702-plus-cve-2016-5300-v1
index de962941c8de..23a47f43c816 100644
--- a/textproc/expat2/files/patch-cve-2012-6702-plus-cve-2016-5300-v1
+++ b/textproc/expat2/files/patch-cve-2012-6702-plus-cve-2016-5300-v1
@@ -39,15 +39,15 @@ index 353627e..524d514 100755
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -41,6 +41,9 @@ include_directories(${CMAKE_BINARY_DIR} ${CMAKE_SOURCE_DIR}/lib)
- if(MSVC)
- add_definitions(-D_CRT_SECURE_NO_WARNINGS -wd4996)
- endif(MSVC)
-+if(WIN32)
-+ add_definitions(-DCOMPILED_FROM_DSP)
-+endif(WIN32)
-
- set(expat_SRCS
- lib/xmlparse.c
+ if(MSVC)
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS -wd4996)
+ endif(MSVC)
++if(WIN32)
++ add_definitions(-DCOMPILED_FROM_DSP)
++endif(WIN32)
+
+ set(expat_SRCS
+ lib/xmlparse.c
diff --git a/expat/lib/xmlparse.c b/expat/lib/xmlparse.c
index e308c79..c5f942f 100644
--- lib/xmlparse.c
diff --git a/textproc/p5-XML-AutoWriter/Makefile b/textproc/p5-XML-AutoWriter/Makefile
index 70c20dfb6661..c9e1df7e5b04 100644
--- a/textproc/p5-XML-AutoWriter/Makefile
+++ b/textproc/p5-XML-AutoWriter/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
-USES= perl5
+USES= dos2unix perl5
+DOS2UNIX_GLOB= *.pm
USE_PERL5= configure
post-patch:
diff --git a/textproc/p5-XML-AutoWriter/files/patch-Makefile.PL b/textproc/p5-XML-AutoWriter/files/patch-Makefile.PL
index 4618fef63a73..885901fc6790 100644
--- a/textproc/p5-XML-AutoWriter/files/patch-Makefile.PL
+++ b/textproc/p5-XML-AutoWriter/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig 2012-12-23 11:07:17.511361339 +0900
-+++ Makefile.PL 2012-12-23 11:09:35.165438990 +0900
-@@ -9,7 +9,6 @@
+--- Makefile.PL.orig 2009-06-11 18:26:48 UTC
++++ Makefile.PL
+@@ -9,7 +9,6 @@ requires => 'XML::Parser';
build_requires => 'Test';
build_requires => 'IO::File';
diff --git a/textproc/p5-XML-AutoWriter/files/patch-Doctype.pm b/textproc/p5-XML-AutoWriter/files/patch-lib_XML_Doctype.pm
index d9d905f2fae4..be7993d4c047 100644
--- a/textproc/p5-XML-AutoWriter/files/patch-Doctype.pm
+++ b/textproc/p5-XML-AutoWriter/files/patch-lib_XML_Doctype.pm
@@ -1,12 +1,12 @@
---- lib/XML/Doctype.pm.orig Tue Dec 27 23:27:13 2005
-+++ lib/XML/Doctype.pm Mon Jan 30 23:43:38 2006
-@@ -62,7 +62,9 @@
- =cut
-
- use strict ;
+--- lib/XML/Doctype.pm.orig 2016-06-20 16:08:38 UTC
++++ lib/XML/Doctype.pm
+@@ -62,7 +62,9 @@ XML::Doctype::ENITITY
+ =cut
+
+ use strict ;
+use Config;
- use vars qw( $VERSION %_default_dtds ) ;
+ use vars qw( $VERSION %_default_dtds ) ;
+use lib $Config{sitelib};
- use fields (
- 'ELTS', # A hash of declared & undeclared elements, keyed by name
- 'NAME', # The root node (the name from the DOCTYPE decl).
+ use fields (
+ 'ELTS', # A hash of declared & undeclared elements, keyed by name
+ 'NAME', # The root node (the name from the DOCTYPE decl).