aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-11-04 15:32:20 +0800
committertj <tj@FreeBSD.org>2016-11-04 15:32:20 +0800
commitbe5fc3a0755d9548e02acb5839ff6c746244e365 (patch)
treec68f8ae6f1ea7bdd466ad31cdc9307f28ae6e132 /textproc
parent36964a903dc95ba30554a1ba212cde393ec80790 (diff)
downloadfreebsd-ports-gnome-be5fc3a0755d9548e02acb5839ff6c746244e365.tar.gz
freebsd-ports-gnome-be5fc3a0755d9548e02acb5839ff6c746244e365.tar.zst
freebsd-ports-gnome-be5fc3a0755d9548e02acb5839ff6c746244e365.zip
New port for elasticsearch x-pack plugins.
X-Pack is an Elastic Stack extension that bundles security, alerting, monitoring, reporting, and graph capabilities into one easy-to-install package. While the X-Pack components are designed to work together seamlessly, you can easily enable or disable the features you want to use. WWW: https://www.elastic.co/guide/en/x-pack/current/xpack-introduction.html
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch5-x-pack/Makefile28
-rw-r--r--textproc/elasticsearch5-x-pack/distinfo3
-rw-r--r--textproc/elasticsearch5-x-pack/pkg-descr6
-rw-r--r--textproc/elasticsearch5-x-pack/pkg-plist49
5 files changed, 87 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ddb3c1e79800..f2c13f77cc87 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -162,6 +162,7 @@
SUBDIR += elasticsearch2-plugin-migration
SUBDIR += elasticsearch2-plugin-sql
SUBDIR += elasticsearch5
+ SUBDIR += elasticsearch5-x-pack
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
diff --git a/textproc/elasticsearch5-x-pack/Makefile b/textproc/elasticsearch5-x-pack/Makefile
new file mode 100644
index 000000000000..fff0bb4375a9
--- /dev/null
+++ b/textproc/elasticsearch5-x-pack/Makefile
@@ -0,0 +1,28 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= x-pack
+PORTVERSION= 5.0.0
+CATEGORIES= textproc java
+MASTER_SITES= https://artifacts.elastic.co/downloads/packs/x-pack/
+PKGNAMEPREFIX= elasticsearch5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Elasticsearch X-Pack plugins
+
+
+RUN_DEPENDS:= elasticsearch5>=5.0.0:textproc/elasticsearch5
+
+NO_BUILD= yes
+
+USES+= zip
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ ( cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} -d ${PORTNAME}-${PORTVERSION} \
+ ${_DISTDIR}${DISTFILES} )
+
+do-install:
+ @cd ${WRKSRC}/elasticsearch && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/x-pack
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch5-x-pack/distinfo b/textproc/elasticsearch5-x-pack/distinfo
new file mode 100644
index 000000000000..04e862e77a70
--- /dev/null
+++ b/textproc/elasticsearch5-x-pack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478242515
+SHA256 (x-pack-5.0.0.zip) = e05af3423e8504cf1e7b8e4f2ead4e7f7522fca174527ee94d6b93268dfdfa4a
+SIZE (x-pack-5.0.0.zip) = 72364732
diff --git a/textproc/elasticsearch5-x-pack/pkg-descr b/textproc/elasticsearch5-x-pack/pkg-descr
new file mode 100644
index 000000000000..7f61d3aeb614
--- /dev/null
+++ b/textproc/elasticsearch5-x-pack/pkg-descr
@@ -0,0 +1,6 @@
+X-Pack is an Elastic Stack extension that bundles security, alerting,
+monitoring, reporting, and graph capabilities into one easy-to-install package.
+While the X-Pack components are designed to work together seamlessly, you can
+easily enable or disable the features you want to use.
+
+WWW: https://www.elastic.co/guide/en/x-pack/current/xpack-introduction.html
diff --git a/textproc/elasticsearch5-x-pack/pkg-plist b/textproc/elasticsearch5-x-pack/pkg-plist
new file mode 100644
index 000000000000..5e53461481db
--- /dev/null
+++ b/textproc/elasticsearch5-x-pack/pkg-plist
@@ -0,0 +1,49 @@
+lib/elasticsearch/plugins/x-pack/LICENSE.txt
+lib/elasticsearch/plugins/x-pack/NOTICE.txt
+lib/elasticsearch/plugins/x-pack/activation-1.1.jar
+lib/elasticsearch/plugins/x-pack/automaton-1.11-8.jar
+lib/elasticsearch/plugins/x-pack/bcpkix-jdk15on-1.55.jar
+lib/elasticsearch/plugins/x-pack/bcprov-jdk15on-1.55.jar
+lib/elasticsearch/plugins/x-pack/bin/.in.bat
+lib/elasticsearch/plugins/x-pack/bin/certgen
+lib/elasticsearch/plugins/x-pack/bin/certgen.bat
+lib/elasticsearch/plugins/x-pack/bin/croneval
+lib/elasticsearch/plugins/x-pack/bin/croneval.bat
+lib/elasticsearch/plugins/x-pack/bin/extension
+lib/elasticsearch/plugins/x-pack/bin/extension.bat
+lib/elasticsearch/plugins/x-pack/bin/migrate
+lib/elasticsearch/plugins/x-pack/bin/migrate.bat
+lib/elasticsearch/plugins/x-pack/bin/syskeygen
+lib/elasticsearch/plugins/x-pack/bin/syskeygen.bat
+lib/elasticsearch/plugins/x-pack/bin/users
+lib/elasticsearch/plugins/x-pack/bin/users.bat
+lib/elasticsearch/plugins/x-pack/commons-codec-1.10.jar
+lib/elasticsearch/plugins/x-pack/commons-logging-1.1.3.jar
+lib/elasticsearch/plugins/x-pack/config/log4j2.properties
+lib/elasticsearch/plugins/x-pack/config/role_mapping.yml
+lib/elasticsearch/plugins/x-pack/config/roles.yml
+lib/elasticsearch/plugins/x-pack/config/users
+lib/elasticsearch/plugins/x-pack/config/users_roles
+lib/elasticsearch/plugins/x-pack/guava-16.0.1.jar
+lib/elasticsearch/plugins/x-pack/httpasyncclient-4.1.2.jar
+lib/elasticsearch/plugins/x-pack/httpclient-4.5.2.jar
+lib/elasticsearch/plugins/x-pack/httpcore-4.4.5.jar
+lib/elasticsearch/plugins/x-pack/httpcore-nio-4.4.5.jar
+lib/elasticsearch/plugins/x-pack/javax.mail-1.5.3.jar
+lib/elasticsearch/plugins/x-pack/netty-3.10.6.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-buffer-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-codec-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-codec-http-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-common-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-handler-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-resolver-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/netty-transport-4.1.5.Final.jar
+lib/elasticsearch/plugins/x-pack/owasp-java-html-sanitizer-r239.jar
+lib/elasticsearch/plugins/x-pack/plugin-descriptor.properties
+lib/elasticsearch/plugins/x-pack/plugin-security.policy
+lib/elasticsearch/plugins/x-pack/rest-5.0.0.jar
+lib/elasticsearch/plugins/x-pack/sniffer-5.0.0.jar
+lib/elasticsearch/plugins/x-pack/transport-netty3-5.0.0.jar
+lib/elasticsearch/plugins/x-pack/transport-netty4-5.0.0.jar
+lib/elasticsearch/plugins/x-pack/unboundid-ldapsdk-3.1.1.jar
+lib/elasticsearch/plugins/x-pack/x-pack-5.0.0.jar