aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
committertijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
commitc06f97c7c46a03f3f6bb887aee3534bece5267a1 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /textproc
parent682bd0d0ee3984087ff6a9f3bf4b0552db04d013 (diff)
downloadfreebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.gz
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.zst
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.zip
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate keyword or USES for this. Approved by: portmgr (bapt)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libextractor/Makefile3
-rw-r--r--textproc/redland/Makefile4
-rw-r--r--textproc/scim-openvanilla/Makefile4
3 files changed, 6 insertions, 5 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index 8acc0205e6c0..17a0f63d193e 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -11,10 +11,11 @@ COMMENT= Library for keyword extraction
LICENSE= GPLv3 # (or later)
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= iconv gettext libtool makeinfo pathfix pkgconfig
USE_GNOME= gtk20
USE_PYTHON= yes
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk-version=2 \
--with-ltdl=${LOCALBASE}
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 09cdf3c1d02b..78c3ce7a2273 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -15,10 +15,10 @@ COMMENT= High-level interface for RDF
LICENSE= APACHE20 GPLv2 GPLv3 LGPL21
LICENSE_COMB= dual
-LIB_DEPENDS= libraptor2.so:${PORTSDIR}/textproc/raptor2 \
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libraptor2.so:${PORTSDIR}/textproc/raptor2 \
librasqal.so:${PORTSDIR}/textproc/rasqal
-USE_AUTOTOOLS= libltdl
USE_PERL5= build
USES= gmake libtool pathfix perl5 pkgconfig shebangfix
SHEBANG_FILES= scripts/touch-mtime.pl
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index 957265cd063d..85070271f427 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -14,9 +14,9 @@ COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
-LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libexpat.so:${PORTSDIR}/textproc/expat2
-USE_AUTOTOOLS= libltdl
WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USES= pkgconfig gettext iconv gmake libtool:keepla
GNU_CONFIGURE= yes