aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-14 22:26:55 +0800
committermat <mat@FreeBSD.org>2017-04-14 22:26:55 +0800
commitc37f92f10a6ae4da19c4b4d098c7b90bc7c0fad8 (patch)
tree91c0bafdcde6f31a04883235f699f729cfaa2f60 /textproc
parenta49bf0ae450e99b39f2c39d34ca2d40290be26d6 (diff)
downloadfreebsd-ports-gnome-c37f92f10a6ae4da19c4b4d098c7b90bc7c0fad8.tar.gz
freebsd-ports-gnome-c37f92f10a6ae4da19c4b4d098c7b90bc7c0fad8.tar.zst
freebsd-ports-gnome-c37f92f10a6ae4da19c4b4d098c7b90bc7c0fad8.zip
Add textproc/py-autopep8 1.3.1.
autopep8 automatically formats Python code to conform to the PEP 8 style guide. It uses the pycodestyle utility to determine what parts of the code needs to be formatted. autopep8 is capable of fixing most of the formatting issues that can be reported by pycodestyle. Sponsored by: Absolight
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-autopep8/Makefile29
-rw-r--r--textproc/py-autopep8/distinfo3
-rw-r--r--textproc/py-autopep8/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 50696937d3db..5f9152ea4039 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1244,6 +1244,7 @@
SUBDIR += py-agate-excel
SUBDIR += py-alabaster
SUBDIR += py-asv
+ SUBDIR += py-autopep8
SUBDIR += py-awesome-slugify
SUBDIR += py-bugzillatools
SUBDIR += py-chardet
diff --git a/textproc/py-autopep8/Makefile b/textproc/py-autopep8/Makefile
new file mode 100644
index 000000000000..f7a3b8555d91
--- /dev/null
+++ b/textproc/py-autopep8/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= autopep8
+PORTVERSION= 1.3.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= automatically formats Python code to conform to the PEP 8 style guide
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycodestyle>=2.3:devel/py-pycodestyle
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= README.rst
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-autopep8/distinfo b/textproc/py-autopep8/distinfo
new file mode 100644
index 000000000000..7b5afc507dbb
--- /dev/null
+++ b/textproc/py-autopep8/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492175834
+SHA256 (autopep8-1.3.1.tar.gz) = 405eaa5199c74a0570125916e6af44d39343c1fcaaafee117fc329a3f86048c4
+SIZE (autopep8-1.3.1.tar.gz) = 107541
diff --git a/textproc/py-autopep8/pkg-descr b/textproc/py-autopep8/pkg-descr
new file mode 100644
index 000000000000..28570629be79
--- /dev/null
+++ b/textproc/py-autopep8/pkg-descr
@@ -0,0 +1,6 @@
+autopep8 automatically formats Python code to conform to the PEP 8 style guide.
+It uses the pycodestyle utility to determine what parts of the code needs to be
+formatted. autopep8 is capable of fixing most of the formatting issues that can
+be reported by pycodestyle.
+
+WWW: https://github.com/hhatto/autopep8/