aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsanpei <sanpei@FreeBSD.org>2004-04-15 17:08:18 +0800
committersanpei <sanpei@FreeBSD.org>2004-04-15 17:08:18 +0800
commitc3b36a5ed1ffd1834c88a74b4f53111e1d1407c2 (patch)
treeee6f8c144cdb49b1c4a1d9be4dfa4144ebdc9fd3 /textproc
parent9485ac89b6f3fbd8c97f54b59b6b9a9a9af3e52c (diff)
downloadfreebsd-ports-gnome-c3b36a5ed1ffd1834c88a74b4f53111e1d1407c2.tar.gz
freebsd-ports-gnome-c3b36a5ed1ffd1834c88a74b4f53111e1d1407c2.tar.zst
freebsd-ports-gnome-c3b36a5ed1ffd1834c88a74b4f53111e1d1407c2.zip
fix -v and --version options
Submitted by: Daniel V Klein <dvk@lonewolf.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/wdiff/Makefile2
-rw-r--r--textproc/wdiff/files/patch-ac31
2 files changed, 30 insertions, 3 deletions
diff --git a/textproc/wdiff/Makefile b/textproc/wdiff/Makefile
index 9d003b37aa59..7c0dff9bc9ff 100644
--- a/textproc/wdiff/Makefile
+++ b/textproc/wdiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wdiff
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wdiff
diff --git a/textproc/wdiff/files/patch-ac b/textproc/wdiff/files/patch-ac
index 4e309c03fc93..5674af964e0d 100644
--- a/textproc/wdiff/files/patch-ac
+++ b/textproc/wdiff/files/patch-ac
@@ -1,5 +1,14 @@
---- wdiff.c.orig Sun Nov 6 02:57:23 1994
-+++ wdiff.c Wed Aug 1 16:48:38 2001
+--- wdiff.c.orig Sun Nov 6 16:57:23 1994
++++ wdiff.c Thu Apr 15 17:58:08 2004
+@@ -108,7 +108,7 @@
+ struct option const longopts[] =
+ {
+ {"copyright" , 0, NULL, 'C'},
+- {"version" , 0, NULL, 'V'},
++ {"version" , 0, NULL, 'v'},
+ {"no-deleted" , 0, NULL, '1'},
+ {"no-inserted" , 0, NULL, '2'},
+ {"no-common" , 0, NULL, '3'},
@@ -892,8 +892,9 @@
{
/* Launch the diff program. */
@@ -11,3 +20,21 @@
right_side->temp_name, NULL);
else
input_file = readpipe (DIFF_PROGRAM, left_side->temp_name,
+@@ -1111,7 +1112,7 @@
+ Mandatory arguments to long options are mandatory for short options too.\n\
+ \n\
+ -C, --copyright print Copyright then exit\n\
+- -V, --version print program version then exit\n\
++ -v, --version print program version then exit\n\
+ -1, --no-deleted inhibit output of deleted words\n\
+ -2, --no-inserted inhibit output of inserted words\n\
+ -3, --no-common inhibit output of common words\n\
+@@ -1173,7 +1174,7 @@
+ count_changed_left = 0;
+ count_changed_right = 0;
+
+- while (option_char = getopt_long (argc, argv, "123CVahidlnpstw:x:y:z:",
++ while (option_char = getopt_long (argc, argv, "123Cahidlnpstvw:x:y:z:",
+ longopts, NULL),
+ option_char != EOF)
+ switch (option_char)