aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-02-21 12:38:19 +0800
committerknu <knu@FreeBSD.org>2001-02-21 12:38:19 +0800
commitc7f8d504a5fbb53033b212e22f6a7ff360eb48ef (patch)
tree6f8bb11825a245454e81e81ed49b9a23101d1704 /textproc
parent462c6637f6410bef0a35318a84ac21be571310a0 (diff)
downloadfreebsd-ports-gnome-c7f8d504a5fbb53033b212e22f6a7ff360eb48ef.tar.gz
freebsd-ports-gnome-c7f8d504a5fbb53033b212e22f6a7ff360eb48ef.tar.zst
freebsd-ports-gnome-c7f8d504a5fbb53033b212e22f6a7ff360eb48ef.zip
Add ruby-erb, another eRuby implementation which can be invoked from
within a script.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-erb/Makefile37
-rw-r--r--textproc/ruby-erb/distinfo1
-rw-r--r--textproc/ruby-erb/pkg-comment1
-rw-r--r--textproc/ruby-erb/pkg-descr7
-rw-r--r--textproc/ruby-erb/pkg-plist17
6 files changed, 64 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a209400e8556..ab1e90cf805f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -118,6 +118,7 @@
SUBDIR += py-xml
SUBDIR += rand
SUBDIR += rman
+ SUBDIR += ruby-erb
SUBDIR += ruby-html-parser
SUBDIR += ruby-qt2xml
SUBDIR += ruby-rdtool
diff --git a/textproc/ruby-erb/Makefile b/textproc/ruby-erb/Makefile
new file mode 100644
index 000000000000..75a9b3873226
--- /dev/null
+++ b/textproc/ruby-erb/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-ERb
+# Date created: 21 February 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= erb
+PORTVERSION= 1.3.3
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www2a.biglobe.ne.jp/~seki/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/sample/ja
+ ${MV} ${WRKSRC}/sample/sample.rhtml ${WRKSRC}/sample/ja
+
+post-patch:
+ ${RUBY} -i -pe '$$. == 1 and $$_ = "#!${RUBY}\n" + $$_' \
+ ${WRKSRC}/lib/erb/erb.rb
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${RUBY} install.rb
+ ${LN} -s ${RUBY_SITELIBDIR}/erb/erb.rb ${PREFIX}/bin/erb
+.if !defined(NOPORTDOCS)
+ ${CP} -R ${WRKSRC}/sample ${RUBY_EXAMPLESDIR}/erb/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-erb/distinfo b/textproc/ruby-erb/distinfo
new file mode 100644
index 000000000000..cb51a70875ae
--- /dev/null
+++ b/textproc/ruby-erb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/erb-1.3.3.tar.gz) = c32910a629f69546dc491e4ce235d433
diff --git a/textproc/ruby-erb/pkg-comment b/textproc/ruby-erb/pkg-comment
new file mode 100644
index 000000000000..0c44c453895f
--- /dev/null
+++ b/textproc/ruby-erb/pkg-comment
@@ -0,0 +1 @@
+Another eRuby implementation which can be invoked from within a script
diff --git a/textproc/ruby-erb/pkg-descr b/textproc/ruby-erb/pkg-descr
new file mode 100644
index 000000000000..5608b8d2d9a7
--- /dev/null
+++ b/textproc/ruby-erb/pkg-descr
@@ -0,0 +1,7 @@
+ERb - Tiny eRuby.
+
+ERb is another eRuby implementation which can be invoked from within a
+script as a library.
+
+Author: Masatoshi SEKI <m_seki@mva.biglobe.ne.jp>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=ERb+-+Tiny+eRuby
diff --git a/textproc/ruby-erb/pkg-plist b/textproc/ruby-erb/pkg-plist
new file mode 100644
index 000000000000..a26ce2a4d180
--- /dev/null
+++ b/textproc/ruby-erb/pkg-plist
@@ -0,0 +1,17 @@
+bin/erb
+%%RUBY_SITELIBDIR%%/erb/compile.rb
+%%RUBY_SITELIBDIR%%/erb/erb.rb
+%%RUBY_SITELIBDIR%%/erb/erbcgi.rb
+%%RUBY_SITELIBDIR%%/erb/erbl.rb
+%%RUBY_SITELIBDIR%%/erb/erbu.rb
+%%RUBY_SITELIBDIR%%/erb/main.rb
+%%RUBY_SITELIBDIR%%/erb/strio.rb
+@dirrm %%RUBY_SITELIBDIR%%/erb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/cgi_test.rhtml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/dot.htaccess
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/erbux.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/err.rhtml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/succ.rhtml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/erb/ja/sample.rhtml
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/erb/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/erb