aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-07 17:39:35 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-07 17:39:35 +0800
commitd9c72df92612bfa87d4d7873de5bb35eb506cc75 (patch)
tree061aed4376835a650f216731ccce37b2994fa89e /textproc
parent09a68bf88da19b30dd10cf4fc543b256093a777d (diff)
downloadfreebsd-ports-gnome-d9c72df92612bfa87d4d7873de5bb35eb506cc75.tar.gz
freebsd-ports-gnome-d9c72df92612bfa87d4d7873de5bb35eb506cc75.tar.zst
freebsd-ports-gnome-d9c72df92612bfa87d4d7873de5bb35eb506cc75.zip
- Convert to use shebangfix USES flag
- Trim header - Use new options framework for DOCS
Diffstat (limited to 'textproc')
-rw-r--r--textproc/align/Makefile8
-rw-r--r--textproc/xmldiff/Makefile13
-rw-r--r--textproc/xmlprpr/Makefile13
-rw-r--r--textproc/xslint/Makefile20
4 files changed, 22 insertions, 32 deletions
diff --git a/textproc/align/Makefile b/textproc/align/Makefile
index 3ad86369dd73..df8542ea031d 100644
--- a/textproc/align/Makefile
+++ b/textproc/align/Makefile
@@ -14,14 +14,12 @@ LICENSE= GPLv2 # (or later)
NO_BUILD= yes
+USES= shebangfix
USE_PERL5_RUN= yes
-PLIST_FILES= bin/align bin/width
+SHEBANG_FILES= align width
-post-patch:
-.for i in align width
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/${i}
-.endfor
+PLIST_FILES= bin/align bin/width
do-install:
.for i in align width
diff --git a/textproc/xmldiff/Makefile b/textproc/xmldiff/Makefile
index 9ab9b907a805..b456e3f68c30 100644
--- a/textproc/xmldiff/Makefile
+++ b/textproc/xmldiff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmldiff
-# Date created: Sun Oct 9 10:33:37 EDT 2005
-# Whom: Paul Chvostek <paul+ports@it.ca>
-#
+# Created by: Paul Chvostek <paul+ports@it.ca>
# $FreeBSD$
-#
PORTNAME= xmldiff
PORTVERSION= 0.01
@@ -18,17 +14,18 @@ COMMENT= Display meaningful differences between XML files
RUN_DEPENDS= xmlprpr:${PORTSDIR}/textproc/xmlprpr
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+
+SHEBANG_FILES= xmldiff.pl
+
PLIST_FILES= bin/xmldiff
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} -f ${_DISTDIR}/${_DISTFILES} ${WRKSRC}
-post-patch:
- @${REINPLACE_CMD} -e '1s:/usr/bin/perl:${PERL}:' ${WRKSRC}/xmldiff.pl
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/xmldiff.pl ${PREFIX}/bin/xmldiff
diff --git a/textproc/xmlprpr/Makefile b/textproc/xmlprpr/Makefile
index 518949b3853f..360b55aabde2 100644
--- a/textproc/xmlprpr/Makefile
+++ b/textproc/xmlprpr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmlprpr
-# Date created: Sun Oct 9 10:33:37 EDT 2005
-# Whom: Paul Chvostek <paul+ports@it.ca>
-#
+# Created by: Paul Chvostek <paul+ports@it.ca>
# $FreeBSD$
-#
PORTNAME= xmlprpr
PORTVERSION= 1.32
@@ -16,18 +12,19 @@ DISTFILES= xmlpp.pl
MAINTAINER= ports@FreeBSD.org
COMMENT= An XML pretty printer
+USES= shebangfix
USE_PERL5= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
+
+SHEBANG_FILES= xmlpp.pl
+
PLIST_FILES= bin/xmlprpr
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} -f ${_DISTDIR}/${_DISTFILES} ${WRKSRC}
-post-patch:
- @${REINPLACE_CMD} -e '1s:/usr/bin/perl:${PERL}:' ${WRKSRC}/xmlpp.pl
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/xmlpp.pl ${PREFIX}/bin/xmlprpr
diff --git a/textproc/xslint/Makefile b/textproc/xslint/Makefile
index 1fdce14a0798..bfa61b8dc04b 100644
--- a/textproc/xslint/Makefile
+++ b/textproc/xslint/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xslint
-# Date created: 11 August 2001
-# Whom: Alex Kapranoff <kapr@crosswinds.net>
-#
+# Created by: Alex Kapranoff <kapr@crosswinds.net>
# $FreeBSD$
-#
PORTNAME= xslint
PORTVERSION= 005
@@ -16,25 +12,27 @@ COMMENT= XSL(T) stylesheet checker
RUN_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
+USES= shebangfix
USE_ZIP= yes
USE_PERL5_RUN= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-0.05
NO_BUILD= yes
+SHEBANG_FILES= xslint.pl
+
PLIST_FILES= bin/xslint
PORTDOCS= README xslint.html xslint.xml
-post-patch:
- @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/${PORTNAME}.pl
+.include <bsd.port.options.mk>
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-. for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-. endfor
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>