aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-02 23:05:37 +0800
committertijl <tijl@FreeBSD.org>2014-09-02 23:05:37 +0800
commitdab80b2905c14f5d8eec4d771b804d49915e51f7 (patch)
tree2c63a050ec8d0daca5830705537e05214fc46b08 /textproc
parent9fd0c0d361b953f278c8a5d0907e2d6b4d645c1a (diff)
downloadfreebsd-ports-gnome-dab80b2905c14f5d8eec4d771b804d49915e51f7.tar.gz
freebsd-ports-gnome-dab80b2905c14f5d8eec4d771b804d49915e51f7.tar.zst
freebsd-ports-gnome-dab80b2905c14f5d8eec4d771b804d49915e51f7.zip
- Add USES=libtool and bump dependent ports
- Add USES=iconv to fix build on FreeBSD 10
Diffstat (limited to 'textproc')
-rw-r--r--textproc/gmetadom/Makefile12
-rw-r--r--textproc/gmetadom/files/patch-ltmain.sh15
-rw-r--r--textproc/gmetadom/pkg-plist3
3 files changed, 9 insertions, 21 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index c40cfca8727b..253cc2c45b24 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gmetadom
PORTVERSION= 0.2.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF
@@ -12,12 +12,12 @@ COMMENT= Collection of DOM Implementations
LIB_DEPENDS= libgdome.so:${PORTSDIR}/textproc/gdome2
-USES= pathfix pkgconfig gmake
+USES= gmake iconv libtool pathfix pkgconfig
USE_GNOME= glib20 libxml2
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= OCAML
OPTIONS_SUB= yes
@@ -29,6 +29,8 @@ OCAML_BUILD_DEPENDS= ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
OCAML_CONFIGURE_OFF= HAVE_OCAMLDEP=no HAVE_OCAMLFIND=no HAVE_OCAMLOPT=no
post-patch:
- @${REINPLACE_CMD} -e 's/-lstdc++//g' ${WRKSRC}/src/gdome_cpp_smart/Makefile.in
+ @${REINPLACE_CMD} -e 's/-lstdc++//g' \
+ ${WRKSRC}/src/gdome_cpp_smart/Makefile.in \
+ ${WRKSRC}/src/gdome_cpp_smart/test/Makefile.in
.include <bsd.port.mk>
diff --git a/textproc/gmetadom/files/patch-ltmain.sh b/textproc/gmetadom/files/patch-ltmain.sh
deleted file mode 100644
index e638fd52020d..000000000000
--- a/textproc/gmetadom/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Sun May 11 23:50:20 2003
-+++ ltmain.sh Sun May 11 23:50:40 2003
-@@ -4247,10 +4247,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/textproc/gmetadom/pkg-plist b/textproc/gmetadom/pkg-plist
index 768e2032ea83..2a4afaeb5212 100644
--- a/textproc/gmetadom/pkg-plist
+++ b/textproc/gmetadom/pkg-plist
@@ -35,7 +35,8 @@ include/gmetadom/gdome_cpp_smart/GdomeSmartDOMUTF16String.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMUTF8String.hh
lib/libgmetadom_gdome_cpp_smart.a
lib/libgmetadom_gdome_cpp_smart.so
-lib/libgmetadom_gdome_cpp_smart.so.2
+lib/libgmetadom_gdome_cpp_smart.so.0
+lib/libgmetadom_gdome_cpp_smart.so.0.2.6
%%OCAML%%lib/ocaml/gdome2/META
%%OCAML%%lib/ocaml/gdome2/gdome.cmi
%%OCAML%%lib/ocaml/gdome2/gdome.mli