aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-10-26 03:09:14 +0800
committerantoine <antoine@FreeBSD.org>2016-10-26 03:09:14 +0800
commite98d0f2995f86043343f7f95fa12d204445336c8 (patch)
tree9dc37d6444f87dba17d1385b85a4cef69bf394a0 /textproc
parent0005b722b1ad39c92abfe8ab925cd8abbf1ffef8 (diff)
downloadfreebsd-ports-gnome-e98d0f2995f86043343f7f95fa12d204445336c8.tar.gz
freebsd-ports-gnome-e98d0f2995f86043343f7f95fa12d204445336c8.tar.zst
freebsd-ports-gnome-e98d0f2995f86043343f7f95fa12d204445336c8.zip
Do not hand roll PYTHON_CMD
Diffstat (limited to 'textproc')
-rw-r--r--textproc/codespell/Makefile2
-rw-r--r--textproc/py-libxml2/Makefile4
-rw-r--r--textproc/py3-libxml2/Makefile4
3 files changed, 5 insertions, 5 deletions
diff --git a/textproc/codespell/Makefile b/textproc/codespell/Makefile
index 620a92cb5db9..2ebc1eccf04f 100644
--- a/textproc/codespell/Makefile
+++ b/textproc/codespell/Makefile
@@ -23,7 +23,7 @@ PORTEXAMPLES= *
SUB_FILES+= pkg-message
do-build:
- ${REINPLACE_CMD} 's|#!/usr/bin/env python3|#!${LOCALBASE}/bin/${PYTHON_VERSION}|' \
+ ${REINPLACE_CMD} 's|#!/usr/bin/env python3|#!${PYTHON_CMD}|' \
${WRKSRC}/codespell.py
do-install:
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index 16c525b30eb8..1320484796c2 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -18,8 +18,8 @@ USE_GNOME+= libxml2
USES+= python:2 gettext-runtime
USE_PYTHON= autoplist distutils
-CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
+CPPFLAGS+= `${PYTHON_CMD}-config --cflags`
+LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_CMD}-config --libs`
CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
diff --git a/textproc/py3-libxml2/Makefile b/textproc/py3-libxml2/Makefile
index ad334737da6f..9926e1371f12 100644
--- a/textproc/py3-libxml2/Makefile
+++ b/textproc/py3-libxml2/Makefile
@@ -18,8 +18,8 @@ USE_GNOME+= libxml2
USES= python:3 gettext-runtime
USE_PYTHON= autoplist distutils
-CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
+CPPFLAGS+= `${PYTHON_CMD}-config --cflags`
+LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_CMD}-config --libs`
CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \