aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1998-08-30 10:32:23 +0800
committermax <max@FreeBSD.org>1998-08-30 10:32:23 +0800
commitf33cbf79c808c14ac067fd00b16865a74d6e4d9a (patch)
tree3c4c9ad0e9116301fca241b12ec291a232a1c5b1 /textproc
parent20bafa5e84bd28bd343f5dc06d22972db7069424 (diff)
downloadfreebsd-ports-gnome-f33cbf79c808c14ac067fd00b16865a74d6e4d9a.tar.gz
freebsd-ports-gnome-f33cbf79c808c14ac067fd00b16865a74d6e4d9a.tar.zst
freebsd-ports-gnome-f33cbf79c808c14ac067fd00b16865a74d6e4d9a.zip
New port, nfbtrans:
NFBTRANS is a very accurate Grade Two braille translator. It can also back translate a Grade Two file into normal text. The program has many options which allow the user to customize its operation. Formatting commands can be used to generate Tables of Contents, ink print page numbers, running headers and much more. Translation rules are in a text file and can easily be modified by the user. The program can be configured to hyphenate words to save space. Because the copyright status is unclear, I'm marking this as RESTRICTED until I can find out from the author.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/nfbtrans/Makefile44
-rw-r--r--textproc/nfbtrans/distinfo2
-rw-r--r--textproc/nfbtrans/files/patch-aa41
-rw-r--r--textproc/nfbtrans/files/patch-ab48
-rw-r--r--textproc/nfbtrans/files/patch-ac23
-rw-r--r--textproc/nfbtrans/files/patch-ad11
-rw-r--r--textproc/nfbtrans/pkg-comment1
-rw-r--r--textproc/nfbtrans/pkg-descr9
-rw-r--r--textproc/nfbtrans/pkg-plist25
9 files changed, 204 insertions, 0 deletions
diff --git a/textproc/nfbtrans/Makefile b/textproc/nfbtrans/Makefile
new file mode 100644
index 000000000000..9d9e14345020
--- /dev/null
+++ b/textproc/nfbtrans/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: nfbtrans
+# Version required: 7.50.2
+# Date created: 30 Aug 1998
+# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
+#
+# $Id: porting.sgml,v 1.16 1996/03/21 14:15:01 asami Exp $
+#
+
+DISTNAME= nfbtr750
+PKGNAME= nfbtrans-7.50.2
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.netcom.com/pub/in/inge/
+EXTRACT_SUFX= .zip
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} nfb7502.zip
+
+MAINTAINER= max@FreeBSD.ORG
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+RESTRICTED= "Unclear copyright status"
+EXTRACT_CMD= unzip
+EXTRACT_ARGS= -q -a -L -o
+NO_WRKSUBDIR= yes
+ALL_TARGET= freebsd
+MAKEFILE= makefile
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/nfbtrans/tables
+ ${INSTALL_PROGRAM} ${WRKSRC}/nfbtrans ${PREFIX}/bin
+.for f in braille.tab back.tab english.dic nfbtrans.cnf
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/lib/nfbtrans
+.endfor
+ @unzip -q -L -a -o ${WRKSRC}/tables.zip -d ${PREFIX}/lib/nfbtrans/tables
+.if !defined(NOPORTDOCS)
+ @${ECHO} '~0 ~-pw=80 ~-ls=99 ~-pl=56 ~-if=12 ~-fc=. ~o5 ~p- ~-ip=0 ~-oc=1' \
+ | ${CAT} - ${WRKSRC}/nfbtrans.fmt > ${WRKSRC}/nfbprint.fmt
+ @${WRKSRC}/nfbtrans st=${WRKSRC}/stat.txt qm=1 ob=oc=15 \
+ ${WRKSRC}/nfbprint.fmt > ${WRKSRC}/nfbtrans.doc
+ ${MKDIR} ${PREFIX}/share/doc/nfbtrans
+ ${INSTALL_DATA} ${WRKSRC}/nfbtrans.doc ${PREFIX}/share/doc/nfbtrans
+ ${INSTALL_DATA} ${WRKSRC}/nfbtrans.fmt ${PREFIX}/share/doc/nfbtrans
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/nfbtrans/distinfo b/textproc/nfbtrans/distinfo
new file mode 100644
index 000000000000..dfaa0282f647
--- /dev/null
+++ b/textproc/nfbtrans/distinfo
@@ -0,0 +1,2 @@
+MD5 (nfbtr750.zip) = c118ad48d76e9e04a32a6fb6e93c33d8
+MD5 (nfb7502.zip) = 0a2c31ee62431713eb6143aa1fbce043
diff --git a/textproc/nfbtrans/files/patch-aa b/textproc/nfbtrans/files/patch-aa
new file mode 100644
index 000000000000..8e83aa8d30f7
--- /dev/null
+++ b/textproc/nfbtrans/files/patch-aa
@@ -0,0 +1,41 @@
+--- makefile.orig Sun Aug 30 06:13:32 1998
++++ makefile Sun Aug 30 07:58:37 1998
+@@ -3,6 +3,11 @@
+ #translation software written by the National Federation of the Blind
+ #compile under the Unix operating system.
+ #
++#Installation prefix:
++PREFIX?=/usr/local
++#Library path:
++UNIX_PATH?=${PREFIX}/lib/nfbtrans/
++#
+ #The source and object files are as follows:
+
+ SRCFILES=nfbtrans.c nfbpatch.c
+@@ -10,7 +15,7 @@
+ LIBS= -ltermcap
+
+ #Compiler and linking flags are as follows:
+-CFLAGS=-O
++CFLAGS+=-O -dUNIX_PATH=${UNIX_PATH}
+ CC=gcc
+ LDFLAGS=-Bdynamic
+
+@@ -22,6 +27,7 @@
+ @echo "ultrix"
+ @echo "aix"
+ @echo "linux"
++ @echo "freebsd"
+ all: nfbtrans
+
+ #Lint can wait a while
+@@ -31,6 +37,9 @@
+
+ ultrix:
+ $(MAKE) CFLAGS=-O
++
++freebsd:
++ ${MAKE} all CFLAGS="${CFLAGS} -Dfreebsd"
+
+ linux:
+ $(MAKE) CFLAGS=-O
diff --git a/textproc/nfbtrans/files/patch-ab b/textproc/nfbtrans/files/patch-ab
new file mode 100644
index 000000000000..2608e9a78bb5
--- /dev/null
+++ b/textproc/nfbtrans/files/patch-ab
@@ -0,0 +1,48 @@
+--- nfbtrans.c.orig Wed Aug 19 16:30:14 1998
++++ nfbtrans.c Sun Aug 30 08:34:55 1998
+@@ -2,7 +2,9 @@
+ #define LINT_ARGS
+ #define DOS
+ #else
+-#define UNIX_PATH "/usr/local/lib/"
++#ifndef UNIX_PATH
++#define UNIX_PATH "/usr/local/lib/nfbtrans/"
++#endif
+ #endif /* unix */
+ #ifndef lint
+ #endif /* lint */
+@@ -24,7 +26,7 @@
+ #include <fcntl.h>
+ #include <stdarg.h>
+ #define MAXARGS 7
+-#if defined(sunos) || defined(linux)
++#if defined(sunos) || defined(linux) || defined(freebsd)
+ #define max(a,b) (((a) > (b)) ? (a) : (b))
+ #define min(a,b) (((a) < (b)) ? (a) : (b))
+ #endif
+@@ -4731,7 +4733,12 @@
+ for (;;)
+ {
+ fprintf(stderr, "Enter dictionary word <RETURN> to skip: ");
++#ifdef freebsd
++ fgets(temp, sizeof(temp), stdin);
++ temp[strlen(temp)-1] = '\0';
++#else
+ gets(temp);
++#endif
+ if (!temp[0])
+ break; /* skip, don't store as rejected */
+ strupr(temp);
+@@ -5242,7 +5249,12 @@
+ for (;;)
+ {
+ fprintf(stderr, "enter word <RETURN> to exit: ");
++#ifdef freebsd
++ fgets(field, (sizeof(field_) - (field - field_)), stdin);
++ field[strlen(field-1)] = '\0';
++#else
+ gets(field);
++#endif
+ if (strlen(field) < 2)
+ break;
+ strupr(field);
diff --git a/textproc/nfbtrans/files/patch-ac b/textproc/nfbtrans/files/patch-ac
new file mode 100644
index 000000000000..425a44de9925
--- /dev/null
+++ b/textproc/nfbtrans/files/patch-ac
@@ -0,0 +1,23 @@
+--- nfbpatch.c.orig Thu Feb 6 12:00:00 1997
++++ nfbpatch.c Sun Aug 30 05:44:36 1998
+@@ -31,9 +31,11 @@
+ #include <unistd.h>
+
+ #define CASE_SHIFT 32 /* diference between upper and lower case */
++#ifndef freebsd
+ #define SYSVR4 /* use with gcc and solaris 2.1 see getpgrp. Also defines
+ * usleep. Wasn't able to link with /usr/ucblib/libucb.a
+ * Really no need for delay anyway */
++#endif
+ #ifdef ultrix
+ #define ECHOCTL TCTLECH
+ #endif
+@@ -97,7 +99,7 @@
+ int i;
+
+ i = tcgetpgrp(0);/* Use stdin as the file descriptor */
+-#ifdef SYSVR4
++#if defined(SYSVR4) || defined(freebsd)
+ if (i == getpgrp())
+ return (1);
+ #else
diff --git a/textproc/nfbtrans/files/patch-ad b/textproc/nfbtrans/files/patch-ad
new file mode 100644
index 000000000000..17359778a703
--- /dev/null
+++ b/textproc/nfbtrans/files/patch-ad
@@ -0,0 +1,11 @@
+--- nfbtrans.cnf.orig Sun Aug 30 06:11:38 1998
++++ nfbtrans.cnf Sun Aug 30 07:52:45 1998
+@@ -30,7 +30,7 @@
+ ;s0=~[DL instructs juliet printer to ignore formfeed in spool mode
+ so=15 sound enabled
+ sp=0 spool mode off don't use dos print for backround printing
+-st=c:\stat.txt statistics file
++st=stat.txt statistics file
+ ;tv=2000 timming value for microsoft C not used otherwise
+
+ ;Assign extension types
diff --git a/textproc/nfbtrans/pkg-comment b/textproc/nfbtrans/pkg-comment
new file mode 100644
index 000000000000..4418268a5ee2
--- /dev/null
+++ b/textproc/nfbtrans/pkg-comment
@@ -0,0 +1 @@
+ASCII text to Grade Two braille translator.
diff --git a/textproc/nfbtrans/pkg-descr b/textproc/nfbtrans/pkg-descr
new file mode 100644
index 000000000000..93d2a9f3937f
--- /dev/null
+++ b/textproc/nfbtrans/pkg-descr
@@ -0,0 +1,9 @@
+NFBTRANS is a very accurate Grade Two braille translator. It can also
+back translate a Grade Two file into normal text. The program has
+many options which allow the user to customize its operation.
+Formatting commands can be used to generate Tables of Contents, ink
+print page numbers, running headers and much more. Translation rules
+are in a text file and can easily be modified by the user. The
+program can be configured to hyphenate words to save space.
+
+- Max
diff --git a/textproc/nfbtrans/pkg-plist b/textproc/nfbtrans/pkg-plist
new file mode 100644
index 000000000000..67e04a66418d
--- /dev/null
+++ b/textproc/nfbtrans/pkg-plist
@@ -0,0 +1,25 @@
+bin/nfbtrans
+lib/nfbtrans/back.tab
+lib/nfbtrans/braille.tab
+lib/nfbtrans/english.dic
+lib/nfbtrans/nfbtrans.cnf
+lib/nfbtrans/tables/bhs_bhm.tab
+lib/nfbtrans/tables/danish.tab
+lib/nfbtrans/tables/dutch.tab
+lib/nfbtrans/tables/dutch3.tab
+lib/nfbtrans/tables/esperant.tab
+lib/nfbtrans/tables/german.tab
+lib/nfbtrans/tables/gnt.tab
+lib/nfbtrans/tables/iceland.tab
+lib/nfbtrans/tables/netcom.cap
+lib/nfbtrans/tables/norweg.tab
+lib/nfbtrans/tables/russian.tab
+lib/nfbtrans/tables/span2.tab
+lib/nfbtrans/tables/spanish.tab
+lib/nfbtrans/tables/swedish.tab
+lib/nfbtrans/tables/tables.doc
+share/doc/nfbtrans/nfbtrans.doc
+share/doc/nfbtrans/nfbtrans.fmt
+@dirrm lib/nfbtrans/tables
+@dirrm lib/nfbtrans
+@dirrm share/doc/nfbtrans