aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-01-17 18:38:06 +0800
committertcberner <tcberner@FreeBSD.org>2018-01-17 18:38:06 +0800
commit5b2f53587087b7cf655313f9650579e6c2e797f9 (patch)
tree8ae2cc5943fef530bd84750d856e8604aad731d8 /textproc
parenta392e5973e1d775ee8422ac4687c9d4243eda69a (diff)
downloadfreebsd-ports-gnome-5b2f53587087b7cf655313f9650579e6c2e797f9.tar.gz
freebsd-ports-gnome-5b2f53587087b7cf655313f9650579e6c2e797f9.tar.zst
freebsd-ports-gnome-5b2f53587087b7cf655313f9650579e6c2e797f9.zip
texproc/uim fix build with clang6
PR: 224669
Diffstat (limited to 'textproc')
-rw-r--r--textproc/uim/Makefile2
-rw-r--r--textproc/uim/files/patch-xim_main.cpp15
2 files changed, 16 insertions, 1 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index b24702744c29..70ab2abc72c9 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uim
PORTVERSION= 1.8.6
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= textproc
MASTER_SITES= https://github.com/uim/uim/releases/download/${PORTNAME}-${PORTVERSION}/
.if !defined(UIM_SLAVE) && defined(WITHOUT_X11)
diff --git a/textproc/uim/files/patch-xim_main.cpp b/textproc/uim/files/patch-xim_main.cpp
new file mode 100644
index 000000000000..9ac7dab80b4e
--- /dev/null
+++ b/textproc/uim/files/patch-xim_main.cpp
@@ -0,0 +1,15 @@
+error: invalid suffix on literal; C++11 requires a space between literal and identifier
+ [-Wreserved-user-defined-literal]
+ #define VERSION_NAME "uim-xim under the way! Version "PACKAGE_VERSION"\n"
+
+--- xim/main.cpp.orig 2018-01-17 10:10:47 UTC
++++ xim/main.cpp
+@@ -65,7 +65,7 @@ int g_option_mask;
+ int scr_width, scr_height;
+ int host_byte_order;
+
+-#define VERSION_NAME "uim-xim under the way! Version "PACKAGE_VERSION"\n"
++#define VERSION_NAME "uim-xim under the way! Version " PACKAGE_VERSION "\n"
+ const char *version_name=VERSION_NAME;
+ const char *usage=
+ "--help , --version :Show usage or version\n"