aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-04 18:52:10 +0800
committermiwi <miwi@FreeBSD.org>2008-08-04 18:52:10 +0800
commit03cc493dc16c9355f195c48d862dda630f5442c7 (patch)
tree1bae204509c9d62e3011d8ba89c941fb274acf96 /textproc
parentcb291aca067f915be50d8ead675e75b961517ca0 (diff)
downloadfreebsd-ports-gnome-03cc493dc16c9355f195c48d862dda630f5442c7.tar.gz
freebsd-ports-gnome-03cc493dc16c9355f195c48d862dda630f5442c7.tar.zst
freebsd-ports-gnome-03cc493dc16c9355f195c48d862dda630f5442c7.zip
This module attempts to extract the maximum amount of content from available
documents, and is less concerned with XML compliance than alternatives. Rather than rely on XML::Parser, it uses heuristics and good old-fashioned Perl regular expressions. WWW: http://search.cpan.org/dist/XML-RSSLite/ PR: ports/126116 Submitted by: Tomoyuki Sakurai <cherry at trombik.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-RSSLite/Makefile22
-rw-r--r--textproc/p5-XML-RSSLite/distinfo3
-rw-r--r--textproc/p5-XML-RSSLite/pkg-descr6
-rw-r--r--textproc/p5-XML-RSSLite/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ac51819b2549..09dfaf318e28 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -718,6 +718,7 @@
SUBDIR += p5-XML-RSS-Liberal
SUBDIR += p5-XML-RSS-Parser
SUBDIR += p5-XML-RSS-SimpleGen
+ SUBDIR += p5-XML-RSSLite
SUBDIR += p5-XML-RegExp
SUBDIR += p5-XML-SAX
SUBDIR += p5-XML-SAX-Expat
diff --git a/textproc/p5-XML-RSSLite/Makefile b/textproc/p5-XML-RSSLite/Makefile
new file mode 100644
index 000000000000..0c1f4a873136
--- /dev/null
+++ b/textproc/p5-XML-RSSLite/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-XML-RSSLite
+# Date created: 2008-07-31
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSSLite
+PORTVERSION= 0.11
+CATEGORIES= textproc
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR= ../by-authors/id/J/JP/JPIERCE
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Lightweight, relaxed RSS (and XML-ish) parser
+
+PERL_CONFIGURE= Yes
+MAN3= XML::RSSLite.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-RSSLite/distinfo b/textproc/p5-XML-RSSLite/distinfo
new file mode 100644
index 000000000000..0cb00b4adb2c
--- /dev/null
+++ b/textproc/p5-XML-RSSLite/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-RSSLite-0.11.tgz) = 96940cdc3c85958a0825c44245750bd6
+SHA256 (XML-RSSLite-0.11.tgz) = dc22def5e10f4e81be0a64ed7d0b1af0a883e184aeb793973a10f0415bfbd4d9
+SIZE (XML-RSSLite-0.11.tgz) = 8557
diff --git a/textproc/p5-XML-RSSLite/pkg-descr b/textproc/p5-XML-RSSLite/pkg-descr
new file mode 100644
index 000000000000..a0418e8111c7
--- /dev/null
+++ b/textproc/p5-XML-RSSLite/pkg-descr
@@ -0,0 +1,6 @@
+This module attempts to extract the maximum amount of content from available
+documents, and is less concerned with XML compliance than alternatives.
+Rather than rely on XML::Parser, it uses heuristics and good old-fashioned
+Perl regular expressions.
+
+WWW: http://search.cpan.org/dist/XML-RSSLite/
diff --git a/textproc/p5-XML-RSSLite/pkg-plist b/textproc/p5-XML-RSSLite/pkg-plist
new file mode 100644
index 000000000000..31a660c9fb41
--- /dev/null
+++ b/textproc/p5-XML-RSSLite/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/XML/RSSLite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSSLite/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSSLite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML