aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-05-17 00:23:57 +0800
committerskv <skv@FreeBSD.org>2004-05-17 00:23:57 +0800
commit097ff686eecae416b6812ba8940595ce8438330e (patch)
tree10e6ca435d9b8fb3e9cd2452adc79c1e08099714 /textproc
parent96ba17ae25984654f2948b18c06d457e72abdc57 (diff)
downloadfreebsd-ports-gnome-097ff686eecae416b6812ba8940595ce8438330e.tar.gz
freebsd-ports-gnome-097ff686eecae416b6812ba8940595ce8438330e.tar.zst
freebsd-ports-gnome-097ff686eecae416b6812ba8940595ce8438330e.zip
Unbreak build on perl 5.00503
Pointed by: kris
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-XML-LibXSLT/Makefile8
-rw-r--r--textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs26
2 files changed, 33 insertions, 1 deletions
diff --git a/textproc/p5-XML-LibXSLT/Makefile b/textproc/p5-XML-LibXSLT/Makefile
index 6af3c94a103e..f7651059c985 100644
--- a/textproc/p5-XML-LibXSLT/Makefile
+++ b/textproc/p5-XML-LibXSLT/Makefile
@@ -26,4 +26,10 @@ PERL_ABASE= ${SITE_PERL}/${PERL_ARCH}
MAN3= XML::LibXSLT.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES= ${FILESDIR}/500503-*
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs b/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
new file mode 100644
index 000000000000..6ed285503380
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
@@ -0,0 +1,26 @@
+--- LibXSLT.xs.orig Mon Mar 1 21:42:43 2004
++++ LibXSLT.xs Sun May 16 20:21:57 2004
+@@ -29,6 +29,23 @@
+ }
+ #endif
+
++#ifndef dTHX
++#define dTHX extern int errno
++#endif
++
++#ifndef SvPV_nolen
++#define SvPV_nolen(sv) \
++ ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK \
++ ? SvPVX(sv) : sv_2pv_nolen(sv))
++
++static char *
++sv_2pv_nolen(register SV *sv)
++{
++ STRLEN n_a;
++ return sv_2pv(sv, &n_a);
++}
++#endif
++
+ #define SET_CB(cb, fld) \
+ RETVAL = cb ? newSVsv(cb) : &PL_sv_undef;\
+ if (SvOK(fld)) {\