aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-12-18 02:02:09 +0800
committerriggs <riggs@FreeBSD.org>2016-12-18 02:02:09 +0800
commit0fe4b337b460141146e6589f99fa6e79703da4e5 (patch)
tree33afb645397f1832b46f31a3a08a7619f565005a /textproc
parentf9a9c9d23b5cc0d2558b96950c985b1321b4c8f0 (diff)
downloadfreebsd-ports-gnome-0fe4b337b460141146e6589f99fa6e79703da4e5.tar.gz
freebsd-ports-gnome-0fe4b337b460141146e6589f99fa6e79703da4e5.tar.zst
freebsd-ports-gnome-0fe4b337b460141146e6589f99fa6e79703da4e5.zip
New port: textproc/zxing-cpp, a C++ Library for QR code recognition
PR: 214519 Submitted by: yuri@rawbw.com (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/zxing-cpp/Makefile21
-rw-r--r--textproc/zxing-cpp/distinfo3
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp11
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp10
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp14
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h19
-rw-r--r--textproc/zxing-cpp/pkg-descr3
-rw-r--r--textproc/zxing-cpp/pkg-plist104
9 files changed, 186 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d12df4bef1d8..8234090b6e4f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1738,5 +1738,6 @@
SUBDIR += zsh-syntax-highlighting
SUBDIR += zu-aspell
SUBDIR += zu-hunspell
+ SUBDIR += zxing-cpp
.include <bsd.port.subdir.mk>
diff --git a/textproc/zxing-cpp/Makefile b/textproc/zxing-cpp/Makefile
new file mode 100644
index 000000000000..bb15a44a31d0
--- /dev/null
+++ b/textproc/zxing-cpp/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= zxing-cpp
+PORTVERSION= 0.20161114
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= ZXing C++ Library for QR code recognition
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= glassechidna
+GH_TAGNAME= 97e9c5c
+
+USES= cmake:outsource gmake iconv
+
+.include <bsd.port.mk>
diff --git a/textproc/zxing-cpp/distinfo b/textproc/zxing-cpp/distinfo
new file mode 100644
index 000000000000..74e1bdedb42f
--- /dev/null
+++ b/textproc/zxing-cpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479160657
+SHA256 (glassechidna-zxing-cpp-v0.20161114-97e9c5c_GH0.tar.gz) = 5084329c0d3a045b2c1e416c42e8f52bf4b1afea5d44cb9442b8af12a19cba05
+SIZE (glassechidna-zxing-cpp-v0.20161114-97e9c5c_GH0.tar.gz) = 307807
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp
new file mode 100644
index 000000000000..59ca7b777c9f
--- /dev/null
+++ b/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp
@@ -0,0 +1,11 @@
+--- core/src/zxing/DecodeHints.cpp.orig 2016-11-10 14:45:28 UTC
++++ core/src/zxing/DecodeHints.cpp
+@@ -29,7 +29,7 @@ using zxing::DecodeHints;
+ // VC++
+ using zxing::BarcodeFormat;
+
+-// const DecodeHintType DecodeHints::CHARACTER_SET;
++const DecodeHintType DecodeHints::CHARACTER_SET;
+
+ const DecodeHints DecodeHints::PRODUCT_HINT(
+ UPC_A_HINT |
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp
new file mode 100644
index 000000000000..7ea729463064
--- /dev/null
+++ b/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp
@@ -0,0 +1,10 @@
+--- core/src/zxing/oned/OneDReader.cpp.orig 2016-11-10 14:45:28 UTC
++++ core/src/zxing/oned/OneDReader.cpp
+@@ -21,6 +21,7 @@
+ #include <zxing/oned/OneDResultPoint.h>
+ #include <zxing/NotFoundException.h>
+ #include <math.h>
++#include <float.h>
+ #include <limits.h>
+ #include <algorithm>
+
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp
new file mode 100644
index 000000000000..3b5cad6c226f
--- /dev/null
+++ b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp
@@ -0,0 +1,14 @@
+--- core/src/zxing/pdf417/detector/LinesSampler.cpp.orig 2016-11-10 14:45:28 UTC
++++ core/src/zxing/pdf417/detector/LinesSampler.cpp
+@@ -75,6 +75,11 @@ VoteResult getValueWithMaxVotes(map<int,
+
+ }
+
++const int LinesSampler::MODULES_IN_SYMBOL = 17;
++const int LinesSampler::BARS_IN_SYMBOL = 8;
++const int LinesSampler::POSSIBLE_SYMBOLS = 2787;
++const int LinesSampler::BARCODE_START_OFFSET = 2;
++
+ vector<float> LinesSampler::init_ratios_table() {
+ // Pre-computes and outputs the symbol ratio table.
+ vector<vector<float> > table (BitMatrixParser::SYMBOL_TABLE_LENGTH);
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h
new file mode 100644
index 000000000000..221ef74afe8f
--- /dev/null
+++ b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h
@@ -0,0 +1,19 @@
+--- core/src/zxing/pdf417/detector/LinesSampler.h.orig 2016-11-14 22:55:07 UTC
++++ core/src/zxing/pdf417/detector/LinesSampler.h
+@@ -28,12 +28,12 @@ namespace detector {
+
+ class LinesSampler {
+ protected:
+- static const int MODULES_IN_SYMBOL = 17;
+- static const int BARS_IN_SYMBOL = 8;
+- static const int POSSIBLE_SYMBOLS = 2787;
++ static const int MODULES_IN_SYMBOL;
++ static const int BARS_IN_SYMBOL;
++ static const int POSSIBLE_SYMBOLS;
+ static const std::vector<float> RATIOS_TABLE;
+ static std::vector<float> init_ratios_table();
+- static const int BARCODE_START_OFFSET = 2;
++ static const int BARCODE_START_OFFSET;
+
+ Ref<BitMatrix> linesMatrix_;
+ int symbolsPerLine_;
diff --git a/textproc/zxing-cpp/pkg-descr b/textproc/zxing-cpp/pkg-descr
new file mode 100644
index 000000000000..1b20f9720af3
--- /dev/null
+++ b/textproc/zxing-cpp/pkg-descr
@@ -0,0 +1,3 @@
+The fork of C++ version of ZXing library (https://github.com/zxing/zxing).
+
+WWW: https://github.com/glassechidna/zxing-cpp
diff --git a/textproc/zxing-cpp/pkg-plist b/textproc/zxing-cpp/pkg-plist
new file mode 100644
index 000000000000..ac1762747232
--- /dev/null
+++ b/textproc/zxing-cpp/pkg-plist
@@ -0,0 +1,104 @@
+bin/zxing
+include/zxing/BarcodeFormat.h
+include/zxing/Binarizer.h
+include/zxing/BinaryBitmap.h
+include/zxing/ChecksumException.h
+include/zxing/DecodeHints.h
+include/zxing/Exception.h
+include/zxing/FormatException.h
+include/zxing/IllegalStateException.h
+include/zxing/InvertedLuminanceSource.h
+include/zxing/LuminanceSource.h
+include/zxing/MultiFormatReader.h
+include/zxing/NotFoundException.h
+include/zxing/Reader.h
+include/zxing/ReaderException.h
+include/zxing/Result.h
+include/zxing/ResultPoint.h
+include/zxing/ResultPointCallback.h
+include/zxing/ZXing.h
+include/zxing/aztec/AztecDetectorResult.h
+include/zxing/aztec/AztecReader.h
+include/zxing/aztec/decoder/Decoder.h
+include/zxing/aztec/detector/Detector.h
+include/zxing/common/Array.h
+include/zxing/common/BitArray.h
+include/zxing/common/BitMatrix.h
+include/zxing/common/BitSource.h
+include/zxing/common/CharacterSetECI.h
+include/zxing/common/Counted.h
+include/zxing/common/DecoderResult.h
+include/zxing/common/DetectorResult.h
+include/zxing/common/GlobalHistogramBinarizer.h
+include/zxing/common/GreyscaleLuminanceSource.h
+include/zxing/common/GreyscaleRotatedLuminanceSource.h
+include/zxing/common/GridSampler.h
+include/zxing/common/HybridBinarizer.h
+include/zxing/common/IllegalArgumentException.h
+include/zxing/common/PerspectiveTransform.h
+include/zxing/common/Point.h
+include/zxing/common/Str.h
+include/zxing/common/StringUtils.h
+include/zxing/common/detector/JavaMath.h
+include/zxing/common/detector/MathUtils.h
+include/zxing/common/detector/MonochromeRectangleDetector.h
+include/zxing/common/detector/WhiteRectangleDetector.h
+include/zxing/common/reedsolomon/GenericGF.h
+include/zxing/common/reedsolomon/GenericGFPoly.h
+include/zxing/common/reedsolomon/ReedSolomonDecoder.h
+include/zxing/common/reedsolomon/ReedSolomonException.h
+include/zxing/datamatrix/DataMatrixReader.h
+include/zxing/datamatrix/Version.h
+include/zxing/datamatrix/decoder/BitMatrixParser.h
+include/zxing/datamatrix/decoder/DataBlock.h
+include/zxing/datamatrix/decoder/DecodedBitStreamParser.h
+include/zxing/datamatrix/decoder/Decoder.h
+include/zxing/datamatrix/detector/CornerPoint.h
+include/zxing/datamatrix/detector/Detector.h
+include/zxing/datamatrix/detector/DetectorException.h
+include/zxing/multi/ByQuadrantReader.h
+include/zxing/multi/GenericMultipleBarcodeReader.h
+include/zxing/multi/MultipleBarcodeReader.h
+include/zxing/multi/qrcode/QRCodeMultiReader.h
+include/zxing/multi/qrcode/detector/MultiDetector.h
+include/zxing/multi/qrcode/detector/MultiFinderPatternFinder.h
+include/zxing/oned/CodaBarReader.h
+include/zxing/oned/Code128Reader.h
+include/zxing/oned/Code39Reader.h
+include/zxing/oned/Code93Reader.h
+include/zxing/oned/EAN13Reader.h
+include/zxing/oned/EAN8Reader.h
+include/zxing/oned/ITFReader.h
+include/zxing/oned/MultiFormatOneDReader.h
+include/zxing/oned/MultiFormatUPCEANReader.h
+include/zxing/oned/OneDReader.h
+include/zxing/oned/OneDResultPoint.h
+include/zxing/oned/UPCAReader.h
+include/zxing/oned/UPCEANReader.h
+include/zxing/oned/UPCEReader.h
+include/zxing/pdf417/PDF417Reader.h
+include/zxing/pdf417/decoder/BitMatrixParser.h
+include/zxing/pdf417/decoder/DecodedBitStreamParser.h
+include/zxing/pdf417/decoder/Decoder.h
+include/zxing/pdf417/decoder/ec/ErrorCorrection.h
+include/zxing/pdf417/decoder/ec/ModulusGF.h
+include/zxing/pdf417/decoder/ec/ModulusPoly.h
+include/zxing/pdf417/detector/Detector.h
+include/zxing/pdf417/detector/LinesSampler.h
+include/zxing/qrcode/ErrorCorrectionLevel.h
+include/zxing/qrcode/FormatInformation.h
+include/zxing/qrcode/QRCodeReader.h
+include/zxing/qrcode/Version.h
+include/zxing/qrcode/decoder/BitMatrixParser.h
+include/zxing/qrcode/decoder/DataBlock.h
+include/zxing/qrcode/decoder/DataMask.h
+include/zxing/qrcode/decoder/DecodedBitStreamParser.h
+include/zxing/qrcode/decoder/Decoder.h
+include/zxing/qrcode/decoder/Mode.h
+include/zxing/qrcode/detector/AlignmentPattern.h
+include/zxing/qrcode/detector/AlignmentPatternFinder.h
+include/zxing/qrcode/detector/Detector.h
+include/zxing/qrcode/detector/FinderPattern.h
+include/zxing/qrcode/detector/FinderPatternFinder.h
+include/zxing/qrcode/detector/FinderPatternInfo.h
+lib/libzxing.a