aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-06-12 05:44:16 +0800
committerrakuco <rakuco@FreeBSD.org>2013-06-12 05:44:16 +0800
commit1931c15f9b98c26e8b61add4fd4964305eb8f8fd (patch)
treeb38c646c74dad6bc372d7e95059a38c4b3258682 /textproc
parent39a45577a1ddb8cfeffc1667badf4f20acc00d7b (diff)
downloadfreebsd-ports-gnome-1931c15f9b98c26e8b61add4fd4964305eb8f8fd.tar.gz
freebsd-ports-gnome-1931c15f9b98c26e8b61add4fd4964305eb8f8fd.tar.zst
freebsd-ports-gnome-1931c15f9b98c26e8b61add4fd4964305eb8f8fd.zip
Respect CXXFLAGS when linking.
hunspell's configure script seems to have been generated with a very old version of libtool. Specifically, it does not uses CFLAGS instead of CXXFLAGS when performing some tests related to the C++ compiler. This ends up making it add '-lstdc++' to the linker's command line even if one sets CXXFLAGS to -stdlib=libc++. The attached patch fixes the problem by "backporting" the appropriate libtool.m4 change to the configure script. PR: ports/178696 Approved by: maintainer timeout (office@, 28 days)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/hunspell/Makefile2
-rw-r--r--textproc/hunspell/files/patch-configure26
2 files changed, 27 insertions, 1 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index 7291a541c679..f698e61c3d8d 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hunspell
PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/Hunspell/${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
diff --git a/textproc/hunspell/files/patch-configure b/textproc/hunspell/files/patch-configure
new file mode 100644
index 000000000000..2c62f4863229
--- /dev/null
+++ b/textproc/hunspell/files/patch-configure
@@ -0,0 +1,26 @@
+--- configure.orig 2013-05-17 01:18:45.000000000 +0300
++++ configure 2013-05-17 01:26:35.000000000 +0300
+@@ -11880,6 +11880,7 @@
+
+ # Allow CC to be a program name with arguments.
+ lt_save_CC=$CC
++ lt_save_CFLAGS=$CFLAGS
+ lt_save_LD=$LD
+ lt_save_GCC=$GCC
+ GCC=$GXX
+@@ -11897,6 +11898,7 @@
+ fi
+ test -z "${LDCXX+set}" || LD=$LDCXX
+ CC=${CXX-"c++"}
++ CFLAGS=$CXXFLAGS
+ compiler=$CC
+ compiler_CXX=$CC
+ for cc_temp in $compiler""; do
+@@ -14618,6 +14620,7 @@
+ fi # test -n "$compiler"
+
+ CC=$lt_save_CC
++ CFLAGS=$lt_save_CFLAGS
+ LDCXX=$LD
+ LD=$lt_save_LD
+ GCC=$lt_save_GCC