aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-07-15 22:31:54 +0800
committerolgeni <olgeni@FreeBSD.org>2015-07-15 22:31:54 +0800
commit23e0db0f086eaa8b8558b782263ef06c9e0e4b60 (patch)
treedc74e18e93f5dffb28f3b8d93420cdae435f7614 /textproc
parent93d823325213a1d96d963c526c6ec029b3a1cbb0 (diff)
downloadfreebsd-ports-gnome-23e0db0f086eaa8b8558b782263ef06c9e0e4b60.tar.gz
freebsd-ports-gnome-23e0db0f086eaa8b8558b782263ef06c9e0e4b60.tar.zst
freebsd-ports-gnome-23e0db0f086eaa8b8558b782263ef06c9e0e4b60.zip
Add textproc/elixir-sweet_xml, a wrapper around xmerl for Elixir.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elixir-sweet_xml/Makefile17
-rw-r--r--textproc/elixir-sweet_xml/distinfo2
-rw-r--r--textproc/elixir-sweet_xml/files/patch-mix.exs11
-rw-r--r--textproc/elixir-sweet_xml/pkg-descr5
-rw-r--r--textproc/elixir-sweet_xml/pkg-plist5
6 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2ca8bf8398fe..459156223c2b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -152,6 +152,7 @@
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
+ SUBDIR += elixir-sweet_xml
SUBDIR += emacs-wiki
SUBDIR += en-aspell
SUBDIR += en-hunspell
diff --git a/textproc/elixir-sweet_xml/Makefile b/textproc/elixir-sweet_xml/Makefile
new file mode 100644
index 000000000000..1e26f057e77a
--- /dev/null
+++ b/textproc/elixir-sweet_xml/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= sweet_xml
+PORTVERSION= 0.2.1
+CATEGORIES= textproc
+PKGNAMEPREFIX= elixir-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Wrapper around xmerl application for Elixir
+
+LICENSE= MIT
+
+USES= elixir
+USE_GITHUB= yes
+GH_ACCOUNT= gniquil
+
+.include <bsd.port.mk>
diff --git a/textproc/elixir-sweet_xml/distinfo b/textproc/elixir-sweet_xml/distinfo
new file mode 100644
index 000000000000..14c3c8921539
--- /dev/null
+++ b/textproc/elixir-sweet_xml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gniquil-sweet_xml-0.2.1_GH0.tar.gz) = cec2c401bfe336d1151f3996f7d38b7afad527b7e1c6967f7dcbc40a668ad3f5
+SIZE (gniquil-sweet_xml-0.2.1_GH0.tar.gz) = 66589
diff --git a/textproc/elixir-sweet_xml/files/patch-mix.exs b/textproc/elixir-sweet_xml/files/patch-mix.exs
new file mode 100644
index 000000000000..30a2e1332a8b
--- /dev/null
+++ b/textproc/elixir-sweet_xml/files/patch-mix.exs
@@ -0,0 +1,11 @@
+--- mix.exs.orig 2015-07-15 14:25:56 UTC
++++ mix.exs
+@@ -26,8 +26,6 @@ defmodule SweetXml.Mixfile do
+
+ defp deps do
+ [
+- {:ex_doc, "~> 0.7", only: :dev},
+- {:markdown, github: "devinus/markdown"}
+ ]
+ end
+ end
diff --git a/textproc/elixir-sweet_xml/pkg-descr b/textproc/elixir-sweet_xml/pkg-descr
new file mode 100644
index 000000000000..74f4fe3cdf79
--- /dev/null
+++ b/textproc/elixir-sweet_xml/pkg-descr
@@ -0,0 +1,5 @@
+SweetXml is a thin wrapper around :xmerl. It allows you to converts
+a string or xmlElement record as defined in :xmerl to an elixir
+value such as map, list, char_list, or any combination of these.
+
+WWW: https://github.com/gniquil/sweet_xml
diff --git a/textproc/elixir-sweet_xml/pkg-plist b/textproc/elixir-sweet_xml/pkg-plist
new file mode 100644
index 000000000000..4df5dd9b8d2d
--- /dev/null
+++ b/textproc/elixir-sweet_xml/pkg-plist
@@ -0,0 +1,5 @@
+lib/elixir/lib/sweet_xml/ebin/Elixir.SweetXml.beam
+lib/elixir/lib/sweet_xml/ebin/Elixir.SweetXpath.beam
+lib/elixir/lib/sweet_xml/ebin/sweet_xml.app
+lib/elixir/lib/sweet_xml/lib/sweet_xml.ex
+%%PORTDOCS%%%%DOCSDIR%%/README.md