aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-05-29 00:37:49 +0800
committermat <mat@FreeBSD.org>2015-05-29 00:37:49 +0800
commit2a3c9b387a946f95bd531df73ace72c45995cb21 (patch)
tree2d1cf16c62ab302cbdad66d3ef8b87a3e1c039c2 /textproc
parenta8fbbbec54adb390ede738bd1cc5e138480978c3 (diff)
downloadfreebsd-ports-gnome-2a3c9b387a946f95bd531df73ace72c45995cb21.tar.gz
freebsd-ports-gnome-2a3c9b387a946f95bd531df73ace72c45995cb21.tar.zst
freebsd-ports-gnome-2a3c9b387a946f95bd531df73ace72c45995cb21.zip
Convert a few ports to use the new multi-github framework.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'textproc')
-rw-r--r--textproc/consul-template/Makefile44
-rw-r--r--textproc/consul-template/distinfo32
2 files changed, 32 insertions, 44 deletions
diff --git a/textproc/consul-template/Makefile b/textproc/consul-template/Makefile
index 1bc6e0531fed..15ebbf58f31e 100644
--- a/textproc/consul-template/Makefile
+++ b/textproc/consul-template/Makefile
@@ -5,23 +5,6 @@ PORTNAME= consul-template
PORTVERSION= 0.8.0
DISTVERSIONPREFIX= v
CATEGORIES= textproc
-MASTER_SITES= https://codeload.github.com/armon/consul-api/legacy.tar.gz/0e644b8?dummy=/:group2 \
- https://codeload.github.com/hashicorp/hcl/legacy.tar.gz/2c88e7e?dummy=/:group3 \
- https://codeload.github.com/hashicorp/logutils/legacy.tar.gz/23b0af5?dummy=/:group4 \
- https://codeload.github.com/hashicorp/terraform/legacy.tar.gz/d87fa90?dummy=/:group5 \
- https://codeload.github.com/mitchellh/mapstructure/legacy.tar.gz/740c764?dummy=/:group6 \
- https://github.com/hashicorp/go-multierror/archive/fcdddc395df1ddf4247c69bd436e84cfa0733f7e.tar.gz?dummy=/:group7 \
- https://github.com/hashicorp/go-syslog/archive/42a2b573b664dbf281bd48c3cc12c086b17a39ba.tar.gz?dummy=/:group8 \
- https://github.com/hashicorp/consul/archive/v0.5.0.tar.gz?dummy=/:group9
-DISTFILES= ${DISTNAME}.tar.gz \
- armon-consul-api-0e644b8.tar.gz:group2 \
- hashicorp-hcl-2c88e7e.tar.gz:group3 \
- hashicorp-logutils-23b0af5.tar.gz:group4 \
- hashicorp-terraform-d87fa90.tar.gz:group5 \
- mitchellh-mapstructure-740c764.tar.gz:group6 \
- hashicorp_go-multierror_fcdddc395df1ddf4247c69bd436e84cfa0733f7e.tar.gz:group7 \
- hashicorp_go-syslog_42a2b573b664dbf281bd48c3cc12c086b17a39ba.tar.gz:group8 \
- consul-v0.5.0.tar.gz:group9
MAINTAINER= swills@FreeBSD.org
COMMENT= Generic template rendering and notifications with Consul
@@ -29,9 +12,14 @@ COMMENT= Generic template rendering and notifications with Consul
BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
USE_GITHUB= yes
-GH_ACCOUNT= hashicorp
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GH_ACCOUNT= hashicorp:DEFAULT,consul,go_multierror,go_syslog,hcl,logutils,terraform \
+ armon:consul_api mitchellh:mapstructure
+GH_PROJECT= consul-api:consul_api consul:consul \
+ go-multierror:go_multierror go-syslog:go_syslog hcl:hcl \
+ logutils:logutils mapstructure:mapstructure terraform:terraform
+GH_TAGNAME= 0e644b8:consul_api 23b0af5:logutils 2c88e7e:hcl \
+ 42a2b57:go_syslog 740c764:mapstructure d87fa90:terraform \
+ fcdddc3:go_multierror v0.5.0:consul
PLIST_FILES= bin/consul-template
@@ -49,14 +37,14 @@ post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/armon
@${MKDIR} ${WRKSRC}/src/github.com/mitchellh
@${MKDIR} ${WRKSRC}/src/github.com/hashicorp
- @${MV} ${WRKDIR}/armon-consul-api-0e644b8 ${WRKSRC}/src/github.com/armon/consul-api
- @${MV} ${WRKDIR}/hashicorp-hcl-2c88e7e ${WRKSRC}/src/github.com/hashicorp/hcl
- @${MV} ${WRKDIR}/hashicorp-logutils-23b0af5 ${WRKSRC}/src/github.com/hashicorp/logutils
- @${MV} ${WRKDIR}/hashicorp-terraform-d87fa90 ${WRKSRC}/src/github.com/hashicorp/terraform
- @${MV} ${WRKDIR}/mitchellh-mapstructure-740c764 ${WRKSRC}/src/github.com/mitchellh/mapstructure
- @${MV} ${WRKDIR}/go-multierror-fcdddc395df1ddf4247c69bd436e84cfa0733f7e ${WRKSRC}/src/github.com/hashicorp/go-multierror
- @${MV} ${WRKDIR}/go-syslog-42a2b573b664dbf281bd48c3cc12c086b17a39ba ${WRKSRC}/src/github.com/hashicorp/go-syslog
- @${MV} ${WRKDIR}/consul-0.5.0 ${WRKSRC}/src/github.com/hashicorp/consul
+ @${MV} ${WRKSRC_consul_api} ${WRKSRC}/src/github.com/armon/consul-api
+ @${MV} ${WRKSRC_hcl} ${WRKSRC}/src/github.com/hashicorp/hcl
+ @${MV} ${WRKSRC_logutils} ${WRKSRC}/src/github.com/hashicorp/logutils
+ @${MV} ${WRKSRC_terraform} ${WRKSRC}/src/github.com/hashicorp/terraform
+ @${MV} ${WRKSRC_mapstructure} ${WRKSRC}/src/github.com/mitchellh/mapstructure
+ @${MV} ${WRKSRC_go_multierror} ${WRKSRC}/src/github.com/hashicorp/go-multierror
+ @${MV} ${WRKSRC_go_syslog} ${WRKSRC}/src/github.com/hashicorp/go-syslog
+ @${MV} ${WRKSRC_consul} ${WRKSRC}/src/github.com/hashicorp/consul
do-build:
@cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build
diff --git a/textproc/consul-template/distinfo b/textproc/consul-template/distinfo
index 060b7a83e67e..62fec2d42116 100644
--- a/textproc/consul-template/distinfo
+++ b/textproc/consul-template/distinfo
@@ -1,18 +1,18 @@
SHA256 (hashicorp-consul-template-v0.8.0_GH0.tar.gz) = ac12bdde35e88184d5e3f2201c2f46e2dd7b301d4f31b51945905d1b2c456064
SIZE (hashicorp-consul-template-v0.8.0_GH0.tar.gz) = 63281
-SHA256 (armon-consul-api-0e644b8.tar.gz) = 98ced8eb879ad2aec426e8821973e476ad76d5e91aa467362aaac98b7ae639b0
-SIZE (armon-consul-api-0e644b8.tar.gz) = 17558
-SHA256 (hashicorp-hcl-2c88e7e.tar.gz) = 2f3dc2241a1716b8e9c7bd331d8113b9b780a1233bf2dcf73bb77c68ebe17d0e
-SIZE (hashicorp-hcl-2c88e7e.tar.gz) = 28350
-SHA256 (hashicorp-logutils-23b0af5.tar.gz) = 00187038a1bbf6ac3575e7630216903fdbbe6165dd4d4415023d030736994025
-SIZE (hashicorp-logutils-23b0af5.tar.gz) = 7691
-SHA256 (hashicorp-terraform-d87fa90.tar.gz) = 5657d8f9a596c94e86c72d50e8eedbb4da8942eed56e5317e6611a488c557d54
-SIZE (hashicorp-terraform-d87fa90.tar.gz) = 3245770
-SHA256 (mitchellh-mapstructure-740c764.tar.gz) = 5d140730c448532df9b1413fe03e752462a992d6ff2badcc5d2eb4bb9346a478
-SIZE (mitchellh-mapstructure-740c764.tar.gz) = 11949
-SHA256 (hashicorp_go-multierror_fcdddc395df1ddf4247c69bd436e84cfa0733f7e.tar.gz) = af90f9be029c091eb011ff25d270772fdb51edf3c6396cf99f224c4e7ad724c3
-SIZE (hashicorp_go-multierror_fcdddc395df1ddf4247c69bd436e84cfa0733f7e.tar.gz) = 8058
-SHA256 (hashicorp_go-syslog_42a2b573b664dbf281bd48c3cc12c086b17a39ba.tar.gz) = 378f5249729661db9d0c65030fbf636f6ec1d60ee926e67abf8c6dd7921d3907
-SIZE (hashicorp_go-syslog_42a2b573b664dbf281bd48c3cc12c086b17a39ba.tar.gz) = 4397
-SHA256 (consul-v0.5.0.tar.gz) = 282f561c814fdb1f61106f3bb64b881c8eabc71f79f70f581509714e96f0449a
-SIZE (consul-v0.5.0.tar.gz) = 1608079
+SHA256 (hashicorp-consul-v0.5.0_GH0.tar.gz) = 282f561c814fdb1f61106f3bb64b881c8eabc71f79f70f581509714e96f0449a
+SIZE (hashicorp-consul-v0.5.0_GH0.tar.gz) = 1608079
+SHA256 (hashicorp-go-multierror-fcdddc3_GH0.tar.gz) = e730020ed331e0fed430a5f725de4c5f61aa7f240258f797833d1689efb178b0
+SIZE (hashicorp-go-multierror-fcdddc3_GH0.tar.gz) = 8064
+SHA256 (hashicorp-go-syslog-42a2b57_GH0.tar.gz) = c092db8da3dc2c7279b4ad6afbb6ee7c4daae9ac3020a591096be59f94330544
+SIZE (hashicorp-go-syslog-42a2b57_GH0.tar.gz) = 4394
+SHA256 (hashicorp-hcl-2c88e7e_GH0.tar.gz) = e16ce4e45f4debe9fd454946125da7f830ab59e564c3765918602b593d082443
+SIZE (hashicorp-hcl-2c88e7e_GH0.tar.gz) = 28350
+SHA256 (hashicorp-logutils-23b0af5_GH0.tar.gz) = 357fe9e27ef2ca04df6a80d35d942cc017b426be8f0bcdaeef89b8b1ae0374f3
+SIZE (hashicorp-logutils-23b0af5_GH0.tar.gz) = 7690
+SHA256 (hashicorp-terraform-d87fa90_GH0.tar.gz) = 750141c683c96b5434b037af1e7ab6cc4721ce5e485295e4e621c4787459e6fe
+SIZE (hashicorp-terraform-d87fa90_GH0.tar.gz) = 3245706
+SHA256 (armon-consul-api-0e644b8_GH0.tar.gz) = cfeb1ac28f9696d8311c082da317d216bf53df350c14fa7970dadd866589e7e4
+SIZE (armon-consul-api-0e644b8_GH0.tar.gz) = 17549
+SHA256 (mitchellh-mapstructure-740c764_GH0.tar.gz) = d68a258cdb95fc5f2971cd50ad29c0c479f6c3420ddeec386077626e517b5f71
+SIZE (mitchellh-mapstructure-740c764_GH0.tar.gz) = 11943