aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2014-02-13 00:48:32 +0800
committertj <tj@FreeBSD.org>2014-02-13 00:48:32 +0800
commit492890e83738b9f2e3874dddeef4a20c661e7b39 (patch)
tree1859b6e1462cb3dc09c3c5eb0dd695b493647f93 /textproc
parent33e4347fa8804cb36e96df723261cf59b0998ea1 (diff)
downloadfreebsd-ports-gnome-492890e83738b9f2e3874dddeef4a20c661e7b39.tar.gz
freebsd-ports-gnome-492890e83738b9f2e3874dddeef4a20c661e7b39.tar.zst
freebsd-ports-gnome-492890e83738b9f2e3874dddeef4a20c661e7b39.zip
Update to 0.9.11.
Changes: http://www.elasticsearch.org/downloads/0-90-11/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch/Makefile26
-rw-r--r--textproc/elasticsearch/distinfo4
-rw-r--r--textproc/elasticsearch/files/elasticsearch.in4
-rw-r--r--textproc/elasticsearch/pkg-plist8
4 files changed, 20 insertions, 22 deletions
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index f422b8a71136..5923854eecef 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 0.90.0
+PORTVERSION= 0.90.11
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -18,13 +18,12 @@ JAVA_VERSION= 1.7+
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= ${PORTNAME}
-NO_STAGE= yes
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-LUCENEVER= 4.2.1
+LUCENEVER= 4.6.1
CONFIG_FILES= elasticsearch.yml logging.yml
JARS= elasticsearch-${PORTVERSION}.jar \
jna-3.3.0.jar \
@@ -71,26 +70,23 @@ post-patch:
${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
do-install:
- ${INSTALL} -d -o ${SEARCHUSER} -g ${SEARCHUSER} -m 750 ${PREFIX}/etc/elasticsearch
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
.for f in ${CONFIG_FILES}
- ${INSTALL} -o ${SEARCHUSER} -g ${SEARCHUSER} -m 444 ${WRKSRC}/config/${f} ${PREFIX}/etc/elasticsearch/${f}.sample
- @if [ ! -f ${CONFIG_DIR}/${f} ]; then \
- ${CP} -p ${PREFIX}/etc/elasticsearch/${f}.sample ${PREFIX}/etc/elasticsearch/${f} ; \
- fi
+ ${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${PREFIX}/etc/elasticsearch/${f}.sample
.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/elasticsearch-plugin ${PREFIX}/bin/elasticsearch-plugin
- ${MKDIR} ${PREFIX}/lib/elasticsearch
+ ${INSTALL_SCRIPT} ${WRKDIR}/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch
.for f in ${JARS}
- ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/elasticsearch/
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/
.endfor
- ${MKDIR} ${PREFIX}/lib/elasticsearch/sigar
- ${INSTALL_DATA} ${WRKSRC}/lib/sigar/sigar-1.6.4.jar ${PREFIX}/lib/elasticsearch/sigar/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/sigar
+ ${INSTALL_DATA} ${WRKSRC}/lib/sigar/sigar-1.6.4.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/sigar/
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/textproc/elasticsearch/distinfo b/textproc/elasticsearch/distinfo
index a745874bfb93..732db2fdb652 100644
--- a/textproc/elasticsearch/distinfo
+++ b/textproc/elasticsearch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (elasticsearch-0.90.0.tar.gz) = 168864fed1a7b9f11c3e144b881cf7f2c3021e68dd71819f87f02b06b0edc24c
-SIZE (elasticsearch-0.90.0.tar.gz) = 17743635
+SHA256 (elasticsearch-0.90.11.tar.gz) = cff503078fcb3e1b1d2b966e9173599be38a1a451278f587415c7f2311fd5697
+SIZE (elasticsearch-0.90.11.tar.gz) = 18147996
diff --git a/textproc/elasticsearch/files/elasticsearch.in b/textproc/elasticsearch/files/elasticsearch.in
index c86df05081e9..1e4f27500cfa 100644
--- a/textproc/elasticsearch/files/elasticsearch.in
+++ b/textproc/elasticsearch/files/elasticsearch.in
@@ -73,7 +73,9 @@ command_args="-f %%LOCALBASE%%/bin/java -Des.pidfile=${pidfile} ${elasticsearch_
elasticsearch_precmd() {
touch ${pidfile}
chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
- /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/db/elasticsearch
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
}
elasticsearch_console () {
diff --git a/textproc/elasticsearch/pkg-plist b/textproc/elasticsearch/pkg-plist
index 9293f76dd7ae..c20358526b51 100644
--- a/textproc/elasticsearch/pkg-plist
+++ b/textproc/elasticsearch/pkg-plist
@@ -1,15 +1,15 @@
+@owner %%SEARCHUSER%%
+@group %%SEARCHGROUP%%
@unexec if cmp -s %D/etc/elasticsearch/elasticsearch.yml.sample %D/etc/elasticsearch/elasticsearch.yml; then rm -f %D/etc/elasticsearch/elasticsearch.yml; fi
etc/elasticsearch/elasticsearch.yml.sample
@exec if [ ! -f %D/etc/elasticsearch/elasticsearch.yml ] ; then cp -p %D/%F %B/elasticsearch.yml; fi
@unexec if cmp -s %D/etc/elasticsearch/logging.yml.sample %D/etc/elasticsearch/logging.yml; then rm -f %D/etc/elasticsearch/logging.yml; fi
etc/elasticsearch/logging.yml.sample
@exec if [ ! -f %D/etc/elasticsearch/logging.yml ] ; then cp -p %D/%F %B/logging.yml; fi
-@exec install -d -o %%SEARCHUSER%% -g %%SEARCHGROUP%% %%ELASTIC_DBDIR%%
-@dirrmtry %%ELASTIC_LOGDIR%%
@unexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
-@exec install -d -o %%SEARCHUSER%% -g %%SEARCHGROUP%% %%ELASTIC_LOGDIR%%
-@dirrmtry %%ELASTIC_DBDIR%%
@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
+@owner
+@group
bin/elasticsearch-plugin
lib/elasticsearch/elasticsearch-%%PORTVERSION%%.jar
lib/elasticsearch/jna-3.3.0.jar