aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-08-16 10:33:05 +0800
committerkris <kris@FreeBSD.org>2004-08-16 10:33:05 +0800
commit4c32b4dc0e277a56a00a54ce0a4d9363d65d75ae (patch)
treebfad1c5a415ba3bf86fc67750ccb4b476511b188 /textproc
parent13ccd05622018a941264027d27d850ec2adc030a (diff)
downloadfreebsd-ports-gnome-4c32b4dc0e277a56a00a54ce0a4d9363d65d75ae.tar.gz
freebsd-ports-gnome-4c32b4dc0e277a56a00a54ce0a4d9363d65d75ae.tar.zst
freebsd-ports-gnome-4c32b4dc0e277a56a00a54ce0a4d9363d65d75ae.zip
BROKEN on 5.x: Does not compile with gcc 3.4.2
Diffstat (limited to 'textproc')
-rw-r--r--textproc/domc/Makefile8
-rw-r--r--textproc/word2x/Makefile8
-rw-r--r--textproc/xmlppm/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/textproc/domc/Makefile b/textproc/domc/Makefile
index b7690e611c8c..21ed9095dd59 100644
--- a/textproc/domc/Makefile
+++ b/textproc/domc/Makefile
@@ -28,8 +28,14 @@ INSTALLS_SHLIB= yes
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
-e "s|gcc|${CC}|g" ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/word2x/Makefile b/textproc/word2x/Makefile
index 31e80af34c8b..c9055a74b581 100644
--- a/textproc/word2x/Makefile
+++ b/textproc/word2x/Makefile
@@ -22,4 +22,10 @@ GNU_CONFIGURE= yes
MAN1= word2x.1
PLIST_FILES= bin/rtest2 bin/word2x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
index 029c5089b6d6..f6949b663674 100644
--- a/textproc/xmlppm/Makefile
+++ b/textproc/xmlppm/Makefile
@@ -27,6 +27,12 @@ USE_ICONV= yes
MAKE_ARGS= CC="${CXX}" OPT_FLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lexpat -liconv"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmlppm ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/xmlunppm ${PREFIX}/bin
@@ -35,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>