aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-11 22:18:01 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:22:30 +0800
commit571015546123021553fe7bdce7be2a346eca2faf (patch)
treea03389c683dc28e3b281b76c1bb8dbf6bee07984 /textproc
parent472462823561f4f67165c505a1c40534eeadcde3 (diff)
downloadfreebsd-ports-gnome-571015546123021553fe7bdce7be2a346eca2faf.tar.gz
freebsd-ports-gnome-571015546123021553fe7bdce7be2a346eca2faf.tar.zst
freebsd-ports-gnome-571015546123021553fe7bdce7be2a346eca2faf.zip
Do not abuse INSTALL_MAN when installing documentation, examples, and
other miscellaneous files that are not actually manual pages (part 2).
Diffstat (limited to 'textproc')
-rw-r--r--textproc/bibtool/Makefile2
-rw-r--r--textproc/perl2html/Makefile2
-rw-r--r--textproc/yaml-mode.el/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/textproc/bibtool/Makefile b/textproc/bibtool/Makefile
index b927f7ac9c0b..a45f7d1b6c5d 100644
--- a/textproc/bibtool/Makefile
+++ b/textproc/bibtool/Makefile
@@ -31,7 +31,7 @@ post-build:
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/textproc/perl2html/Makefile b/textproc/perl2html/Makefile
index a77137383a16..5532992780ec 100644
--- a/textproc/perl2html/Makefile
+++ b/textproc/perl2html/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS NEWS README
- ${INSTALL_MAN} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>
diff --git a/textproc/yaml-mode.el/Makefile b/textproc/yaml-mode.el/Makefile
index a0ff02d84c3b..fd4ee0754cc1 100644
--- a/textproc/yaml-mode.el/Makefile
+++ b/textproc/yaml-mode.el/Makefile
@@ -32,7 +32,7 @@ pre-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in Changes README
- ${INSTALL_MAN} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>