aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2013-10-17 04:15:24 +0800
committermatthew <matthew@FreeBSD.org>2013-10-17 04:15:24 +0800
commit5fbc855a01f9225eebccf2e668a18762c73389c0 (patch)
tree293328e4ae0a07c24725435f074329f189664559 /textproc
parente2116810ad9db33f167d46d8cf446a128df6ac1e (diff)
downloadfreebsd-ports-gnome-5fbc855a01f9225eebccf2e668a18762c73389c0.tar.gz
freebsd-ports-gnome-5fbc855a01f9225eebccf2e668a18762c73389c0.tar.zst
freebsd-ports-gnome-5fbc855a01f9225eebccf2e668a18762c73389c0.zip
Update to 2.1.2
- stagify - new style LIB_DEPENDS Announcement: http://sphinxsearch.com/blog/2013/10/15/sphinx-2-1-2-is-now-available/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/sphinxsearch/Makefile42
-rw-r--r--textproc/sphinxsearch/distinfo4
-rw-r--r--textproc/sphinxsearch/pkg-plist5
3 files changed, 25 insertions, 26 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index baa2780de23e..f5daeb223535 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -6,7 +6,7 @@
# See http://www.infracaninophile.co.uk/articles/sphinxse.html
PORTNAME= sphinxsearch
-PORTVERSION= 2.0.9
+PORTVERSION= 2.1.2
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/
DISTNAME= sphinx-${PORTVERSION}-release
@@ -20,7 +20,7 @@ LICENSE= GPLv2
# If expat is present on the system and configure finds it, it will
# unconditionally link the output binary against it. There's no way
# of turning this off. So for consistency, make sure it's always on.
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
SYSLOG UNIXODBC
@@ -39,7 +39,6 @@ OPTIONS_DEFAULT= ICONV MYSQL SYSLOG
CONFLICTS= sphinxsearch-devel-[0-9]* dpsearch-[0-9]* rdb-[0-9]* \
swish++-[0-9]* xaira-[0-9]*
-NO_STAGE= yes
.include <bsd.port.options.mk>
# The port will successfully compile with both PGSQL and MYSQL support
@@ -152,9 +151,9 @@ PORTEXAMPLES= *
.if ${PORT_OPTIONS:MDOCS}
DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
-MAN1= indexer.1 indextool.1 search.1 spelldump.1
-MAN8= searchd.8
DOCSRC= ${WRKSRC}/doc
+MAN1SRC= indexer.1 indextool.1 search.1 spelldump.1
+MAN8SRC= searchd.8
.endif
post-extract:
@@ -183,42 +182,37 @@ post-patch:
do-install: install-bin install-docs install-man install-examples
install-bin:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/indexer ${PREFIX}/bin/indexer
- ${INSTALL_PROGRAM} ${WRKSRC}/src/indextool ${PREFIX}/bin/indextool
- ${INSTALL_PROGRAM} ${WRKSRC}/src/search ${PREFIX}/bin/search
- ${INSTALL_PROGRAM} ${WRKSRC}/src/spelldump ${PREFIX}/bin/spelldump
- ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${PREFIX}/sbin/searchd
- ${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${CFGFILE}.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/indexer ${STAGEDIR}${PREFIX}/bin/indexer
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/indextool ${STAGEDIR}${PREFIX}/bin/indextool
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/search ${STAGEDIR}${PREFIX}/bin/search
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/spelldump ${STAGEDIR}${PREFIX}/bin/spelldump
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${STAGEDIR}${PREFIX}/sbin/searchd
+ ${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${STAGEDIR}${CFGFILE}.sample
install-docs:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
install-man:
.if ${PORT_OPTIONS:MDOCS}
-.for man in ${MAN1}
- ${INSTALL_MAN} ${DOCSRC}/${man} ${MANPREFIX}/man/man1/${man}
+.for man in ${MAN1SRC}
+ ${INSTALL_MAN} ${DOCSRC}/${man} ${STAGEDIR}${MANPREFIX}/man/man1/${man}
.endfor
-.for man in ${MAN8}
- ${INSTALL_MAN} ${DOCSRC}/${man} ${MANPREFIX}/man/man8/${man}
+.for man in ${MAN8SRC}
+ ${INSTALL_MAN} ${DOCSRC}/${man} ${STAGEDIR}${MANPREFIX}/man/man8/${man}
.endfor
.endif
install-examples:
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for example in ${EXAMPLES}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} ${example} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${example} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.endif
-post-install-cfg:
- @if [ ! -f ${CFGFILE} ]; then \
- ${CP} -p ${CFGFILE}.sample ${CFGFILE} ; \
- fi
-
.include <bsd.port.mk>
diff --git a/textproc/sphinxsearch/distinfo b/textproc/sphinxsearch/distinfo
index 3fc597fadebc..a20d68d77070 100644
--- a/textproc/sphinxsearch/distinfo
+++ b/textproc/sphinxsearch/distinfo
@@ -1,4 +1,4 @@
-SHA256 (sphinx-2.0.9-release.tar.gz) = c4fb5d7951bc0831e46f102d17b5f32bbde11434ce3b00b20531dfe9e646869d
-SIZE (sphinx-2.0.9-release.tar.gz) = 1996939
+SHA256 (sphinx-2.1.2-release.tar.gz) = 73d63a5875a557196847d373f74a65713c81ede8329389fccc593f0e65703e60
+SIZE (sphinx-2.1.2-release.tar.gz) = 2388748
SHA256 (libstemmer_c.tgz) = 5adcf6432fd3d5ba51c8674d833d851b5aa6e532d52ff95e57102033edcd285f
SIZE (libstemmer_c.tgz) = 129496
diff --git a/textproc/sphinxsearch/pkg-plist b/textproc/sphinxsearch/pkg-plist
index 69e851942acd..c67005db0e02 100644
--- a/textproc/sphinxsearch/pkg-plist
+++ b/textproc/sphinxsearch/pkg-plist
@@ -6,6 +6,11 @@ sbin/searchd
@unexec if cmp -s %D/etc/sphinx.conf.sample %D/etc/sphinx.conf; then rm -f %D/etc/sphinx.conf; fi
etc/sphinx.conf.sample
@exec if [ ! -f %D/etc/sphinx.conf ] ; then cp -p %D/%F %B/sphinx.conf; fi
+%%PORTDOCS%%man/man1/indexer.1.gz
+%%PORTDOCS%%man/man1/indextool.1.gz
+%%PORTDOCS%%man/man1/search.1.gz
+%%PORTDOCS%%man/man1/spelldump.1.gz
+%%PORTDOCS%%man/man8/searchd.8.gz
%%PORTDOCS%%%%DOCSDIR%%/sphinx.css
%%PORTDOCS%%%%DOCSDIR%%/sphinx.html
%%PORTDOCS%%%%DOCSDIR%%/sphinx.txt