aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2011-05-10 04:08:23 +0800
committerthierry <thierry@FreeBSD.org>2011-05-10 04:08:23 +0800
commit7da1e3c7b7f1ed7ef08d0aa393b650130b5382db (patch)
tree04e5e133334074c472114164cbffe890795033d6 /textproc
parentbc9745d694ba88a72be9359e3d041b7a07cefcb8 (diff)
downloadfreebsd-ports-gnome-7da1e3c7b7f1ed7ef08d0aa393b650130b5382db.tar.gz
freebsd-ports-gnome-7da1e3c7b7f1ed7ef08d0aa393b650130b5382db.tar.zst
freebsd-ports-gnome-7da1e3c7b7f1ed7ef08d0aa393b650130b5382db.zip
Fix compilation with Clang (patch submitted by rdivacky).
Since I'm there, pet portlint.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/aspell/Makefile4
-rw-r--r--textproc/aspell/files/patch-cxx-clang.patch58
2 files changed, 60 insertions, 2 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 2c0a28b3f4e5..30b13f95e6e2 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -28,8 +28,8 @@ CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-static
PTHREAD_CFLAGS= # Disable threading
PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD= yes
diff --git a/textproc/aspell/files/patch-cxx-clang.patch b/textproc/aspell/files/patch-cxx-clang.patch
new file mode 100644
index 000000000000..cf7d6c42c1a6
--- /dev/null
+++ b/textproc/aspell/files/patch-cxx-clang.patch
@@ -0,0 +1,58 @@
+--- common/posib_err.hpp 2004-12-17 09:23:33.000000000 +0100
++++ common/posib_err.hpp 2011-05-09 19:46:45.000000000 +0200
+@@ -158,6 +158,16 @@
+ void del();
+ };
+
++ template <>
++ class PosibErr<void> : public PosibErrBase
++ {
++ public:
++ PosibErr(const PosibErrBase & other)
++ : PosibErrBase(other) {}
++
++ PosibErr() {}
++ };
++
+ template <typename Ret>
+ class PosibErr : public PosibErrBase
+ {
+@@ -186,16 +196,6 @@
+ Ret data;
+ };
+
+- template <>
+- class PosibErr<void> : public PosibErrBase
+- {
+- public:
+- PosibErr(const PosibErrBase & other)
+- : PosibErrBase(other) {}
+-
+- PosibErr() {}
+- };
+-
+ //
+ //
+ //
+--- common/vector.hpp 2011-05-09 19:51:59.000000000 +0200
++++ common/vector.hpp 2011-05-09 19:51:54.000000000 +0200
+@@ -24,7 +24,7 @@
+ this->push_back(t);
+ }
+ void append(const T * begin, unsigned int size) {
+- insert(this->end(), begin, begin+size);
++ this->insert(this->end(), begin, begin+size);
+ }
+ void append(const T * begin, const T * end) {
+ insert(this->end(), begin, end);
+--- common/hash.hpp 2011-05-09 19:52:05.000000000 +0200
++++ common/hash.hpp 2011-05-09 19:51:35.000000000 +0200
+@@ -318,7 +318,7 @@
+ : Base(s, Parms(h,e)) {}
+ data_type & operator[](const key_type & k)
+ {
+- return (*((insert(value_type(k, data_type()))).first)).second;
++ return (*((this->insert(value_type(k, data_type()))).first)).second;
+ }
+ };
+